Remove All Ads from XDA

 View Poll Results: Have you had an issue with "phantom" headset button presses?

3 Vote(s)
6 Vote(s)

[Q] Anyone had this problem with TMO HTC One + headset?

269 posts
Thanks Meter: 33
By ERamseth, Senior Member on 7th August 2013, 02:53 PM
Post Reply Email Thread
EDIT: Moderators, please feel free to move this thread to the troubleshooting/Q&A forum. I didn't realize it might belong there... Sorry!

OK so I got a new HTC One and so far I love it in all aspects except... the following:

With a headset plugged in to the headphone jack (earbuds with in-line mic and button) any amount of jostling or rotation of the plug in the jack causes my phone to skip songs, stop playing music, and begin redialing the last call in my call log. This issue makes the phone practically unusable for listening to music, as even the slightest shaking of the plug (i.e. from phone in pocket while walking, movement of headphone cord from turning head left or right while sitting still, etc) causes problems.

I thought it was a problem with the individual device I got so T-Mobile was nice enough to send me a new HTC One...

And it has the exact same problem.

I have tried several different headsets with button and mic. Notably, all of the headsets with mic I've tried all work flawlessly on all other devices.

Has ANYONE had this problem?

Note that I Intend to record a video of the problem for evidence, but I'm pretty convinced its a design flaw in the HTC One.

At this point I have all intention to go with a different device, as much as that pains me to say (probably the Xperia Z)

EDIT2: After some experimentation, I have discovered the problem. It is a ridiculous design flaw on the part of HTC. I will post pictures later along with videos. In theory it can be remedied with a new set of headphones of a certain style or possibly some electrical tape or other insulating material, but I really don't think that should be a requirement of using the HTC One.

EDIT4: See here for my post on reddit with a description of what I believe to be the cause of this problem:

And here is a link directly to the photo album on imgur with descriptive captions:
8th August 2013, 11:59 AM |#2  
Senior Member
Thanks Meter: 7
i just picked up a set of ear bud n mic headphones today and played music and did voice commands with it today and had no issues but it was a short period of time...i will try to replicate ur issue and report back later today.
8th August 2013, 12:26 PM |#3  
Sieze's Avatar
Senior Member
Flag somewhere in the middle of california
Thanks Meter: 44
its a issue with something of htc software i believe. it was doing similar with my skullcandy ink'd second gens.

i looked into it a lil but not alot. but it seems only certain headset/earbud combos work properly. i really dont know why theyd have it like that. but for me i had to play around with the mic button and what not.
8th August 2013, 07:39 PM |#4  
Flag Dumfries
Thanks Meter: 0
Donate to Me
It's the head set I have earbuds and soul, soul works fine

Sent from my HTC One using Tapatalk 2
8th August 2013, 11:52 PM |#5  
Junior Member
Flag Columbus
Thanks Meter: 1
I've run into this problem on other phones before, but it was always the 3.5mm jack. Either it was tarnished or the case/jack design combo was causing it to not seat fully. Check very closely that the jack is fully seated and maybe try with another set before condemning the jack in the phone as bad.
12th August 2013, 03:31 AM |#6  
OP Senior Member
Thanks Meter: 33
I believe I have diagnosed the cause of this and other problems. Please see the OP for links to photo album with descriptions.
15th August 2013, 12:43 AM |#7  
Junior Member
Thanks Meter: 0
I purchased mine back in june and never had this problem. Ive used 2 pairs of headphones with the device (some $5 kyocera promo headset from when I worked at metropcs and a pair of Sony MDR-XB500). Only thing I could think of would be faulty software/hardware (phone jack) combination.
18th August 2013, 06:52 AM |#8  
user1511's Avatar
Flag Tehran
Thanks Meter: 13
Originally Posted by LifeEscalade

I purchased mine back in june and never had this problem.

yeah , it's right.
20th August 2013, 03:11 PM |#9  
Senior Member
Thanks Meter: 20
I have this very issue on my HTC one Since my wife's HTC one doesn't experience it with the same headphones I just concluded it was some tolerances that were off on mine I mainly use Bluetooth so I didn't feel it was a big enough issue to return. I had originally searched to see if it was a widespread issue, but could not find any others who had it.
20th August 2013, 08:55 PM |#10  
Senior Member
Thanks Meter: 13
I have not had the problem, either with a headset or an AUX cable I use for my car stereo. The headset jack on mine fits very snug and the plug does not touch the housing except maybe a very small area where the lip is metal.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes