FORUMS
Remove All Ads from XDA

[MOD][Xposed] Fix talkback issues

1,080 posts
Thanks Meter: 5,548
 
Post Reply Email Thread
Requires Xposed Framework!

You're using accessibility settings for something like Dynamic Notifications. You scan for Wi-Fi and you get "Scan finished", you're playing a video, and you can't hide the UI.

Issues fixed by this mod:
  • Doing a Wi-Fi scan in Settings makes the device speak "Scan finished".
  • Playing a video on the Samsung Galaxy S4 with accessibility enabled prevents the UI from being hidden when the video is clicked.
  • The device speaks "Folder opened/closed" when a folder is opened/closed on 4.1.2 devices.

This mod fixes those.
Know some more of these? Post them here and I'll try to kill them with fire.

Compatibility:
Tested only with the Galaxy S4, might work with other devices.

Source:
The mod is open source, and licensed under GPLv3: https://github.com/MohammadAG/Xposed...alkback-issues

Download:
http://mohammadag.xceleo.org/public/...Issues_1.1.apk

Support development:
If you found this mod useful, consider donating with PayPal.
The Following 6 Users Say Thank You to MohammadAG For This Useful Post: [ View ] Gift MohammadAG Ad-Free
 
 
3rd September 2013, 05:32 PM |#2  
@xDeepS's Avatar
Senior Member
Flag Dubai
Thanks Meter: 202
 
Donate to Me
More
If this works, great job. I had these issues too but they seem to have somewhat been solved by Samsung. I mean the bug exists but the havoc it caused has been gone.

Now whenever you enable an accessiblity provider it turns off Multiview and other S Features. But you can re-enable them and they work.

You should really post this at Samsungs developer bug/thread too. I am sure many developers would be thankful.

http://developer.samsung.com/forum/t...ices/77/204387
4th September 2013, 01:55 PM |#3  
Chewee91's Avatar
Member
Thanks Meter: 6
 
More
Hi !

Thx for this mod, works great for wifi numérisation issu, but doesn't work for stock browser, same issu ("page is charging etc"...). I'm on stock mdm root...

Only fix i have is freezing talkback and all Samsung tts stock apps...

Can you fix it ?
4th September 2013, 03:58 PM |#4  
OP Inactive Recognized Developer
Flag Jerusalem
Thanks Meter: 5,548
 
Donate to Me
More
Quote:
Originally Posted by SilentRazor

If this works, great job. I had these issues too but they seem to have somewhat been solved by Samsung. I mean the bug exists but the havoc it caused has been gone.

Now whenever you enable an accessiblity provider it turns off Multiview and other S Features. But you can re-enable them and they work.

You should really post this at Samsungs developer bug/thread too. I am sure many developers would be thankful.

http://developer.samsung.com/forum/t...ices/77/204387

Fixing those issues shouldn't be hard, I'll get a Galaxy Note 2 and work on it.





Quote:
Originally Posted by Chewee91

Hi !

Thx for this mod, works great for wifi numérisation issu, but doesn't work for stock browser, same issu ("page is charging etc"...). I'm on stock mdm root...

Only fix i have is freezing talkback and all Samsung tts stock apps...

Can you fix it ?

Which device? My S4 doesn't say anything when using the stock browser.

Sent from my GT-I9500 using xda app-developers app
4th September 2013, 06:40 PM |#5  
Chewee91's Avatar
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by MohammadAG

Which device? My S4 doesn't say anything when using the stock browser.

Sent from my GT-I9500 using xda app-developers app

International s4: GT I9505, mine say toooo much things, as long i'm using accessibility for some apps, with stock tts not frozen...

I have a solution but you are a so productive xposed dev, i can't send you some...riddle
5th September 2013, 12:47 PM |#6  
Member
Thanks Meter: 6
 
More
Can someone confirm if this is working please?
5th September 2013, 04:43 PM |#7  
cmd512's Avatar
Senior Member
Flag Shanghai
Thanks Meter: 845
 
More
**Removed**
5th September 2013, 05:18 PM |#8  
OP Inactive Recognized Developer
Flag Jerusalem
Thanks Meter: 5,548
 
Donate to Me
More
Quote:
Originally Posted by cmd512

I can confirm it screwed with the camera shutter sounds, absolutely bizarre:

1) I had the feature enabled in the CSC others.xml file to turn off shutter sounds, and did so through camera settings.
2) I also deleted the appropriate files from /system/media/audio/ui
3) Was working fine, zero shutter or focus sounds. But, after installing this module, the sounds all comeback, even though the sound files have been deleted!

Uhh, it can't do that. Seriously, it can't.

Check what else you did and blame that

Sent from my GT-I9500 using xda app-developers app
5th September 2013, 05:48 PM |#9  
cmd512's Avatar
Senior Member
Flag Shanghai
Thanks Meter: 845
 
More
**Removed**
6th September 2013, 05:01 PM |#10  
Member
Thanks Meter: 6
 
More
This may sound like a stupid question, but exactly does this mod do? what I want it to do is: when i turn a service on in accessibility settings, it automaticly turns talkback on although i ask it to turn that on.

Will this mod fix this?
6th September 2013, 05:15 PM |#11  
OP Inactive Recognized Developer
Flag Jerusalem
Thanks Meter: 5,548
 
Donate to Me
More
Quote:
Originally Posted by idi_idi

This may sound like a stupid question, but exactly does this mod do? what I want it to do is: when i turn a service on in accessibility settings, it automaticly turns talkback on although i ask it to turn that on.

Will this mod fix this?

Yes, in a way, the only two issues I fixed are in the first post, you can mention any other issues with your device model and I'll try to fix those.

Sent from my GT-I9500 using xda app-developers app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes