FORUMS

Removing T-Mobile CRAPPS from Huawei U8730

62 posts
Thanks Meter: 28
 
By gblues, Member on 15th September 2013, 10:01 PM
Post Reply Email Thread
Hello fellow XDAers,

My wife replaced her Samsung Gravity Smart with the T-Mobile MyTouch Q, AKA the Huawei U8730 (not the older LG C800 model w/ the same name). She gave me the task of cleaning the junk APKs off of it to de-clutter it.

Rooting the phone was the first task. This method worked perfectly for me without any fuss (the app will return error 64, but after installing Superuser and rebooting, I had root access). I was able to use Titanium to remove much of the crap ware, but the most annoying bits gave the error "cannot find APK." Weird.

After digging around, I took an inventory of the apps in /data and /system.

The T-Mobile junk wasn't there.

I threw busybox on the phone and used the 'find' command, and I found where the apps were hiding: /cust/t-mobile/us/apps, which is a loopback-mounted ext3 partition. I tried to remount it read/write, but got 'permission denied' error. I figured something had the filesystem locked, so I ended all the apps that were running and tried again, but no luck.

However, I was able to remount the volume that held the ext3 image file read/write. It mounts to the /.cust_backup directory.

IMPORTANT NOTE: For those who will be following these steps themselves, at this point you will want to make sure to go into the Applications manager and uninstall any updates downloaded for the crapware you are going to remove. I will explain why below. It's not absolutely critical, but it will save you some head-scratching.

I remounted the partition read/write, grabbed the image file (located in /.cust_backup/image/cust.img), and uploaded the image file to a linux server.

On the linux server, I mounted the image, nuked the unwanted APKs, and unmounted the filesystem.
I created a backup of the original cust.img file, then overwrote the one in /.cust_backup/image
Last step was to reboot the phone, and most of the junkware was gone.

Here's where the head-scratching came in. A couple of the apps were still there, and I didn't know why. I double-checked the phone, and the APKs were in fact deleted. Then I realized: the app had received an update and I was seeing the update. When I uninstalled the update, the uninstall "failed" but the icon still disappeared. However, I had to reboot the phone again to fully remove it.

So, here's the process in a nutshell:

1. Uninstall all app updates for the crapware you plan to remove
2. Root the phone using This method .
3. copy down /.cust_backup/images/cust.img
4. Using a linux system, mount cust.img as a loopback device, then delete the unwanted APKs (they will be in t-mobile/us/apps)
5. Unmount the image (this writes your changes back into the cust.img you mounted in step #3)
6. On the phone, remount /.cust_backup r/w
7. overwrite /.cust_backup/images/cust.img with the modified version
8. Reboot the phone

That's it! Enjoy your uncluttered phone!
24th February 2014, 06:45 PM |#2  
Junior Member
Thanks Meter: 0
 
More
I know it's been a while since the original post, but I was wondering if OP has had any problems with the phone since then, or if anyone else has tried this with the Huawei u8730 and had success. My wife also wants all this crap removed from her phone, but she would probably murder me if I bricked it in the process.

Thanks!
14th May 2020, 04:01 PM |#3  
Junior Member
Thanks Meter: 1
 
More
Just on a side note here as I'm still using this device. How did you get around the non-working tethering on this device? Both the USB and Wifi hotspot won't work unless you've subscribed to the T-Mobile Smartphone Mobile HotSpot app option on your account? Mine is unlocked and being used with another carrier, but only recently wanted to tether to it so I can't figure out how to correct this one. Also still looking around for any working custom ROM for this. Thx.
Post Reply Subscribe to Thread

Tags
huawei, mytouch q u8730, u8730

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes