FORUMS
Remove All Ads from XDA

[FAQ] Asus T100: Installing custom OS (android/ubuntu/*nix/Windows 7/Windows 8 x64)

1,000 posts
Thanks Meter: 496
 
By paperWastage, Senior Member on 27th October 2013, 05:40 AM
Post Reply Email Thread
29th October 2013, 02:51 AM |#11  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
<instructions below should be complete

got ubuntu 13.10 to boot to command prompt (with bootia32.efi and grub.cfg fixes below)

Rufus (GPT for UEFI + FAT + 64 kb+ 13.10 desktop x64 as bootable disk using ISO Image)

Note:

Good behavior:
After you select "Try Ubuntu" in grub, screen goes to blank, (?might appear as well) usb light disappears... wait < 30s, the screen should then show the logs and then cmd line)
Bad Behavior:
After you select "Try Ubuntu" in grub, screen goes to blank, then the grub menu reappears (but nothing happens when you press arrow keys). (?might appear as well) usb light stays lighted. if you wait >5 minutes, nothing happens. just force reboot machine (hold power button), and reboot into windows, then UEFI and try again
/boot/grub/grub.cfg - replace with the text below

Code:
if loadfont /boot/grub/font.pf2 ; then
	insmod efi_gop
	insmod efi_uga
	insmod gfxterm
	terminal_output gfxterm
fi

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

menuentry "Try Ubuntu without installing" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper text noacpi nomodeset --
	initrd	/casper/initrd.lz
}
menuentry "Install Ubuntu" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash --
	initrd	/casper/initrd.lz
}
menuentry "OEM install (for manufacturers)" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true --
	initrd	/casper/initrd.lz
}
menuentry "Check disc for defects" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  boot=casper integrity-check quiet splash --
	initrd	/casper/initrd.lz
}


(changes in grub is to disable efifb which causes screen flickering/corruption - video=vesa: off doesn't work, probably because vesa IS the fallback driver)

then boot. After you get to command line, remove the vesa_drv.so module from /usr/lib/xorg/modules/drivers/, type startx

touchscreen works on x64 13.10. still haven't had time to make x86 ISO work with bootia32.efi GRUB
The Following 2 Users Say Thank You to paperWastage For This Useful Post: [ View ] Gift paperWastage Ad-Free
 
 
29th October 2013, 05:27 PM |#12  
Senior Member
Flag Upstate NY
Thanks Meter: 342
 
More
For Android-x86 without EFI support, I wonder if this method courtesy of Tyler Swindell on Youtube would work. This is what he used to get Android-x86 booting on the Surface.

Quote:

Alright guys, this is the Surface Pro running Android-x86. It was something we all saw coming. Past 2
nights, I have been trying hard to get Android-x86 to run on my Surface Pro since I saw how amazing it
ran on my desktop PC. If it would just boot, I could see just how great Android is on the Surface Pro. So
I got it to boot, and it was just as great as I expected it to be.
So why didn't it boot? I had Secure Boot off. Ubuntu boots, Windows 7 boots. Well what do all these
operating systems have in common? Their installers all include both BIOS and EFI boot loaders. What is
interesting about the Surface Pro is the UEFI chip was designed without legacy BIOS support. There is
no way to boot a BIOS-based boot loader.
I thought about it and how Ubuntu boots. I checked the files and I saw a EFI-based Grub boot loader.
All I had to do was drop in Android's files into an Android directory and add the boot entries. This
worked and Android booted thanks to the EFI-based Grub boot loader.
Everything works except no connectivity, no Wi-Fi or Bluetooth. Also the buttons could have better
functions such as the Windows button or the power button which just brings up a power menu. Overall
it's a great start, it's booting, and the drivers are there for mostly everything. It's fantastic.
This tutorial can be drastically simplified and improved. Keep in mind it was just to get it to work.
1. Download Android-x86 ISO and Ubuntu 12.10 x64 ISO.
2. Format a USB flash drive.
3. Using LiLil USB Creator, copy Ubuntu ISO to flash drive.
4. Create Android directory in flash drive. Extract Android ISO, copy initrd.img, kernel, ramdisk.img,
system.sfs to the Android directory.
5. Modify boot/grub/grub.cfg to add these entries:
submenu "Android" {
menuentry "Android" --class android --class linux --class os {
linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 quiet video=1920x1080
dpi=145 i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/
initrd /android/initrd.img
}
menuentry "Android text output" --class android --class linux --class os {
linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 video=1920x1080 dpi=145
i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/
initrd /android/initrd.img
}
menuentry "Android debug mode" --class android --class linux --class os {
linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 video=1920x1080 dpi=145
i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/ DEBUG=1
initrd /android/initrd.img
}
}
6. Turn off Secure Boot and boot Android. Enjoy.



Sent from my DROID BIONIC using Tapatalk
The Following User Says Thank You to spunker88 For This Useful Post: [ View ] Gift spunker88 Ad-Free
29th October 2013, 05:48 PM |#13  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
Quote:
Originally Posted by spunker88

For Android-x86 without EFI support, I wonder if this method courtesy of Tyler Swindell on Youtube would work. This is what he used to get Android-x86 booting on the Surface.





Sent from my DROID BIONIC using Tapatalk

that might work, forcing android-x86 to boot via grub.. thanks

been using android-ia, which doesn't use grub... uses another efitool, need to play with both android-x86 and android-ia later tonight
29th October 2013, 07:32 PM |#14  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by paperWastage

that might work, forcing android-x86 to boot via grub.. thanks

been using android-ia, which doesn't use grub... uses another efitool, need to play with both android-x86 and android-ia later tonight


Picking up on our conversation from SlickDeals.. I actually ended up buying one of these things and I was able to get an external hard drive recognized just by plugged into my usb OTG cable -- in windows. I even tried a USB mouse which worked perfectly.
30th October 2013, 01:26 AM |#15  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
Quote:
Originally Posted by Deltido

Picking up on our conversation from SlickDeals.. I actually ended up buying one of these things and I was able to get an external hard drive recognized just by plugged into my usb OTG cable -- in windows. I even tried a USB mouse which worked perfectly.

yeah, my usb otg cable works now in windows (detects flash drive). no idea why it didn;t work before (maybe I unpluged it too early while it was detecting/installing the usb driver?)
30th October 2013, 02:51 AM |#16  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
got android to boot up, but uglily

need 2 flash drives, and a USB-OTG cable(to be able to connect using the microUSB port)... a USB-hub should work too

(basically, you're piggying back off the ubuntu grub2 bootloader, to load the android kernel and other stuff)
  • used my (existing & currently working) ubuntu 13.10 x64 bootable USB (made via Rufus, GPT partition with bootia32.efi fix)
    copied the contents of android-x86-4.3-20130725.iso into the USB:/android/
    modified contents of grub.cfg as per the post by spunker88 with some changes to the resolution
  • second flash drive had dd if=android-x86-4.3-20130725.iso of=/dev/sdb1
    without this second flash drive, the android boot sequence stops at "Detecting Android-x86" and "VFS: could not find a valid V7 on sda1". probably something to do with android/kernel not liking the first drive having FAT instead of ext2/3/4


grub.cfg - add to the end, and select this during grub

Code:
submenu "Android" {
 menuentry "Android" --class android --class linux --class os {
 linux /android/kernel root=/dev/ram0 androidboot.hardware=x86 video=1366x768 DEBUG=1 SRC=/android/ 
 initrd /android/initrd.img
 }
 }


boot into USB, then grub, then select android.

android crashes to command line. forcing it to start (type exit twice), leads to the default android start screen, and eventually this

it is SUPER LAGGY. not usable



The Following 4 Users Say Thank You to paperWastage For This Useful Post: [ View ] Gift paperWastage Ad-Free
30th October 2013, 04:49 PM |#17  
Member
Thanks Meter: 36
 
More
Quote:
Originally Posted by paperWastage

got android to boot up, but uglily

need 2 flash drives, and a USB-OTG cable(to be able to connect using the microUSB port)... a USB-hub should work too

(basically, you're piggying back off the ubuntu grub2 bootloader, to load the android kernel and other stuff)

  • used my (existing & currently working) ubuntu 13.10 x64 bootable USB (made via Rufus, GPT partition with bootia32.efi fix)
    copied the contents of android-x86-4.3-20130725.iso into the USB:/android/
    modified contents of grub.cfg as per the post by spunker88 with some changes to the resolution
  • second flash drive had dd if=android-x86-4.3-20130725.iso of=/dev/sdb1
    without this second flash drive, the android boot sequence stops at "Detecting Android-x86" and "VFS: could not find a valid V7 on sda1". probably something to do with android/kernel not liking the first drive having FAT instead of ext2/3/4


grub.cfg - add to the end, and select this during grub

Code:
submenu "Android" {
 menuentry "Android" --class android --class linux --class os {
 linux /android/kernel root=/dev/ram0 androidboot.hardware=x86 video=1366x768 DEBUG=1 SRC=/android/ 
 initrd /android/initrd.img
 }
 }


boot into USB, then grub, then select android.

android crashes to command line. forcing it to start (type exit twice), leads to the default android start screen, and eventually this

it is SUPER LAGGY. not usable



Progress!!

Although its unusable, it's nice to see android on this device. So what do you think needs to be done to get android usable on this?
30th October 2013, 11:40 PM |#18  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
Quote:
Originally Posted by costcutter

Progress!!

Although its unusable, it's nice to see android on this device. So what do you think needs to be done to get android usable on this?

for both ubuntu/android, first steps (since it's booting) is to get the graphics driver working. right now, ubuntu is using fbdev and android is (i think) using efifb... both are running at 800x600 and laggy....

either I fix the VESA bug, or find the correct intel driver for the new Bay Trail IGP and use it


then, install ubuntu/android properly on the device, and then debug the rest (instead of through a live USB where changes would not persist from every reboot)
31st October 2013, 12:37 AM |#19  
pastime1971's Avatar
Senior Member
Flag Plesanton, CA
Thanks Meter: 1,091
 
More
I'm trying with Fedora 20 alpha, but not much luck so far.
Got the grub2-efi to work with your tutorial (and some digging), but once I start installing Fedora, it seems to freeze.
Gonna try ubuntu over the weekend.
The Following User Says Thank You to pastime1971 For This Useful Post: [ View ] Gift pastime1971 Ad-Free
31st October 2013, 02:56 AM |#20  
OP Senior Member
Flag NJ
Thanks Meter: 496
 
More
probably the vesa bug as well (if you are trying to install via gui)

attempting to fully install ubuntu on system and boot from it.... the bootia32.efi / bootx64.efi / grubx64.efi is making a mess here...

managed to get Windows Bootloader AND ubuntu grub listed as boot options... grub has problems though, dumps me into grub shell


EDIT: Think it;s easiest for me to try installing EFI Shell, and tinker from there
http://sourceforge.net/apps/mediawik...itle=Efi-shell

EDIT2: For Windows 8 64-bit, the error is "This 64-bit application couldn't load because your PC doesn't have a 64-bit processor"

Looks like we need to enable Virtualization in the UEFI/BIOS... but there isn't such an option (the cpu Z3740 does support VT-x)
GuestX0011
31st October 2013, 08:31 AM |#21  
Guest
Thanks Meter: 0
 
More
Quote:
Originally Posted by paperWastage

probably the vesa bug as well (if you are trying to install via gui)

attempting to fully install ubuntu on system and boot from it.... the bootia32.efi / bootx64.efi / grubx64.efi is making a mess here...

managed to get Windows Bootloader AND ubuntu grub listed as boot options... grub has problems though, dumps me into grub shell


EDIT: Think it;s easiest for me to try installing EFI Shell, and tinker from there
http://sourceforge.net/apps/mediawik...itle=Efi-shell

EDIT2: For Windows 8 64-bit, the error is "This 64-bit application couldn't load because your PC doesn't have a 64-bit processor"

Looks like we need to enable Virtualization in the UEFI/BIOS... but there isn't such an option (the cpu Z3740 does support VT-x)

I would love to help but have not been able to get my hands on a device yet sadly. When I do get it I can help test theories here aswell. I will also subject it to the Computer engineering class at my university. lol
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes