FORUMS
Remove All Ads from XDA

[RECOVERY][R819] TWRP 2.8.3.0 touch recovery [2014-12-22]

1,705 posts
Thanks Meter: 13,533
 
Post Reply Email Thread
Team Win Recovery Project 2.x, or twrp2 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.

Phone look:


Tablet look:


CHANGELOG for 2.8.3.0:

-MTP will now tell the host PC that storage is removed instead of disabling MTP completely
-MTP will now report the correct max file size based on the file system in use to the host PC (may fix transfer of large files)
-Update and improve fix permissions and make fixing contexts optional
-Update SuperSU in TWRP to 2.40 and update install process
-Make TWRP work properly on AArch64 (Nexus 9 is now built in true 64-bit binaries and libraries)
-Attempt to set correct permissions and contexts on all files placed in storage so backups will show in Android
-Fix kernel panic during MTP start on some devices
-Support unicode fonts on devices with True Type Font support
-Fix slider value not showing sometimes (vibration settings page)
-Toggle MTP off during adb sideload to set correct USB IDs
-Reduce library requirements for 5.0 L decrypt
-Other minor fixes and improvements

Note: Starting with TWRP 2.8.2.0 and higher, adb sideload uses a new sideload method originally implemented in AOSP recovery. You will need the latest adb binaries to use sideload in these newer versions of TWRP. The version required is 1.0.32. You can find the version by running "adb version" on your computer. The new sideload feature no longer stores the zip on your device. Instead, a fuse file system is created in RAM and the zip is streamed from your computer. This puts less wear and tear on storage and ensures that large zips will not fill up all of your RAM. The sideload may spit an error on your PC side, but the zip should install just fine on your device.

CHANGELOG for 2.8.2.0:
-Pull in all changes from Android 5.0 lollipop into TWRP
-Add decrypt support for Android 5.0 lollipop encrypted partitions including automatic decrypt when the default_password is in use
-Revert some changes to exFAT that were breaking exFAT support on some devices
-Other minor fixes and updates

Note: At this time we do not have a GUI representation for pattern unlock. You can still decrypt patterns though by translating the pattern dots to numbers. The pattern dots correspond to numbers in the following pattern:
1 2 3
4 5 6
7 8 9

So an upper-case L would translate to a password of 14789 entered on the keyboard. Eventually we plan to add a proper pattern unlock to TWRP but it is a relatively low priority at this point.

CHANGELOG for 2.8.1.0:
-MTP fixes and improvements - you can now copy zips to the root of storage - thanks to _that
-TrueType Font support - optional as it takes up a decent amount of space so may not be available on all devices - thanks to Tassadar
-Temperature support - thanks to bigbiff
-Various other bugfixes and tweaks

Over the course of the last year or so, bigbiff has worked to migrate various Java functions from Android's MTP implementation to bring you a fully C++ based MTP implementation that allows you to transfer files to both emulated storage and Micro SD cards. It's confirmed to work on various Nexus devices but we may have to make some changes on other devices to keep Windows happy. Windows is very picky about USB IDs and its drivers. We have tested it on Windows 7 and 8 as well as Ubuntu 14.04 Trusty. MTP is enabled by default, but we do toggle it off and on automatically during certain operations such as if you choose to wipe a storage partition. You can enable or disable MTP under the mount menu in TWRP. For more about what MTP is here.

Note: Due to a weird bug with our MTP setup, you cannot copy a zip file to the root of storage with Windows. You can change the .zip to something else like .txt and then copy it to the root and rename the file back to .zip once it's copied to the device. You can also copy the zip into any subfolder.

Command line support is also now available. You can perform various OpenRecoveryScript commands via the adb shell. Depending on what you are doing you may wish to do a "twrp set tw_mtp_enabled 0" and then reboot to prevent the MTP auto toggle from killing your adb interface. You can use this option to create and restore backups, wipe, install zips, and more. Via adb shell, type twrp followed by a space then enter the OpenRecoveryScript command and hit enter. Find more OpenRecoveryScript commands here.

CHANGELOG for 2.7.1.0:
-Add GUI option to change or repair file systems on individual partitions. The change is destructive so backup your data including internal sdcard first. This option should make it a little easier to migrate a device from ext4 -> f2fs, for instance. You will find this option under Wipe -> Advanced Wipe, then select only one partition and then press the Repair or Change File System button. If a developer has added f2fs support for your device and we don't have it in TWRP, please contact me via PM to arrange for it to be added.
-Various bugfixes to backup and restore
-Improvements to USB storage handling
-Added a class to search for files to make finding the correct brightness file automatic in most cases
-Various other bugfixes and tweaks

DOWNLOAD:
Most devices can be updated quickly and easily with the TWRP Manager app:
Play Store Link
1) Install TWRP Manager from the Play Store
2) Open TWRP Manager and provide root permissions
3) Hit Advanced->Install Recovery
4) Verify the correct device name on your screen then press Install Recovery if the correct device is showing
OR:
You can find more information and download links on our website!

BUGS:
If you have found a bug, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, your best bet is to PM me directly, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

SUPPORT:
Live support is available via #twrp on Freenode with your IRC client or just click this link.
The Following 9 Users Say Thank You to Dees_Troy For This Useful Post: [ View ]
 
 
30th October 2013, 08:50 PM |#2  
Dees_Troy's Avatar
OP Senior Recognized Developer
Flag KC MO
Thanks Meter: 13,533
 
Donate to Me
More
Reserved
Device Page on our website:
http://www.teamw.in/project/twrp2/203

Downloads:
http://techerrata.com/browse/twrp2/R819
The Following 3 Users Say Thank You to Dees_Troy For This Useful Post: [ View ]
6th November 2013, 10:20 AM |#3  
Member
Thanks Meter: 1
 
More
In my OPPO R819 Goomanager says "No recoveries were found for your device"
6th November 2013, 08:38 PM |#4  
Senior Member
Thanks Meter: 69
 
More
This is great news. Finally a custom recovery for R819!
10th November 2013, 10:01 AM |#5  
Senior Member
Thanks Meter: 69
 
More
Download img file here
http://techerrata.com/browse/twrp2/R819

Flash with MobileUncle MTK tools found from Play Store
https://play.google.com/store/apps/d...euncle.toolbox

Do this with your OWN responsibility! I am not responsible if you screw around and brick your phone!

1. Put downloaded IMG file in root of SDcard
2. Open Mobileuncle Tools
3. Choose 'Recovery Update'
4. On the top of the list should show the IMG file on you SD card that you downloaded.
5. Tap it and confirm with OK to flash.
The Following User Says Thank You to samusalo For This Useful Post: [ View ] Gift samusalo Ad-Free
28th November 2013, 08:33 PM |#6  
vickfred's Avatar
Member
Flag Sofia
Thanks Meter: 30
 
More
Can I flash Stock Recovery Back
I have installed TWRP 2.6.3.0, and I have used it to make Backups of the whole ROM.
However, I tried to install the ColorOS Beta 1.0.0 and found out it would not install, reason unknown.
So I used TWRP to clean the partitions /Data, /System, /Cache etc. and then installed successfully the complete ROM for Oppo R819 - R819AS-11.A.07-OTA-INT-007-all-SVN4875-wipe.zip since this is the only available until now. Perfect installation.
The system says that there is a downloadable OTA Update Stock Oppo OS 4.2.1 (Build R819AS_11_A.09_131010). I downloaded it, clicked the greenish-blue button "Install", but the phone is not able to install it, obviously, because the Stock Recovery is different, and the instructions are for it alone. Is there a way to return back to Stock Recovery, despite it looks so bare and ugly, just to update the system?! Or is there another way to do it? Maybe if I knew where is stored the downloaded OTA update, I could flash it via TWRP...
29th November 2013, 06:29 AM |#7  
ccav2000's Avatar
Senior Member
Flag Manga Cafe
Thanks Meter: 1,128
 
More
Hmm, strange, I installed Color OS with TWRP. To change to stock recovery all you need is to flash a stock rom, it overwrites the recovery during the install process.
29th November 2013, 08:26 PM |#8  
vickfred's Avatar
Member
Flag Sofia
Thanks Meter: 30
 
More
TWRP 2.6.3.0
Sorry, there is no logic in that. I did install Stock ROM, the complete ROM for Oppo R819 - R819AS-11.A.07-OTA-INT-007-all-SVN4875-wipe.zip since this is the only available until now. Perfect installation. Via TWRP, of course. Nothing can change the recovery, it stays the same, it is on its own partition, most notably, so that nothing could mess with it. Simple principle - if you are in Recovery, you cannot destroy Recovery itself.

Thanks to a person, who has a phone Oppo Find 5, but told me the problem is with the root privileges, I managed to get past the problem. I preserved the same TWRP 2.6.3.0 Recovery, since I have no other, and I can't change it. I opened the SuperSU program, and checked inside it to "Disable", temporarily. I did not use the "Permanent Uninstall Root" option, which also exists in it. I rebooted to Recovery, and in TWRP wiped the Cache & Dalvik partitions. After that I chose "Install" and the ColorOS 1.0.0 ROM installed perfectly well. It is beautifull and shiny!
The Following User Says Thank You to vickfred For This Useful Post: [ View ] Gift vickfred Ad-Free
16th December 2013, 10:24 PM |#9  
Senior Member
Flag OnePlus X
Thanks Meter: 140
 
More
Where can I find the stock recovery to flash it back in case I want to revert? Or can anyone give me instructions on how to backup the stock recovery before flashing TWRP?
The Following User Says Thank You to mundano For This Useful Post: [ View ] Gift mundano Ad-Free
25th December 2013, 09:03 AM |#10  
distan7's Avatar
Senior Member
Flag Jakarta-Indonesia
Thanks Meter: 148
 
More
Quote:
Originally Posted by mundano

Where can I find the stock recovery to flash it back in case I want to revert? Or can anyone give me instructions on how to backup the stock recovery before flashing TWRP?

Yeah I'd like to know too. Or perhaps anyone has stock recovery.img for R819 ?

Sent from my R819 using Tapatalk
The Following User Says Thank You to distan7 For This Useful Post: [ View ] Gift distan7 Ad-Free
25th December 2013, 05:21 PM |#11  
vickfred's Avatar
Member
Flag Sofia
Thanks Meter: 30
 
More
Quote:
Originally Posted by distan7

Yeah I'd like to know too. Or perhaps anyone has stock recovery.img for R819 ?
Sent from my R819 using Tapatalk

I have the Stock Recovery from 131010, the file is recovery.img 5,865,472 bytes but it can only be flashed with SP Flash Tool, which is not a thing to recommend to beginners, the Tool needs to have the "MT6589_Android_scatter_emmc.txt". That is why I am afraid to post it plainly, open to anyone, just because they might start experimenting without knowledge and break their Oppo R819. Trust me, if you have installed TWRP Recovery from above, using the MobileUncle Tool, you are safe and well, it is a much better Recovery than the plain Stock one.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes