FORUMS
Remove All Ads from XDA

Stock Android 4.4 KitKat Launcher & Google Apps Extracted

175 posts
Thanks Meter: 173
 
By MyDeSTiNaTe, Senior Member on 2nd November 2013, 07:29 AM
Thread Closed Email Thread
NOTE

1 Just install the apks as a normal app unless you wanna push it to /system/app and make it a system app.

2 It should work for all the devices with Android 4.2 or above.

3 Anyway, if you are on Android 4.1 or below, you may still give it a try if there is no 'error parsing package' occurred.

4 The fix has to be extracted to replace the previous lib under system/lib, do not flash it.

5 If you are pushing the apks to /system/app or replacing the lib, ensure that the permission is set to rw-r--r-- to avoid FC.


Stock Android 4.4 KitKat Launcher --- Here’s what you’ll need to install:

1 PreBuiltGmsCore (Google Play Services 4.0) Download [Mirror]

2 Velvet (Google Search) Download [Mirror]

3 GoogleHome (Google Launcher) Download [Mirror]

UPDATE 1: Google Search Force Close fix:

Long press the home screen, select Settings. Select Voice. Select Language to change the default. Change to another language, for me I choose English – UK. Hit Home. Do a Google Search. Repeat the first three steps. Change back to English – US. (you may have to redo this step every time you restart --- if you experienced FC --- for non-rooted users)

OR

Please extract and replace the /system/lib/libgoogle_recognizer_jni.so with the one downloaded from THIS or THIS LINK. (permanent fix --- for rooted users)

UPDATE 2: "Ok, Google" search feature fix:

If anyone has a problem with the "Ok, Google" search feature, you have to get the English (US) language update. Under "Language and Input" --- "Voice Search"/ "Google Now Settings" --- "Voice", tap "Offline Speech Recognition" --- "All" and tap "English (US)" to update. After it is done, press home and it should be working! If you've cleared data on the app, it'll erase the update and you'll need to do this again.

Google Apps Extracted:

Contact and dialer are not added because they did not work while calculator and map are not added due to parsing error~The apps may not fit every screen perfectly due to different screen resolution

Calendar Download [Mirror]

Clock Download [Mirror]

If you're getting an install prompt instead of the update one, chances are this APK will refuse to install. This happens because this package's pname is com.android.deskclock, and yours is probably com.google.android.clock, so it's not installing as an update but rather as a separate app, and then failing because the same provider name has already been declared. The only way around this would be to freeze/uninstall the stock clock, as far as I can tell, which requires root. You may need to clear data for the Clock app after installation - otherwise it may FC on start.

Email Download [Mirror]

Gmail Download [Mirror]

Keep [(Needs Play Services 4.0) Download [Mirror]

Play Books Download [Mirror]

Play Games Download [Mirror]

QuickOffice Download [Mirror]

Keyboard Download [Mirror]

Hangouts 2 Download [Mirror] Video Call Fix

Wallpaper

Camera Download [Mirror] Photosphere Fix

Gallery Download [Mirror] PHOTO EDITOR DID NOT WORK

Know more about the new Android 4.4: HERE & HERE

All credit goes to:



Google

Luxferro (for the force close fix)

l.m.prowse (for Camera & Gallery)

Myself for digging around I are just a sharer!
The Following 31 Users Say Thank You to MyDeSTiNaTe For This Useful Post: [ View ] Gift MyDeSTiNaTe Ad-Free
 
 
2nd November 2013, 06:29 PM |#2  
Member
Flag in a van down by the river
Thanks Meter: 2
 
More
can extract the dialer and contacts from Android 4.4 kitkat? Or put into a zip to flash? I'm rooted running stock 4.3 (JWR66Y)
2nd November 2013, 06:32 PM |#3  
.Bambino's Avatar
Senior Member
Flag Charm City
Thanks Meter: 847
 
More
Has anyone tried the calculator and clock yet and did not get a parsing error?
2nd November 2013, 07:07 PM |#4  
Junior Member
Thanks Meter: 0
 
More
Fix is not working
Quote:
Originally Posted by .Bambino

Has anyone tried the calculator and clock yet and did not get a parsing error?

1st fix is not working and second is not working because Unable to update offline Recognition data
2nd November 2013, 08:11 PM |#5  
GuyInDogSuit's Avatar
Senior Member
Flag Antelope, CA
Thanks Meter: 1,139
 
Donate to Me
More
Google Keyboard doesn't fit on the screen. Also, someone mentioned the Calculator. Where is that?
2nd November 2013, 08:50 PM |#6  
sayaksark's Avatar
Senior Member
Thanks Meter: 91
 
More
keyboard not fitting the screen
2nd November 2013, 08:54 PM |#7  
Member
Thanks Meter: 4
 
More
I assume the screen recorder can not be used unless on 4.4?
2nd November 2013, 11:29 PM |#8  
Senior Member
Thanks Meter: 15
 
More
My work exchange email quit sending and receiving.
2nd November 2013, 11:52 PM |#9  
tskoze's Avatar
Senior Member
Flag Toronto
Thanks Meter: 168
 
More
Quote:
Originally Posted by GuyInDogSuit

Google Keyboard doesn't fit on the screen. Also, someone mentioned the Calculator. Where is that?

Here you go.
Attached Files
File Type: apk Calculator.apk - [Click for QR Code] (333.4 KB, 2158 views)
The Following User Says Thank You to tskoze For This Useful Post: [ View ] Gift tskoze Ad-Free
3rd November 2013, 12:47 AM |#10  
Junior Member
Flag Cheyenne
Thanks Meter: 0
 
Donate to Me
More
just installed on cleanrom 7 for S3 (4.1.2) just did the language switch from us to uk and back and Google now and home screen work great. Just have to remember to install all three apk's for it to work.
3rd November 2013, 12:54 AM |#11  
Senior Member
Thanks Meter: 57
 
More
Can you change the grid to 4*5 ?

Sent from my GT-I9070 using xda app-developers app
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes