Remove All Ads from XDA

ADATA UD320 32Gb OTG microUSB stick not working

3 posts
Thanks Meter: 0
By awknd_primate, Junior Member on 6th November 2013, 08:23 PM
Post Reply Email Thread
Hey guys! Nice to be here

I've always loved this place 'cause I always found the answers I was looking for but now, fortunately and unfortunately I need to ask for some info more directly.

Well, to put it in a nutshell, I preordered an ADATA UD320 microUSB stick and it doesn't work on my 2nd Gen Nexus 7 that was just updated to Android 4.3.

Oddly, it does work with my Galaxy S2 that's running on Android 4.1.2

Thanks for taking the time to read about my problem!

7th November 2013, 09:58 AM |#2  
Pfeffernuss's Avatar
Senior Member
Flag Wassenaar
Thanks Meter: 1,758
Nexus Media Importer and/or (when rooted) Stickmount don't work?
The Following User Says Thank You to Pfeffernuss For This Useful Post: [ View ] Gift Pfeffernuss Ad-Free
7th November 2013, 11:09 AM |#3  
OP Junior Member
Thanks Meter: 0
Originally Posted by Pfeffernuss

Nexus Media Importer and/or (when rooted) Stickmount don't work?

Well, I just got the Nexus a couple days ago and I don't want to root it for now, but the thing is that ADATA say that the UD320 is Plug and Play and doesn't require anything else. The stick should see the tablet as a host and I should get the message that removable storage was plugged in like I do on my S2.

I would try Nexus Media Importer, but it sucks that I have to use a third party app for something that should work without it. Now, I'm not complaining like a little baby because I truly appreciate this technology and the people that made it possible, but it would be so AWESOME if it actually worked

Anyway, thanks for the tips. If all else fails I'll try the Media Importer but I'm still hoping there could be some kind of fix...or at least people that have the same issue.


I eventually found this thread on Google Code:

code dot in Android Issues with the tag 58277 (sorry, can't post links yet)

From what I understand, there seems to be a bug in Android 4.3 which seems to be preventing some units of Nexus 7 tablets from being able to host USB devices other than keyboards and mice...

Somewhere in the conversation (post #215) it's suggested by possibly a developer that this bug might be addressed in Android 4.4

If someone else is experiencing the same problem as I am and has more know-how about Android's more inner workings, I'd very much appreciate their take on this

I did try something that seemed to have worked. I used the instructions here:

otgtroubleshooter dot in the article "android 4.3 issue 58277" (again, sorry, can't post links yet )

After this I used OTG Troubleshooter (Play Store) to see if it somehow resolved my problem. I got an "All OK!" after my first reboot, but my thumb drive still isn't being detected. Maybe this will work for others...

Well, hope to hear from someone soon...
8th November 2013, 08:35 AM |#4  
OP Junior Member
Thanks Meter: 0
Talking Finally managed to make it work
Well, today I had a bit more time to skim that Google Code thread and found out that for someone it was possible to access their microUSB stick by installing Total Commander and the plugin USB Stick Plugin

I just connect my UD320 to the Nexus 7 and the plugin asked if it should be used by default for said thumb drive and it totally works! I can move files over to my Nexus and vice-versa, and also files can be deleted from the stick. I don't know if it matters or not but I formatted my stick to FAT32 beforehand.

I guess OTG Troubleshooter wasn't completely lying, but it still doesn't work with other File Explorers, unfortunately, so I guess the bug will be fixed in Android 4.4. I hope

'Till then, I'm happy to have found a temporary work around and I hope other people will also benefit from this

Cheers and good luck, and please do share if any of you find any other options for making this work!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes