FORUMS
Remove All Ads from XDA

[ROM][KK][4.4][SABERMOD] CyanogenMod 11 [ALPHA BUILDS] Ported for i777

3,992 posts
Thanks Meter: 16,515
 
Post Reply Email Thread
This is ported from @infected_ and his amazing work! I have been personally porting his roms for my i777 for awhile and have been blown away with how much of a difference SaberMod and Linaro have made to the ROM. I have ported this rom with permission to share some 4.4 goodness with the rest of my fellow i777 users. I may keep porting future releases but have not decided yet.

First and foremost, I nor @infected_ are responsible for what you do to your device and YOU accept full responsibility if there are ANY issues.
IF there are any issues please don't blow up @infected_ 's threads looking for support because you will find none. Please just do some research first before posting an issue. Since this is an Alpha build, someone may have already posted a fix for an issue your having in one of the i9100 threads.

I have personally tested this rom out and everything seems to been in working order. I may have missed something though so please don't quote me. The one thing I have noticed is the Battery Percentage is not correct.

Rom: Build 11/23/2013
GApps: 20130813

Older Builds:
Build 11/20/2013

Instructions:
First make a nandroid backup (DUH)
Make sure you are on the newest CWM recovery. These easiest way i do this is flash the newest CM Nightly
Once you flash the newest CM Nightly, reboot recovery
Wipe Data/ Factory Reset
Wipe Cache/ Dalvic Cache
Format System
Flash ROM
Flash GApps
WIPE DATA/ FACTORY RESET (If you don't you will get stuck on CM Logo)
Enjoy

Change Log: http://review.cyanogenmod.org/#/q/statuspen+branch:cm-11.0,n,z

Thread I am porting from: http://forum.xda-developers.com/show....php?t=2535369
The Following 11 Users Say Thank You to RenderBroken For This Useful Post: [ View ]
 
 
22nd November 2013, 03:09 AM |#2  
eddiemc12's Avatar
Senior Member
Flag Jamaica New York
Thanks Meter: 99
 
More
Quote:
Originally Posted by renderbroken

this is ported from @infected_ and his amazing work! I have been personally porting his roms for my i777 for awhile and have been blown away with how much of a difference sabermod and linaro have made to the rom. I have ported this rom with permission to share some 4.4 goodness with the rest of my fellow i777 users. I may keep porting future releases but have not decided yet.

first and foremost, i nor @infected_ are responsible for what you do to your device and you accept full responsibility if there are any issues.
if there are any issues please don't blow up @infected_ 's threads looking for support because you will find none. Please just do some research first before posting an issue. Since this is an alpha build, someone may have already posted a fix for an issue your having in one of the i9100 threads.

I have personally tested this rom out and everything seems to been in working order. I may have missed something though so please don't quote me. The one thing i have noticed is the battery percentage is not correct.

Rom: http://d-h.st/szt
gapps: http://d-h.st/pba

instructions:
First make a nandroid backup (duh)
make sure you are on the newest cwm recovery. These easiest way i do this is flash the newest cm nightly
once you flash the newest cm nightly, reboot recovery
wipe data/ factory reset
wipe cache/ dalvic cache
format system
flash rom
flash gapps
wipe data/ factory reset (if you don't you will get stuck on cm logo)
enjoy

thread i am porting from: http://forum.xda-developers.com/show....php?t=2535369

any fix for battery percentage problem
22nd November 2013, 03:39 AM |#3  
Junior Member
Thanks Meter: 4
 
More
CWM recovery build
what CWM recovery build do i need im running 6.0.4.4, iv heard i would need 6.0.4.5. Is that infact the one i need for it to run kitkat?
22nd November 2013, 03:41 AM |#4  
RenderBroken's Avatar
OP Recognized Developer
Flag /home/renderbroken/android
Thanks Meter: 16,515
 
Donate to Me
More
Quote:
Originally Posted by eddiemc12

any fix for battery percentage problem

I know there was a flashable zip in Wayland's original CM11 for i9100 thread. I am looing at building nightlies for the i777 and believe the source has already been fixed. In the meantime I will keep porting @infected_ 's builds and will see if its fixed in his newest build and if it persists when porting it over. It may also be a device issue.
22nd November 2013, 03:43 AM |#5  
RenderBroken's Avatar
OP Recognized Developer
Flag /home/renderbroken/android
Thanks Meter: 16,515
 
Donate to Me
More
Quote:
Originally Posted by bigbossmcg

what CWM recovery build do i need im running 6.0.4.4, iv heard i would need 6.0.4.5. Is that infact the one i need for it to run kitkat?

I just flashed the CM nightly of 11/13/2013 and used its recovery. Im sorry I dont remember the CWM version.
22nd November 2013, 04:19 AM |#6  
eddiemc12's Avatar
Senior Member
Flag Jamaica New York
Thanks Meter: 99
 
More
Quote:
Originally Posted by RenderBroken

I know there was a flashable zip in Wayland's original CM11 for i9100 thread. I am looing at building nightlies for the i777 and believe the source has already been fixed. In the meantime I will keep porting @infected_ 's builds and will see if its fixed in his newest build and if it persists when porting it over. It may also be a device issue.

PERSONS on the i9100 thread are having the same issues with their devices
22nd November 2013, 04:37 AM |#7  
RenderBroken's Avatar
OP Recognized Developer
Flag /home/renderbroken/android
Thanks Meter: 16,515
 
Donate to Me
More
Quote:
Originally Posted by eddiemc12

PERSONS on the i9100 thread are having the same issues with their devices

Sorry, the original link is down. I will keep an eye out for a fix
22nd November 2013, 05:21 AM |#8  
Senior Member
Thanks Meter: 58
 
More
Quote:
Originally Posted by RenderBroken

Sorry, the original link is down. I will keep an eye out for a fix

I was able to flash this rom pretty easily. That's all I can really say for it though.

I flashed twice (followed the OP steps) and both times, none of the sounds work. I'll try it out another time when the sound is back. I'm excited this is finally becoming more of a reality for this device now though.

Thanks for your hard work!

PS- I did make a phone call while on it, and it worked fine.
22nd November 2013, 07:25 AM |#9  
Senior Member
Thanks Meter: 67
 
More
got this to boot! phone is dead, so can't do too much testing but just wondering how to get the google launcher?
22nd November 2013, 02:13 PM |#10  
RenderBroken's Avatar
OP Recognized Developer
Flag /home/renderbroken/android
Thanks Meter: 16,515
 
Donate to Me
More
Quote:
Originally Posted by BInspirinG

I was able to flash this rom pretty easily. That's all I can really say for it though.

I flashed twice (followed the OP steps) and both times, none of the sounds work. I'll try it out another time when the sound is back. I'm excited this is finally becoming more of a reality for this device now though.

Thanks for your hard work!

PS- I did make a phone call while on it, and it worked fine.

Thats weird, I was able to use my bluetooth and heard sounds but they were kinda low. If there is an update I will port it today.
22nd November 2013, 03:34 PM |#11  
Senior Member
Thanks Meter: 58
 
More
Quote:
Originally Posted by RenderBroken

Thats weird, I was able to use my bluetooth and heard sounds but they were kinda low. If there is an update I will port it today.

Interesting. Do you have sounds for the ringer, notifications, and alarm clock?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes