Remove All Ads from XDA
Honor View 10

[Q]OTA KitKat Update Failed, won't complete boot process now.

53 posts
Thanks Meter: 6
By Stinger2300, Member on 22nd November 2013, 09:43 AM
Post Reply Email Thread
26th November 2013, 07:55 AM |#51  
azizmulhim's Avatar
Thanks Meter: 2
Originally Posted by Stinger2300


Here is what I did:

I went to this link: and downloaded the 4.3 (Jelly Bean) factory image for my device. In my case, since I have a Nexus 10, it was this file: 4.3 (JWR66Y)

Then inside that file was "". I extracted that file. I then took the files I extracted (boot.img, recovery.img, system.img, userdata.img, and cache.img) and moved them to the "Nexus10RootNew" folder that I had previously downloaded from here:

Then Open file manager
Navigate to the folder you extracted the files to (Nexus10RootNew)
on the left pane select the folder, press SHIFT and Right Click mouse, then select "Open command window here"

From the command window, run >fastboot reboot-bootloader

It should reboot to the bootloader.

Then, run the following commands (note the .img files below are from the 4.3 image file, not 4.4):

fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot erase system
fastboot flash system system.img

At this point you have a clean install of 4.3 JSS15R.

Then I removed the 4.3 .img files (boot.img, recovery.img, system.img, userdata.img, and cache.img) that I just used from the Nexus10RootNew folder and moved the 4.4 (KRT16S) recovery.img file into the Nexus10RootNew folder.

Then, when back in bootloader, go back to the command window and type:

>fastboot flash recovery recovery.img
Note this is the 4.4 (KRT16S) recovery.img file now.
(^^^^^Looking back, I don't think this is necessary and may be why I have some weird issues popping up)

After it's done:

>fastboot reboot-bootloader again and go to recovery using the volume buttons

select and enter recovery mode

wait for dead droid to appear

press both Volume UP and Power at same time and you should get the load menu

select "apply updated from adb" and press power after selecting

orange colored type will now appear at the bottom of the screen

on your PC

>adb sideload

Make sure this is the 4.4 (KRT16S) OTA file from here:

wait till you see its completed successfully

then reboot

It should now load Kit Kat (it takes a while) and then start optimizing apps. At that point you know it's successful. Just wait for it to finish optimizing the apps and enjoy!

I ended up with KRT16O somehow, not sure since I used the KRT16S files but I assume it will notify me of the KRT16S OTA being available at some point. I have not attempted to regain root or anything yet. I'll wait for the next OTA before making it "unstock" to try to avoid any problems this time.

Note: I did end up losing all my homescreens so I'll have to move all the apps/widgets back into position but the apps and the app data is there. I did have to update a few settings like turning WiFi back on and such.

Did you lose any user data in this process?

Sent from my Galaxy Nexus using Tapatalk
27th November 2013, 12:20 AM |#52  
Junior Member
Thanks Meter: 7
Got an error during the sideload
Hey guys,

Thanks for all the help in this thread. I tried the method outlined above of reverting back to a clean copy of 4.3 and then upgrading to 4.4. The problem I have run in to is that when executing the "adb sideload" command I receive the following error at the windows commandline:

adb server is out of date ...
*daemon started successfully*
error device not found

Not really sure what to do. I will note that I don't really care about preserving my settings and don't mind setting all that stuff back up since that is easy enough.

Any help is appreciated.
27th November 2013, 02:34 PM |#53  
Senior Member
Thanks Meter: 23
It means your version of adb is too old. Pull the most current one from the SDK or get the basic yet current version from here

Be sure when you are prompted on the device to accept adb RSA security exception.
30th November 2013, 12:29 AM |#54  
fred1050's Avatar
Flag Rouen, France
Thanks Meter: 13
Thumbs up
Originally Posted by Stinger2300


Here is what I did:

thanks a lot, it's working for me too !!
and without loosing any data !!
1st December 2013, 11:38 PM |#55  
Junior Member
Thanks Meter: 0
Successful flash no problems!
Originally Posted by Stinger2300


This worked for me too! Thank you so much for the walkthrough, I've been having a hell of a time getting mine to update.

Thank you so much!
3rd December 2013, 01:49 AM |#56  
Junior Member
Thanks Meter: 2
Hmm. I had a similar failed update -- stock JB + rooted, after the update I just got stuck at the boot animation.

However, I am unable to get into recovery. Power + volume down or Power + vol down + vol up do nothing, the device just boots as normal and gets stuck at the boot animation. Power + volume up though, I can get to the Odin downloader ("Downloading... Do not turn off target!!" -- shows up as Samsung CDC device and Odin sees it).

Any ideas? Seems like at this point I either need to get an Odin-flashable image (any image really!), or figure out some way to get back into recovery.

Edit: fixed -- I used Odin 1.85 to flash TWRP recovery from tarball (open odin, select PDA, select the twrp .tar file, click start). Then reboot tablet holding both power up and power down; this actually got me into the bootloader now. From there, I used the factory images and fastboot flashed. Curiously, my bootloader wasn't updated from the original OTA update; had to flash MANTAMF01 (I had MANTAMD03).
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes