FORUMS
Remove All Ads from XDA

[Q] Battery not charging Or showing stuck randomly

236 posts
Thanks Meter: 16
 
By besony, Senior Member on 26th November 2013, 11:25 AM
Post Reply Email Thread
Hi all,

I got my Canvas 2 ( 4 days ago ).
Cheers to this forum & all the awesome devs here!

Since I have bought Can2, I could only get to charge my device upto like 95% or so.. ( some thing or the other kept coming up!! DAMN! )

My phone has been giving like 1.5+ days of backup or so.. ( this is with heavy use - games/Wifi/whatsapping & data on whenever wifi is off ).
My phone came with 4.1.2 out of the box!

No root/flash yet. ( still discovering the default power of the phone ).

But --

Today I observed 2 things:

1. I put the phone on charge - and it just was stuck at 15% for quite some time. the charging red LED was 'blinking' the whole time!
-- this charging was through a multipurpose "Croma" portable charger. ( I was charging it through 2 pin plugged to electricity ).
I am not sure - whether the charging LED should blink or stay lit!?

I restarted the phone - and suddenly battery was like 67% !!

2. I disconnected the charger - and plug the usb into my laptop.
Now - the LED (red) was not blinking - it just stays lit.
But- the charging seems very very slow!
in last 40 mins it has just moved to 73% now.

What's going on?

Right now - I am running busy at work.

How can I handle this problem without "rooting" or anything that requires 'reading'?

Thanks in advance folks!

Sony.
 
 
26th November 2013, 06:11 PM |#2  
mrtaim3's Avatar
Senior Member
Flag Faisalabad
Thanks Meter: 36
 
More
Quote:
Originally Posted by besony

Hi all,

I got my Canvas 2 ( 4 days ago ).
Cheers to this forum & all the awesome devs here!

Since I have bought Can2, I could only get to charge my device upto like 95% or so.. ( some thing or the other kept coming up!! DAMN! )

My phone has been giving like 1.5+ days of backup or so.. ( this is with heavy use - games/Wifi/whatsapping & data on whenever wifi is off ).
My phone came with 4.1.2 out of the box!

No root/flash yet. ( still discovering the default power of the phone ).

But --

Today I observed 2 things:

1. I put the phone on charge - and it just was stuck at 15% for quite some time. the charging red LED was 'blinking' the whole time!
-- this charging was through a multipurpose "Croma" portable charger. ( I was charging it through 2 pin plugged to electricity ).
I am not sure - whether the charging LED should blink or stay lit!?

I restarted the phone - and suddenly battery was like 67% !!

2. I disconnected the charger - and plug the usb into my laptop.
Now - the LED (red) was not blinking - it just stays lit.
But- the charging seems very very slow!
in last 40 mins it has just moved to 73% now.

What's going on?

Right now - I am running busy at work.

How can I handle this problem without "rooting" or anything that requires 'reading'?

Thanks in advance folks!

Sony.

Its ur charger problem.. Change the charger.. And if u charge through computer then it charges very slow because of Amperes. Not to worry. I recommend u to buy a usb adapter of 3Ampere. And charge with it. It charges fast .

Sent from my Qmobile Noir A10 using Tapatalk
The Following User Says Thank You to mrtaim3 For This Useful Post: [ View ] Gift mrtaim3 Ad-Free
27th November 2013, 07:12 AM |#3  
besony's Avatar
OP Senior Member
Flag Pune
Thanks Meter: 16
 
More
Quote:
Originally Posted by mrtaim3

Its ur charger problem.. Change the charger.. And if u charge through computer then it charges very slow because of Amperes. Not to worry. I recommend u to buy a usb adapter of 3Ampere. And charge with it. It charges fast .

Sent from my Qmobile Noir A10 using Tapatalk

Thanks man for the reply!

I used the MMX charger yesterday night ( and was relieved ) to find out that phone is charging 1% per 4 mins or so.
^ which I think is ok.

May be my all purpose charger isn't good enough for this phone.

And yeah - the PC USB charging is painfully slow -- like 1% every 13~15 mins!

Cheers,

Sony.
31st July 2018, 01:53 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Charging of my Micromax Canvas 2 sometimes stops at 11, 22 and 32%, charging shows but does not charge further.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes