FORUMS
Remove All Ads from XDA

[FIX] Windows 8.1 Fastboot/Flashmode/ADB for Sony and Samsung devices

8 posts
Thanks Meter: 84
 
By janek2012, Junior Member on 5th January 2014, 03:22 AM
Post Reply Email Thread
As you all may now, Microsoft pushed the new driver stack in Windows 8.1 so ALL (not only USB 3.0) devices must provide a BOS descriptor. Sony ADB and Fastboot doesn't, so Windows fails to enumerate the device which is reported in Device Manager as error code 43.
This also may help if you have a USB drive or mouse and it stopped working after you upgraded from Windows 8 to Windows 8.1.

Microsoft said that the fix will come in February but for people who don't want to wait I prepaired a dirty solution:
Microsoft published the update.

proof - see attachment.

THE PROBLEM IS NOW FIXED BY THIS UPDATE: http://support.microsoft.com/kb/2917929 - USE IT INSTEAD OF MY FIX!

Here is my old (dirty) solution:
HTML Code:
#include <std_disclaimer.h>
/*
 * Your warranty is now void.
 *
 * I am not responsible for bricked devices, dead SD cards,
 * thermonuclear war, or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at me for messing up your device, I will laugh at you.
 */
I repeat this is a REALLY DIRTY solution that may harm your system, personal data, hardware and/or cat.
Here are the steps:
0. Have a Linux or Windows LiveCD just in case something goes wrong
1. Download and extract files from attachment
2. Navigate to the folder corresponding to your system version (x86 = 32-bit, x64 = 64 bit)
3. Right-click franken-usb.bat and click "Run as Administrator"
5. Wait for it to finish and reboot the system. If everything went fine, you will boot your system successfully
6. Install ADB/Fastboot drivers just like on Windows 8
7. Connect your phone in Fastboot mode to your USB 2.0 port and check if it works
8. Enjoy and wait for official fix

How does it work:
It's not any kind of magic - it just replaces Windows 8.1's usbhub.sys and usbport.sys with Windows 8's ones.
Old files don't check for BOS descriptor so Fastboot can work.

Script updated - it should now actually copy the files but please double check if files were copied to C:\Windows\system32\Drivers!


Hope it helps you!

Regards!
Attached Thumbnails
Click image for larger version

Name:	proof.png
Views:	41170
Size:	64.4 KB
ID:	2494919  
Attached Files
File Type: zip USB.zip - [Click for QR Code] (687.0 KB, 88833 views)
The Following 80 Users Say Thank You to janek2012 For This Useful Post: [ View ] Gift janek2012 Ad-Free
 
 
5th January 2014, 09:28 PM |#2  
wabicek's Avatar
Member
Flag Prague
Thanks Meter: 16
 
More
Thumbs up
So far it works (both adb and fastboot) on my computer. But it was necessary to copy these files manually.
Thank you!
9th January 2014, 03:42 AM |#3  
Senior Member
Thanks Meter: 15
 
More
!! success !!
thank u bro , working great on win 8.1 pro 64 bit , fastbooted sony xperia LWW and flashed kernel like before !
just need to copy files manually though but that was so easy .
10th January 2014, 06:36 PM |#4  
heatledger's Avatar
Senior Member
Thanks Meter: 35
 
More
thanks! working perfectly 8.1 64bit
you're my hero
10th January 2014, 11:02 PM |#5  
hhamzah49's Avatar
Senior Member
Flag Den Haag
Thanks Meter: 31
 
More
Looks like it works reading those comments! Gonna try it tomorrow!

Sent from my LT30p using xda app-developers app

EDIT:

doesnt work for me! It now doesnt show the driver blabla it shows s1 fastboot. And the phone doesnt stay in fastboot

EDIT 2:
nevermind fixed it with installing drivers via flashtool.

Thankyou my hero!
The Following User Says Thank You to hhamzah49 For This Useful Post: [ View ] Gift hhamzah49 Ad-Free
17th January 2014, 11:43 PM |#6  
mefistoreyon's Avatar
Senior Member
Flag Varna
Thanks Meter: 605
 
More
Works on me too! Thanks!
18th January 2014, 09:51 AM |#7  
MatteXperiaU's Avatar
Senior Member
Flag Italia
Thanks Meter: 52
 
More
awesome!! you are my hero!!!!
27th January 2014, 08:25 AM |#8  
drmidoo's Avatar
Senior Member
Flag Cairo
Thanks Meter: 183
 
More
Thumbs up
works on windows 8.1 x64 usb 2.0
thanks great fix
27th January 2014, 09:27 AM |#9  
Steph310's Avatar
Senior Member
Flag Cahors
Thanks Meter: 1,380
 
More
I only needed to replace manually files, but yes! Now it works perfectly on Win8.1 x64 on USB2.0 computer!
My problem finally solved, thanks to you janek2012!
27th January 2014, 08:45 PM |#10  
gonzal86's Avatar
Senior Member
Thanks Meter: 59
 
Donate to Me
More
Quote:
Originally Posted by Steph310

I only needed to replace manually files, but yes! Now it works perfectly on Win8.1 x64 on USB2.0 computer!
My problem finally solved, thanks to you janek2012!

Yea me too replaced manualy, but all works fine. At last phone connect in fastboot and flash

Dobra robota @janek
28th January 2014, 02:54 AM |#11  
Senior Member
Flag Alexandria
Thanks Meter: 271
 
More
yes working good with replace manually files

thanks bro
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes