FORUMS

[Q] [ Reverse Tethering ] DNS is not working

1 posts
Thanks Meter: 0
 
By thruthesky, Junior Member on 10th January 2014, 05:40 AM
Post Reply Email Thread
When I did same thing on Galaxy S3, it's working fine.

But When it did it on Galaxy Note2, it some times works. once out of 10 times works.

If you look below, ping is working. but it's not working with the domain name.

I did nslookup and it's working.

I browsed to a website throught IP and it's working. but it's not working with domain.

I tried to adjust DNS info in ADB shell but still not working.

it's working some times. but most out of times it's not working.

Please some body gives me any hint.

thank you.


--------------------------------------------------------------
C:\Users\JaeHo>ipconfig
Ethernet adapter Local Area Connection 9:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::99d3:e644:18aa:c0fe%49
IPv4 Address. . . . . . . . . . . : 192.168.137.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
---------------------------------------------------------------
C:\Users\JaeHo>adb shell
[email protected]:/ $ su
su
[email protected]:/ # netcfg rndis0 dhcp
netcfg rndis0 dhcp
[email protected]:/ # route add default gw 192.168.137.1 dev rndis0
route add default gw 192.168.137.1 dev rndis0
[email protected]:/ # ping -c5 philgo.com
ping -c5 philgo.com
ping: unknown host philgo.com
2|[email protected]:/ # ping -c5 168.126.63.1
ping -c5 168.126.63.1
PING 168.126.63.1 (168.126.63.1) 56(84) bytes of data.
64 bytes from 168.126.63.1: icmp_seq=1 ttl=52 time=105 ms
64 bytes from 168.126.63.1: icmp_seq=2 ttl=52 time=100 ms
64 bytes from 168.126.63.1: icmp_seq=3 ttl=52 time=100 ms
64 bytes from 168.126.63.1: icmp_seq=4 ttl=52 time=132 ms
64 bytes from 168.126.63.1: icmp_seq=5 ttl=52 time=100 ms

--- 168.126.63.1 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 100.747/108.058/132.237/12.238 ms
[email protected]:/ # getprop net.dns1
getprop net.dns1

[email protected]:/ # nslookup philgo.com
nslookup philgo.com
nslookup: can't resolve '(null)': Name or service not known

Name: philgo.com
Address 1: 116.122.36.242
[email protected]:/ # ip route show
ip route show
default via 192.168.137.1 dev rndis0
192.168.137.0/24 dev rndis0 proto kernel scope link src 192.168.137.131
21st May 2014, 05:52 PM |#2  
Junior Member
Thanks Meter: 0
 
More
When setprop does not set the prop... :

Code:
iptables -t nat -A OUTPUT -p udp --dport 53 -j DNAT --to-destination 8.8.8.8:53
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes