FORUMS
Remove All Ads from XDA

"whoami" unknown command (Please help tried everything)

403 posts
Thanks Meter: 22
 
By theMaDHakkeR, Senior Member on 30th June 2010, 11:01 PM
Post Reply Email Thread
Hi everyone,

I'm really baffled by this error im getting now. Just re-did the root on my X10a and everything is working great. SU is advising me when things request root access and it sets to UID 0. FINE. But when i go into terminal and hit whoami i get unknown command. Last time i had this i did ttxdragon (i think is his name) method and it fixed it but now nothing gets it to work. When i hit su i get the # and am able to mount the os in adb and in terminal, also to delete system apps using #6 in the root guide but the whoami command comes up as unknown command. This is driving me nuts because everything seems ot be configured properly and i have proper root access from what i can see. Please someone help if you know what i might be doing wrong.

Also i just re-rooted using the new 5 Step method for X10a.

Your help is much appreciated.

Edit: Also wanted to mention i got the busybox app from the market also and it installed fine as uid0.

Regards.
 
 
30th June 2010, 11:21 PM |#2  
biktor_gj's Avatar
Senior Member
Thanks Meter: 7,040
 
Donate to Me
More
Quote:
Originally Posted by theMaDHakkeR

Hi everyone,

I'm really baffled by this error im getting now. Just re-did the root on my X10a and everything is working great. SU is advising me when things request root access and it sets to UID 0. FINE. But when i go into terminal and hit whoami i get unknown command. Last time i had this i did ttxdragon (i think is his name) method and it fixed it but now nothing gets it to work. When i hit su i get the # and am able to mount the os in adb and in terminal, also to delete system apps using #6 in the root guide but the whoami command comes up as unknown command. This is driving me nuts because everything seems ot be configured properly and i have proper root access from what i can see. Please someone help if you know what i might be doing wrong.

Also i just re-rooted using the new 5 Step method for X10a.

Your help is much appreciated.

Edit: Also wanted to mention i got the busybox app from the market also and it installed fine as uid0.

Regards.

Easy, instead of running simply:
# whoami

Run:
# busybox whoami

Done!

By the way, you can simply type
# id
too
The Following User Says Thank You to biktor_gj For This Useful Post: [ View ] Gift biktor_gj Ad-Free
30th June 2010, 11:29 PM |#3  
OP Senior Member
Thanks Meter: 22
 
More
Haha! Thank you your a saint! I'm still learning everyday:)

Thanks again.

Sent from my X10a using XDA App
8th June 2017, 11:32 AM |#4  
BIG_BADASS's Avatar
Senior Member
Thanks Meter: 41
 
More
Quote:
Originally Posted by biktor_gj

Easy, instead of running simply:
# whoami

Run:
# busybox whoami

Done!

By the way, you can simply type
# id
too

Simple, amazing solution. Thanks !
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes