FORUMS
Remove All Ads from XDA

MMM³ - MoDaCo Mod for MOJO (root + Play Store mod)

5,269 posts
Thanks Meter: 7,352
 
By paulobrien, Senior Member on 19th January 2014, 08:48 PM
Post Reply Email Thread
The MoDaCo Mod for MOJO, which adds root and increased Play Store app availability to the MadCatz MOJO, is now available!

The mod takes the form of a Superboot image (as used on many devices previously), with additional features to resolve the Play Store lack-of-apps issue.

What is this?

Superboot is a boot.img that when booted, will root your device the first time you boot (installing su and the superuser APK). No need to flash any partitions, no messing with the contents of your data partition, no overwriting the shipped ROM on your device, just boot the boot image using the instructions below and you're done!

What are the pre-requisites?

You need a MOJO (duh) and a USB Male A-A cable to carry out this process. And a computer I suppose (Windows, Mac or Linux).

Any caveats?

You should note that while rooting may affect your ability to receive future OTAs, reverting back to stock is easy enough. We'll cross that bridge when we come to it.

Download

APPLY THIS AT YOUR OWN RISK!
  • Superboot MMM³ - DOWNLOAD - MD5: 835de32dd795d2825ade1ed1be422abf
How to use Superboot - Windows, Linux and OSX
  • Download the Superboot zip file above and extract to a directory
  • Put your device in bootloader mode - Unplug the power cable and any USB cables (the dongle can stay in), insert the USB Male A-A cable in the port labelled '2.0', then insert the power cable. 'Key driver not found.. Booting OS' will appear on screen.
  • WINDOWS - install the device drivers from the directory you extracted above if required, then run 'superboot-windows.bat' as Administrator
  • MAC - Open a terminal window to the directory containing the files, and type 'chmod +x superboot-mac.sh' followed by 'sudo ./superboot-mac.sh'
  • LINUX - Open a terminal window to the directory containing the files, and type 'chmod +x superboot-linux.sh' followed by 'sudo ./superboot-linux.sh'
  • You will see 'Booting downloaded image' and a black screen, then the screen will return to 'Key driver not found.. Booting OS'. At this point, unplug the USB cable and the power cable, wait a few moments, then reconnect the power cable to boot as normal.
For all the missing apps to show up on the Play Store, you may need to clear data on the Play Store in 'Settings -> Applications' and reboot, then run the Play Store again.

Enjoy!

P

The Following 11 Users Say Thank You to paulobrien For This Useful Post: [ View ] Gift paulobrien Ad-Free
 
 
19th January 2014, 10:08 PM |#2  
Junior Member
Thanks Meter: 5
 
More
Wink Thank you!
Thank you for kicking off true development for the Mojo to move forward. I'll try this as soon as I can and respond.

you rock!
19th January 2014, 11:16 PM |#3  
ExtremeRyno's Avatar
Senior Member
Thanks Meter: 118
 
More
Now I'm off to get dog food! Oh...I mean I'm using that as an excuse to run and get myself a USB cable. You're awesome, paulobrien. I'll root this evening!
20th January 2014, 12:15 AM |#4  
Member
Thanks Meter: 17
 
More
There we go!!! What we've all been waiting for!!!

BTW, what are the changes to the Play Store that enable all the apps?

Thanks for this! Now I need an A-A cable...
20th January 2014, 12:23 AM |#5  
Dead-neM's Avatar
Senior Member
Flag France
Thanks Meter: 569
 
Donate to Me
More
Ok it's finaly come so happy thanks Paul O'Brien
I don't understand why my pc won't see my mojo there is no sound when i plug into it i try usb 2 and 3 with a usb 3 male male cable
So after i type reboot bootloader the mojo reboot normaly even if i unplug the power etc... and the pc do nothing

Thanks for what you did this is awesome
20th January 2014, 02:53 AM |#6  
Member
Thanks Meter: 5
 
More
Mojo goes into fastboot mode and installed drivers fine. However currently running into issue where when I run the superboot-windows.bat file in admin mode it opens cmd for a second then immediately closes. The mojo doesn't seem to respond whatsoever. Any thoughts?
20th January 2014, 04:07 AM |#7  
Junior Member
Thanks Meter: 1
 
More
Ya same here mojo say key driver not found... Booting OS but when I run the .bat file doesnt close just sitting waiting for device
20th January 2014, 05:22 AM |#8  
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by buggin0915

Ya same here mojo say key driver not found... Booting OS but when I run the .bat file doesnt close just sitting waiting for device

Are running the bat file as an admin? right click>run as admin
20th January 2014, 05:43 AM |#9  
Junior Member
Thanks Meter: 1
 
More
ya ran in admin also tried to run adb just to see if i can connect device but nothing. computer is connecting just not the device with adb/fastboot
20th January 2014, 07:15 AM |#10  
Member
Thanks Meter: 17
 
More
2 things to try:
1) Run the bat file in an actual command window to see the output, or edit it and add pause at the end (likely device not found or fastboot isn't in the path)
2) Manually force a driver (I believe the fastboot driver from the Android SDK should be able to be forced, since this is just a Tegra 4 chipset)

To ensure its ready to go, you should be able to write:
"fastboot devices"

And see that there is a device there. I will try when I get my cable
20th January 2014, 07:44 AM |#11  
Member
Thanks Meter: 5
 
More
Thanks I'll try out more tomorrow.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes