Remove All Ads from XDA

Re: Bluetooth Keyboards don't work N7 & 4.3

107 posts
Thanks Meter: 45
By thenrik, Senior Member on 2nd August 2013, 06:27 PM
Post Reply Email Thread

I culled the following list from XDA, Phandroid and Nexus 7/Nexus 10 Forums. Some folks have gotten keyboards to work on the Nexus 4 and 10 but I haven't seen any reports of success with the Nexus 7 2012 or 2013 running 4.3:

I'm using a Zagg, and it'll pair. I can enter the code. The Nexus seems to recognize what it is, but once it's all set up the keyboard is completely non-functional. It wont move around the home screens and it wont input in a text editor.

Perixx PERIBOARD-806, Bluetooth ALU Folding Keyboard
It pairs with difficulty and shows connected but the soft keyboard still appears and it will not type.

Apple Bluetooth Keyboard
Is anyone else having issues with their bluetooth keyboard when paired with the Nexus 7? I have an Apple Bluetooth keyboard and it repeats characters, and inserts the spaces out of order.

My Apple A1255 keyboard pairs but no longer connects in 4.3 on my Nexus 7 (2012). Works on my Nexus 4 with 4.3 and worked on 4.2.2 no problems.

Spider Bluetooth Keyboard
I recently purchased a Spider bluetooth keyboard and I can get it to pair with my Nexus 7 (which recently updated to 4.3). The tablet recognizes it, and I type in the numerical code and press enter on the keyboard and the Nexus 7 responds. However, I can't get it to work in any other app after it pairs (I've tried unpairing it, turning it off/on, restarting the tablet, etc).

Unknown Bluetooth Keyboard
I have a Bluetooth Keyboard and he works perfectly if im using the 4.2.2. Now only the letters work, no Space, no enter, no backspace and nothing more... Anyone have this problem too? (Sorry for my poor English)

I got the same problem with my bluetooth keyboard and other issue with the ShareKM app The cursor is invisible.

Kensington Bluetooth Keyboard
I have a Kensington UK bluetooth keyboard and although it shows as connected and typing the numbers to pair it worked, I get no input at all...

GYMLE Bluetooth Keyboard
I have a GMYLE keyboard and it will connect but no key will register on screen

Has anyone gotten any Bluetooth Keyboard to work with the Nexus 7?

Does anyone know how to report this to Google?

2nd August 2013, 06:33 PM |#2  
Senior Member
Thanks Meter: 31
I paired a Logitech K810 and a Logitech BT mouse and both worked fine. (2013 Nexus 7 running stock 4.3, stock recovery, bootloader still locked, no root).
2nd August 2013, 08:04 PM |#3  
fewt's Avatar
Thanks Meter: 51
My Logitech Tablet keyboard paired and worked just fine with my 2013 Nexus 7.
3rd August 2013, 12:34 AM |#4  
thenrik's Avatar
OP Senior Member
San Francisco
Thanks Meter: 45
Originally Posted by fewt

My Logitech Tablet keyboard paired and worked just fine with my 2013 Nexus 7.


Thanks for the clarification. Others have reported compati bility with Logitech keyboards as well. I also saw a post that the Rapoo E6100 works with the Nexus 7 as well.

I wrote the same post to Android Police and Cameron Summerson ran with it posting an article today:

Hopefully the article will bring the issue to Google's attention and an upcoming fix will come for the rest of us.

An Android Police user commented:
"I hear they have "top men" working on the issue :P Getting Google to admit the problem exists is the first step. A HUGE first step."

I just hope it's the case.


Tom Henriksen
3rd August 2013, 12:38 AM |#5  
Senior Member
Flag SF Bay Area
Thanks Meter: 145
My by keyboard from my HP touchpad also installed and worked fine including power and sleep

Sent from my Nexus 7 using Tapatalk 4 Beta
12th August 2013, 11:27 PM |#6  
DowntownJeffBrown's Avatar
Senior Member
Flag Porter Indiana (Chicagoland)
Thanks Meter: 3,373
I got the MiniSuit Keyboard Stand Case for Google Nexus 7 FHD 2nd Gen (2013)

I bought it when it was 9.95 plus free Shipping and it arrived at my house today. It connected instantly through the bluetooth and is working flawlessly.

>^.^< Sent from meow HTC One which is like catnip to me atm
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1376342715687.jpg
Views:	770
Size:	74.1 KB
ID:	2184687   Click image for larger version

Name:	uploadfromtaptalk1376342726376.jpg
Views:	664
Size:	70.0 KB
ID:	2184688   Click image for larger version

Name:	uploadfromtaptalk1376342751183.jpg
Views:	635
Size:	66.1 KB
ID:	2184690   Click image for larger version

Name:	uploadfromtaptalk1376342765471.jpg
Views:	599
Size:	79.4 KB
ID:	2184691   Click image for larger version

Name:	uploadfromtaptalk1376342779549.jpg
Views:	618
Size:	73.8 KB
ID:	2184692   Click image for larger version

Name:	uploadfromtaptalk1376342795497.jpg
Views:	604
Size:	114.8 KB
ID:	2184693   Click image for larger version

Name:	uploadfromtaptalk1376342806126.jpg
Views:	583
Size:	72.8 KB
ID:	2184694   Click image for larger version

Name:	uploadfromtaptalk1376342815506.jpg
Views:	567
Size:	96.8 KB
ID:	2184695   Click image for larger version

Name:	uploadfromtaptalk1376342826059.jpg
Views:	555
Size:	68.1 KB
ID:	2184696   Click image for larger version

Name:	uploadfromtaptalk1376342835832.jpg
Views:	535
Size:	74.6 KB
ID:	2184697  
12th August 2013, 11:53 PM |#7  
sciphonic's Avatar
Senior Member
Thanks Meter: 30
Donate to Me
My Apple bt keyboard and mighty mouse connect and function without issue. Also my wired Xbox controller works perfect with an OTG cable.
13th August 2013, 03:42 AM |#8  
Thanks Meter: 8
Are you able to use both your apple bt keyboard and mighty mouse at the same time?

Sent from my Nexus 7 (2013)
13th August 2013, 04:14 AM |#9  
Junior Member
Thanks Meter: 3
I wish ZAGG made cool keyboard cases for the nexus 7 like they do for the iPads. I got a couple keyboard cases from Zagg and they are very cool. If there was a high demand for it they would probably do it.

Sent from my Nexus 7 using xda premium
13th August 2013, 04:20 PM |#10  
Senior Member
Thanks Meter: 76
My logitech keyboard (the one with tablet stand and says android 3+ on it) is all over the place.

FN keys work(volume, mail, etc), but when I open a note taking app, it repeatedly gets stuck on keys.

I'm hoping it's a keyboard issue, not the Nexus. Unfortunately, I do not have another bluetooth keyboard to test this out.
13th August 2013, 06:37 PM |#11  
Senior Member
Thanks Meter: 40
I am using this one and working perfectly
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes