Remove All Ads from XDA
Honor 9 Lite

[Q] Atrix HD Corrupted Data partition

7 posts
Thanks Meter: 0
By Gorrillasnot, Junior Member on 16th February 2014, 11:47 PM
Post Reply Email Thread
I'm a newb..
Atrix HD with unlocked bootloader and rooted. Installed cwm recovery, flashed to the latest nightly cm 11 for atrix hd, rebooted and stuck at cyanogenmod loading screen (head with the spinning circle around it). left it that way over night with no change still stuck on bott.

I've spent several hours following several guides with no success

I think the problem started whn I did a factory reset and clear cache in cwm before I flashed cm 11. it gave an error on data or something.

fastforward several hours later I now have philz touch 6 recovery which I read on this guide you could use to fix the corrupted data partition. problem is when booted to philz recovery the driver for phone is not installed correctly.

The phone is recognized fine in fastboot mode however.
Is there a way to fix the corrupted data partition using fastboot?
I've already tried fastboot -w and reflashing but that did not work.

I have the latest motorola drivers and latest sdk with google usb installed etc.

Unfortunately I was stupid and didn't make a nandroid backup so I hope there is another way to get this phone working.

17th February 2014, 05:36 PM |#2  
OP Junior Member
Thanks Meter: 0
After 2 days of monkeying around I finally got it fixed.
I never could get the phone recognized in recovery mode (philz mod) and using ADB as suggested by the guide I linked.

Finally what worked is I downloaded the stock rom zip, extracted it, edited the xml file in MS word deleting the 2 lines with "getvar" in them, booted the phone into fastboot mode, connected the phone to my PC and made sure it was recognized in device manager, loaded the xml from the stock rom into RSD Lite and flashed back to stock, rebooted, and all was working fine.

I know there's a million and 1 guides that say to do what I just described and believe me I tried the exact things I posted above for the better part of 2 days and rsd lite would always fail with some kind of error. Finally I rebooted my PC, downloaded the stock rom again, edited the xml, and tried one last time and it finally worked...I don't know what made the difference.

Now if I could just find a trick around this darn subsidy (hard) lock this Atrix HD would be back in business.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes