Remove All Ads from XDA

Baseband Unknown on MK2 based ROM

637 posts
Thanks Meter: 73
By majid25, Senior Member on 16th February 2014, 10:24 AM
Post Reply Email Thread
Hello everyone I have a weird issue here and I am in need of some help. I was running a stock MK2 rooted rom, with the modem/firmware MK2 with the MF9 bootloader. When the first NAE (4.4) ROM popped up I decided to give it a try and installed it without getting the NAE modem first. The ROM wouldn't get past the splash screen and other users experienced this too, I figured I should get the NAE modem so I installed it and rebooted hoping it would get past the splash screen. I came to a conclusion that it probably isnt going to work right now so I did a nandroid restore back to my stock MK2 ROM. Upon booting it up I had no data, signal bars with a red X and in About Device section it says baseband unknown and in the status section everything is unknown or has no field. I thought my modem was broken so I tried a 4.4 kitkat ROM OctOS which worked perfectly and I got signal on that ROM. So this brings to me another hypothesis that my modem is fine as I could make calls and what not, no issues. However I tried reinstalling stock MK2 and for some reason I get no signal...

I am not sure whats going on here, I tried a MF9 Stock Tar and formatted the whole phone, tried installing MK2 and MF9 modem and I get no signal on the stock MK2 ROM. I am a little lost here and asking the XDA community for help, I really want to go back to my old setup. Please help me out here.
16th February 2014, 10:48 PM |#2  
optimummind's Avatar
Senior Member
Flag Orange, CA
Thanks Meter: 855
Donate to Me
My situation is kinda similar to yours. I also had no service and got an Unknown baseband message in Settings when I went from stock rooted MK2 (with stock MK2 kernel and MF9 bootloader) to the new NAE ROM and NAE baseband.

I suspect that NAE requires a Knox bootloader for service to work.

Anyhow, to go back to a fully functional MK2 state, here's what I did:

1. Restored my MK2 Nandroid using Philz's recovery.
2. Booted directly into Download mode from Philz and flashed back the MK2 modem with Odin 3.07.
3. Rebooted phone and everything fully works again.

Sent from my Nexus 5 using Tapatalk
The Following User Says Thank You to optimummind For This Useful Post: [ View ] Gift optimummind Ad-Free
17th February 2014, 02:45 PM |#3  
pontif's Avatar
Senior Member
Flag Raleigh
Thanks Meter: 411
modem didn't stick maybe?
Had issues playing with the new modem and nae ROMs. Unknown baseband and no days. Even a ##72786# led to a blank screen with no option to reset. So I played around with different install techniques and got a ROM to fully function.

Unknownforces stock rooted nae. From android development forum.

1. Clean to install new ROM using Philz I used) said any can be used

2. Even of you have already flashed new modern do it again now
A. Power completely off
B. Go into download mode
C. Odin new NAE modem(auto reboot and freset unchecked)
D. After Pass reboot into recovery

3. Clean wipe for new install

4. Install unknown forces ROM

5. Reboot and enjoy data working and WiFi working
Post Reply Subscribe to Thread

baseband, kitkat, mk2, problem, unknown

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes