Remove All Ads from XDA

[Q] Galaxy Ace: stuck in bootloop for unknown reason?

7 posts
Thanks Meter: 0
By Aether Skyborn, Junior Member on 17th February 2014, 01:10 PM
Post Reply Email Thread
Hi, all! I'm sorry if this is in the wrong section, but I'm having a hard time trying to understand the different forums.
My Samsung Galaxy Ace (S5830) running under a custom ROM The Ultimatum (I've been using this custom firmware for a few weeks now, with no real problems up until now), is bootlooping with no apparent reason. On a rare occasion, most apps on the phone stopped responding and would crash upon opening, and would require a restart before they worked again. Well this happened to me a few hours ago, so I decided to reboot my phone. After coming back to check my phone, I had found it was still booting. This has gone on for several hours now, and I've tried turning it on and off, removing batteries and everything. It's stuck in bootloop. I found this was odd, as I have had no dramas with the firmware I've been using. I have not made ANY recent changes to the phone whatsoever, so I can hardly believe it would be my fault.
Now, my question is; how do I fix this without wiping all data and installing a clean ROM? I have a lot of stuff in the internal storage I can't afford to lose, and it's really important to me. A full wipe of all data would not be ideal. I can access recovery mode.

Thanks in advance, and I apologise if this is in the wrong forum!
17th February 2014, 05:50 PM |#2  
Callister's Avatar
Flag Jakarta
Thanks Meter: 22
You might want to ask to the rom thread for some help or ask in this section,
Galaxy Ace S5830 Q&A, Help & Troubleshooting

Anyway, I will try to help. If your custom recovery is support backup and restore (and advanced restore) your rom (check your custom recovery thread), try to backup your phone rom for now, so you could restore it back when solution not working.

Try to reflash the rom again without wipe data and reboot. If still in bootloop try to wipe data and reboot, see if that phone still bootloop.
If phone is successfully boot, go back to recovery and go to advanced restore, restore only data and then reboot. If still not working, then just full restore back to the phone to state before since I have no idea anymore.

That is the option I only know for now. However, try to ask help on section I link above or the rom thread before try this one, since I only familiar with Galaxy Gio (really similar to Ace) in the past.
17th February 2014, 08:18 PM |#3  
OP Junior Member
Thanks Meter: 0
I tried what you suggested but no positive results, really. I managed to boot after a full wipe, but restoring data locked it back into a bootloop. I'll try posting it in the other section.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes