Remove All Ads from XDA

GT-N7000 and specific SIM cards not reading

1,535 posts
Thanks Meter: 649
By br0adband, Senior Member on 5th March 2014, 05:33 AM
Post Reply Email Thread
Well, here I go again with not only another smartphone but I finally got my hands on the GT-N7000 International model with the physical home button. So I get it home, check it out, everything appears to be working fine:

- battery is brand new, just manufactured in January 2014, not a fake one (I checked that out with Samsung directly based on the battery serial number)
- was originally on Android 2.3.6 and upgraded to 4.1.2 through Kies without issues
- no hardware problems noted, everything works great, no damage to the phone at all

Here's where it gets a bit confusing. This is the International version which means it should be unlocked without me having to do anything to or with it, so - when the phone was on 2.3.6 - I took one of my newer T-Mobile microSIM cards and using the adapter to make it a proper miniSIM I slid it into the SIM slot, put the battery back in the phone and turned it on, and nothing gets detected at all.

I pull the battery, find another microSIM, do it again, still the same result. In fact, every microSIM I have (4 T-Mobile, 1 AT&T, all within a year old but none of them are currently activated - whenever I use the T-Mobile SIMs it will still connect to T-Mobile and allow me to pull up the billing web page; the AT&T SIMs never do that and just complain about the SIM not being provisioned).

Since my intention is to use the $30/monthly plan with T-Mobile that I've had in the recent past, I went looking into my little canister of older full size miniSIM cards and found two of them that I used with T-Mobile over the past few years. As most devices use microSIMs and even nanoSIMs nowadays, I figured I better keep them around just in case.

SO... I put one of them in and voila, I get a connection - or so I thought. When inserted, and again when using 2.3.6 I was able to get into the service menu (*#*#4636#*#*) and it would show the number assigned to that SIM originally, etc but it wouldn't show the network. Tried the second SIM card, it gets recognized, same thing - it just doesn't show T-Mobile.

Now, I've never had an International Galaxy Note so I'm kinda confuzzled here so the primary question is this:

Is the GT-N7000 simply incompatible with some SIM cards, even when they're in an adapter so they fit into the SIM slot proper? I know this isn't an LTE capable phone, that's not a concern at all - I suppose I'm not 100% sure that it's even compatible with T-Mobile given the bands but since T-Mobile works nicely here in Las Vegas (at least for me) and they're using more bands nowadays, I'm very interested in attempting to figure this out.

I went ahead and performed the Kies upgrade to 4.1.2 and it's working great so far, but again the same issue: the phone can't or won't see or access anything but these two older T-Mobile miniSIM cards - not anything else that I happen to have which includes two brand new T-Mobile microSIMs I ordered a few weeks back.

Could it be that perhaps the leaf-spring contacts inside the SIM slot are just not making contact on some of the other SIM cards that I'm trying to get recognized, or could this be something with the phone itself due to it being the International variant, or maybe it just not supporting the bands that T-Mobile happens to be using nowadays...?

Any help or info is greatly appreciated as I'd really love to get this thing up and running. If it means I have to get yet another SIM card from T-Mobile to get it working then that's what I'll have to do I suppose.

Thanks for any input...

Just for the record I popped the back housing (not the battery cover, I mean the back housing held down by screws) off just now to get a look at the SIM card slot itself, it appears to have a 3-2 configuration (meaning the 3 visible leaf-spring connectors and the other two are not visible unless you remove that back housing). Maybe a lead snapped off, perhaps? Seems like there should be 6 leaf-spring leads...

And after looking at parts on eBay it does seem like there should be 6, I guess one of them snapped off at some point with the previous owner and probably the reason they were selling it. Odd...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes