Remove All Ads from XDA
Honor View 10

[Q] Can't get LG G2 back to stock / unrooted

23 posts
Thanks Meter: 2
By tophy0, Junior Member on 18th February 2014, 02:38 AM
Post Reply Email Thread
Creating a troubleshooting thread to see if might be able to get some help on a big problem I'm having with my LG G2...

I'm trying to restore my VZ LG G2 to stock so that it can be returned (audio input is malfunctioning). I am currently running TWRP + CM 11 Nightlies on it.

When I enter download mode, I see the screen "Firmware Update" and it says "B99" and "Rooted" at the bottom.

When I use the R&D Test Tool + LGMobile Support Tool to try to restore to VS98011A_01.kdz, the software update runs on my computer as if it is pushing the update to the phone, but the phone itself shows no actual status change. It just sits there with 0% on the status bar.

When it finishes on my computer it says (on my computer) that the software update was successful. Unfortunately my phone boots into CM just like it normally does with all my apps and data there.

Based on some suggestions I have seen, I have tried manually changing to COM 41 and disabling the device as a modem in device manager -- does not make a difference.

I have no idea why no actual change is happening on the phone. Any suggestions?
18th February 2014, 06:24 AM |#2  
OP Junior Member
Thanks Meter: 2
Man, this is brutal. I thought that maybe the issue was that I was using the 3.10 LG United drivers instead of the 3.8 drivers, so I uninstalled 3.10 and installed 3.8.

Unfortunately now the LG G2 is recognized when it is in normal mode (running CM 11.0) but Windows shows "No drivers found" when I put it in download mode:

USB Composite Device: Ready to Use
CDC Serial: No drive found
CDC ECM: No driver found
LGE Android Phone: No driver found
Network Controller: No driver found

The last four all show up under "Other devices" in device manager with an exclamation.

Previously I was at least able to see the LG Android VZW etc. etc. under COM/Ports with 3.10 drivers installed.

I am burning so much time trying to figure this out. Mayday, mayday!
18th February 2014, 06:58 PM |#3  
OP Junior Member
Thanks Meter: 2
For anyone that may come across this thread in the future, I want to share what ultimately worked.

I followed the TOT method instructions in this thread:

It was just as easy as the KDZ method, but actually worked! Here are the two things that seemed to make a difference:

1. I installed the _Verizon_ LG drivers referenced in that thread
2. I manually changed to COM41

Following all instructions in that thread everything worked like a charm.
The Following User Says Thank You to tophy0 For This Useful Post: [ View ] Gift tophy0 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes