Remove All Ads from XDA

[Q] Stuck Updating - S-ON, Re-Locked, 4.4 KitKat T-Mobile

4 posts
Thanks Meter: 0
By Sparkydsm, Junior Member on 23rd February 2014, 05:17 PM
Post Reply Email Thread
Tried updating to
MD5 = 5f4a4c44524a38297ea18d0b0a9d099f

and must have gotten partially finished (or tried something else first and failed), because now i'm stuck on 4.19.531.10, with S-ON, Relocked.

I can get into fastboot, but otherwise doesn't boot normally (shuts off after logo), and I can't flash any 4.3 RUU's via command line zip ( fails ) or windows exe (error 155)

here's my getvar:
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.56.0000
(bootloader) version-baseband: 4A.24.3263.09
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 4.19.531.10
(bootloader) version-misc: PVT SHIP S-ON

(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0713000
(bootloader) cidnum: T-MOB010
(bootloader) battery-status: good
(bootloader) battery-voltage: 4274mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-4dab9d12
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.039s

So I'm pretty sure I know what to do, but not how!
1. I partially succeeded, so i'm on 4.19.531.10 now,
2. can't flash 4.3 stock without s-off
3. Can't get s-off without working rom? (hboot 1.56)

All the information is in front of me but not sure what to do. My ideas are:

a. S-off my hoot 1.56 from recovery and proceed.
b. wait for a 4.4 t-mo RUU exe to try.
23rd February 2014, 06:13 PM |#2  
nkk71's Avatar
Recognized Developer / Recognized Contributor
Flag Beirut
Thanks Meter: 7,128
Donate to Me
Originally Posted by Sparkydsm

All the information is in front of me but not sure what to do. My ideas are:

a. S-off my hoot 1.56 from recovery and proceed.
b. wait for a 4.4 t-mo RUU exe to try.

you can't s-off from recovery, you need a working ROM.

unlock using HTCdev, then get a ROM onto your phone, and then proceed to s-off using rumrunner or firewater
23rd February 2014, 06:58 PM |#3  
OP Junior Member
Thanks Meter: 0
I know I can't. But I know I need to, to be able to downgrade.

So i've updated my plan of attack:

1. Unlock first. Did this already
2. re-install twrp because it wasn't my recovery anymore. Done.
3. flash custom rom with at least version '4.19.531.10' so it doesn't count as a downgrade ( downloading a 4.4 rom now.)
4. Once booted, continue getting s-off however I need to.
5. Back to 4.3 RUU
6. Try OTA Again.

I'll post an update once i've tried this.
23rd February 2014, 07:50 PM |#4  
OP Junior Member
Thanks Meter: 0
Well it seemed to succeed installing ViperOne, but then hung at boot with the " HTC One Beats Audio " screen.

Trying a different rom. Also noticed that it's 4.19.401.8 for viper one not 4.19.531.10, am I failing because I'm still trying to downgrade without s-off?

Should I try Stock 4.4.2 Google edt.?
24th February 2014, 12:04 AM |#5  
OP Junior Member
Thanks Meter: 0
And i think i've got it solved?

So the original problem: Was S-ON and unlocked to begin with, failed 4.3 -> 4.4 update. Unable to downgrade with ruu (s-off required)

Steps to resolve it:

1. Unlock. ( I relocked while i was trying stuff)
2. Install custom recovery (twrp)
3. Flashed Android Revolution HD 4.4 (counted as equal instead of downgrade, has root & prereq for s-off)
4. S-off hboot 1.56 with firewater
5. flash 4.3 ruu zip (this step flashes stock recovery also)
6. copy/push/otg 4.4 ota zip to /sdcard/Downloads
7. reboot into stock recovery, flash ota? (still on this step, wish me luck.)
24th February 2014, 01:29 AM |#6  
Senior Member
Thanks Meter: 517
Donate to Me
Should let it do it automatically without pushing but sure..

sent from my mobile device
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes