Remove All Ads from XDA
Honor 9 Lite

[Q] Cellular Data not working no matter ROM installed

17 posts
Thanks Meter: 1
Post Reply Email Thread
Hello powers that be! I'm a total noob and really wish someone would help me. I currently using an XT910 which was a gift from a friend in China. For some reason my cellular data (both 2G and 3G) won't work on any custom ROM. It only works fine on the Stock ROM slot. I've tried Mokee, SlimKat, LiquidSmooth and MIUIv5.
Whenever i go to the mobile network settings, i see the correct APN is selected but it just won't connect or even show the 'E' or 'H+' icons. I'm currently in Nigeria but i doubt if its a location issue.
PLEASE HELP.. I don't have access to Wi-Fi so mobile data is all i've got, Thanks in advance!
20th February 2014, 12:12 PM |#2  
Toborex's Avatar
OP Junior Member
Thanks Meter: 1
Seriously? No one? Come on guys
20th February 2014, 10:08 PM |#3  
Senior Member
Thanks Meter: 74
Change preferred network type under mobile network????

Sent from my XT912 using xda app-developers app
21st February 2014, 10:10 AM |#4  
Flag Szczecin
Thanks Meter: 21
I have similar observation. After first boot everything is ok. Phone connects perfectly. Next I reboot phone and I can see that phone is connected for 1s not connected for ~20s (looped). What I noticed: additionally Airplane mode switches on and off. All of this without any touch to phone.
I observed this in every KK ROM I tested. There were a few times that phone worked properly after restart.
I always install new ROM on SS Slot 2 that is wiped (system, data, cache, dalvik) before installation.
Today I installed latest MoKee nightly (02.19) - result as described above.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes