Remove All Ads from XDA
Honor View 10

Updating to 4.4 Kitkat constant problems

5 posts
Thanks Meter: 0
By jd_guthrie, Junior Member on 24th February 2014, 04:47 PM
Post Reply Email Thread
Hello everyone. This is my first post with my first problem from my first android phone. Please exercise some patience with me. When kitkat was pushed to the HTC One (T-Mobile) the install failed miserably. When I thought it was done it booted into recovery and just stayed there. I did a hard reboot and the splash screen was all crazy and the HTC boot screen was off colored and it was stuck at the boot screen. Obviously something was corrupted. I ran RUU for 4.3 to get back and flashed twrp and restored from my back up. All is well. I downloaded the OTA (I forget where but I believe somewhere on here) in an attempt to flash it from the stock recovery. Those were the instructions on that post. I ran RUU for 4.3 again to be completely fresh. I get to stock recovery and when I select to "apply from phone storage" I get an "invalid CID" error and the phone reboots. I ran "fastboot getvar all" and my cidnum= T-MOB010. What is the deal? That cid is correct, isn't it? I am also S-On with a "relocked" bootloader. I had to relock in order to run RUU because I was getting error 155. What am I missing? Why is it doing this?
24th February 2014, 08:10 PM |#2  
OP Junior Member
Thanks Meter: 0
Okay. I really need help guys. My phone is completely wiped and I have NO OS!! I side loaded Android Revolution kitkat and I'm getting errors with that. I can't unzip it!! I'm screwed guys. Please. Any help at this moment!! I'm desperate.
24th February 2014, 10:48 PM |#3  
OP Junior Member
Thanks Meter: 0
I was able to get out of this hell hole. I was able to run "adb push" and move my nandroid backup from my pc to the phone and restore.

What do I have to do to update to kitkat??? Why did check cid fail? I never changed that. What else could change it?? I had a stock recovery installed but the OTA failed still. Do I have to have the "right" stock recovery? I'm unlocked, rooted and S-off. Do I need to fix something else? Do I need to "relock" first? Is updating to kitkat even possible?? (sarcasim) The information seems to be scattered all over the place. I can not be the only one unlocked, rooted w/ S-off and trying to update my OS.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes