Remove All Ads from XDA

+ [Solution] Empty 0% battery bootloop on 4.3 Xperia T

29 posts
Thanks Meter: 9
By, Junior Member on 20th February 2014, 04:34 AM
Post Reply Email Thread
I still didn't get my OTA in Croatia so I decided to try this. I came across an issue which wasn't present in official 4.1.2. and maybe someone had (and still has) it as well. I'm posting this here so that it's easier to find if anyone has this issue and wants to fix it.

I have installed 4.3 on my Xperia T with Locked Bootloader and everything worked fine. However, I have come across a issue and managed to solve it as well. Here's what happened and how I solved it, maybe it helps someone with same problem.

Today my battery drained to 0% and the phone shut down. Now when I plug it in to wall socket to charge, red LED goes on and it turns the phone on. Once Android boots I can see 0% in status bar and it starts shutting down again. Then it boots up again and loops like that. I remember that on 4.1.2. there would be a battery icon when it was completely empty and it wouldn't boot the system. Now it just loops. This didn't happen on official 4.1.2.

I have Googled for solutions and have tried this.

"1. Press and hold down the power key on the right side of the phone. If the battery status LED flashes red, try plugging the charger into the phone at the same time as you are pressing and holding in the power key.
When plugging the charger into the phone there is a risk that nothing happens – no red battery status LED as indication of charging, or nothing appearing on the screen.
If the charging doesn’t start, follow the instructions under To let the charger be plugged in for 24 hours.
2. If the charging starts, keep charging the phone until it’s fully charged. Indication of charging is that the battery status LED lights up in red, or that the SONY symbol appears on the screen and then the LED lights up."

Problem was that when I left it to charge (screen off, LED red) it would start booting again after a few minutes. When it started to boot, I would press volume up + power key to shut it down and keep charging. I had to do this many times (10 to 15) and it was very frustrating but it worked in the end. I decided to let it boot and voilà! it showed 1% battery and didn't start shutting down. Now it's charged to 2% and keeps on charging.

The lesson - don't EVER let your Xperia discharge below 1%, you'll have a world of problems.
The Following 4 Users Say Thank You to For This Useful Post: [ View ] Gift Ad-Free
26th February 2014, 01:31 AM |#2  
Junior Member
Thanks Meter: 0
I have the exact same problem, except that it doesn't even charge when my screen is off.
26th February 2014, 10:22 AM |#3  
thedisturbedone's Avatar
Senior Member
Thanks Meter: 382
Great find! I used a separate way to get it to charge but I can assure you it gave me a world of pain! Thank you for sharing
26th February 2014, 12:25 PM |#4  
WhiteNeo's Avatar
Senior Member
Thanks Meter: 4,103
Donate to Me
What about the Xposed module DisableCriticalBatteryShutdown?
If or devices were no longer turning off again after booting when battery is 0%, the problem would be fixed, right? :P

Sent from my LT25i using xda app-developers app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes