Remove All Ads from XDA
Honor View 10

[Q] CIFS issue on GT-I9505 Android 4.3

2 posts
Thanks Meter: 0
By mabel111, Junior Member on 28th February 2014, 10:45 PM
Post Reply Email Thread
Hi guys,

I know that this topic was discussed many times for many different phones. The best thread I read was the topic about "troubleshoot-cifs-on-android". (I can't put link here due to antispam policy ) ... Posted by norbert on October 7, 2013 – 19:45.

I have following device:
Android 4.3
Version I9505XXUEMKF
Kernel version:3.4.0-2082040

I really need to run CIFS mount on this device, so I decided to root it (even with the warnings about warranty).

I used Kingo Android ROOT which allowed me to access the system as root. Via terminal I tried many options how to mount the NAS storage, but all failed.

With the post mentioned above I reached following status:
- I used this command which seems to be the closest to the solution:
mount -o unc=\\\\\\Multimedia,username=test -t cifs // /mnt/cifs/Multimedia
- I received error message "mount: Permission denied". I also saw creepy pop up with "Blocking unauthorized access" in the back.

The same result I received using CIFSManager with parameters:
Share path: //
Mount point: /mnt/cifs/Multimedia
Username: 00
Password: <blank>
Options: noperm,unc=\\\\\\Multimedia,username=t est

I attach the log file from dmesg (when mounting via terminal command) - starting with following:
<7>[11106.274108] /home/se.infra/jenkins1/workspace/HUDSON_JELLYBEAN43_JFLTE_EUR-OPEN_TRUNK/android/kernel/fs/cifs/cifsfs.c: Devname: // flags: 32768
<7>[11106.274169] /home/se.infra/jenkins1/workspace/HUDSON_JELLYBEAN43_JFLTE_EUR-OPEN_TRUNK/android/kernel/fs/cifs/connect.c: Username: test
<7>[11106.274169] /home/se.infra/jenkins1/workspace/HUDSON_JELLYBEAN43_JFLTE_EUR-OPEN_TRUNK/android/kernel/fs/cifs/connect.c: file mode: 0x1ed dir mode: 0x1ed
It seems that CIFS module reached success:
<7>[11106.514465] /home/se.infra/jenkins1/workspace/HUDSON_JELLYBEAN43_JFLTE_EUR-OPEN_TRUNK/android/kernel/fs/cifs/connect.c: CIFS Session Established successfully
But then something happened I can't understand with my poor Android skills.

Is there anybody who got CIFS up & running on GT-I9505 with Android 4.3?

How can I identify the blocking issue?

Thank you in advance.
Attached Files
File Type: txt test2.txt - [Click for QR Code] (128.0 KB, 11 views)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes