Remove All Ads from XDA

[Q] Almost bricked i9505g moving off CM10.2

5 posts
Thanks Meter: 0
By freakypenguin, Junior Member on 5th March 2014, 01:47 PM
Post Reply Email Thread
Ok, so newb here, but I have been searching the xda boards for the last 24 hours, spent a lot of time in the i9505g dev sub forum, but I cannot post there. So this seemed like the next best place.

I am running a GPE S4, i9505g. A while back I flashed CM 10.1 on to it, the jfltexx version. This changed my build.prop file and all was working fine. However, I decided that I wanted to try out 4.4 direct from google, so I tried to flash different versions of the rom, OTA, 'cleaned up' stock roms, etc... none of them would flash via clockwork or twrp. They all failed due to the build.prop being changed to reflect the jfltexx instead of whatever existed before the CM10.1 flash. So, I used adb to load up a stock build.prop (I think). After that, I could not boot anywhere past recovery and had no adb access other than sideload. Somewhere late in the evening I finally found a glimmer of hope and got my CM10.1 build.prop back on the phone and reflashed 10.1 then updated to 10.2.

So now, I'm back to a working phone on CM10.2 but I would like to revert back to stock GPE android 4.3 then use OTA to get to 4.4... I cannot find any specific information on the i9505g which apparently is different than the regular i9505. I believe I made a nandroid backup of my original system when I originally flash CM10.1, but that was months ago and the PC I had then no longer exists, so I have no original backup.

Currently running TWRP, CM10.2, and I have Odin 3.07 on my pc. Can anyone help me figure out how to get back to factory stock on the i9505G?

EDIT/UPDATE: Huzzah! I may have finally found the original nandroid backup. It appears to be a full backup from Oct... I just can't remember if it as a stock backup or a CM10.1 backup. Either way, I may have that to use to get back to stock. Is there anyway to dig into the backup files and see what rom it is?

UPDATE 2: I made a copy of the system.tar.a file in my nandroid backup, renamed it to .tar, and opened it with 7zip. According to the build.prop file in that folder it is a jgedlte build, so that should be the stock nandroid, though it did say version 4.2.2, which I guess is better than nothing. Looks like I may be able to restore that nandroid to get the phone back to stock.

UPDATE 3: So, the original nandroid backup I found, appears to be corrupt. First CWM told me the MD5 checksum didn't match. So I used md5sum to regenerate the nandroid.md5 file. (md5sum *img > nandroid.md5) When I tried to apply it, CWM reports: Error while restoring /system!
So, I restored the nandroid backup I made of CM10.2 today and now it boots into CWM continuously. Going to flash TWRP over CWMR and see if it will boot into the os. :/

5th March 2014, 07:49 PM |#2  
OP Junior Member
Thanks Meter: 0
Fixed it all up finally. Found a 4.4.2 odin tar, full image, was able to push that out via odin and the phone booted write up.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes