Remove All Ads from XDA

[Q] Phone dropped in water, USB Port stopped working

8 posts
Thanks Meter: 1
By mertcanekiz, Junior Member on 30th October 2013, 11:29 PM
Post Reply Email Thread
Hi. I have a Samsung Galaxy S3 Mini. Today I dropped it in water. It wasn't really that deep so the phone wasn't in water all the way. I picked it up right away and looked if something happened and it seemed like it was working. But now, I was about to charge it but I realized that I can't. The phone doesn't charge. I tried different charger and everything but still nothing. I guess it's because water got in the USB port. I haven't any other option but to send it to repair because I flashed custom roms so guarantee or the original service wouldn't do it. I'm wondering what is to be done, if I can do it myself, and if I can't, how much will it cost? Thanks.
30th October 2013, 11:55 PM |#2  
Senior Member
Flag londonderry
Thanks Meter: 215
any time a phone or other elec. device is dropped in water, it should take out battery and put in rice (in sealed bag) for 2 days immediately or in somwhere warm at around 180-200 for hours.. any time you apply power to wet circuits you burn crap out.. you are most likely sol and i wouldnt bother sending it in they will probably charge you close to 200 .. just move on and buy a new phone.
7th March 2014, 03:03 PM |#3  
Junior Member
Thanks Meter: 0
Just though I'd add my 2 cents to this thread,

If the phone is working fine but it just won't charge or do anything with the mini usb connection, then the contacts for the mini usb to the motherboard may have a little corrosion on them. Clean then up and you should be good to go!
8th March 2014, 02:51 PM |#4  
Carlyle_f's Avatar
Senior Member
Flag Cape Town
Thanks Meter: 384
Donate to Me
My friends swear that immediately turning it off and putting it in a bowl of rice works, the rice draws liquid out I think. They're reckless and this always worked for them. You should try it before you take the phone in. Leave it in rice for 2 or 3 days.

EDIT: sorry, I didn't check the date of the OP
Sent from my U.S.S Enterprise NCC-1701-A
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes