Remove All Ads from XDA

Cant update Android..

14 posts
Thanks Meter: 0
By gymfreak81, Junior Member on 10th March 2014, 03:44 AM
Post Reply Email Thread
I have a rooted Moto G phone. It is android 4.3 , I cant update it to 4.4.2 Kitkat for some reason.

I saved Kitkat to the SD Card, loaded into Recovery mode on the MOTO, then tried to install Android 4.4.2 from the .zip file
saved on the SD card in my phone.

I cant get this to work and i tried to install CARBON ROM the same way with out any results.. it says ERROR and fails to install.

Any help would be greatly appreciated.

ALSO does android need to be updated to 4.4.2 to install CARBON ROM?
10th March 2014, 10:58 AM |#2  
Junior Member
Flag Morrona
Thanks Meter: 1
I don't know but maybe can help...
I could update successfully to last minor 176.44.1 update only after flashing stock recovery.img from my exact stock ROM.

after rooting process on KitKat motoG my recovery was modified, restoring the stock one worked for me. I just updated ota normally in WiFi without problems.

after that I flashed cwm recovery.
10th March 2014, 11:45 AM |#3  
Thanks Meter: 13
I restored to stock recovery and removed root. After that applied KitKat OTA, then flashed custom recovery and re-rooted.

Sent from my Moto G using Tapatalk
10th March 2014, 05:42 PM |#4  
Junior Member
Flag Morrona
Thanks Meter: 1
this involve wiping of all data and a factory reset, so first try just restoring the stock recovery.

If not working make a good backup first.
10th March 2014, 06:43 PM |#5  
Dexxon's Avatar
Flag Dörentrup
Thanks Meter: 17
If the phone is rooted, OTA updates do not work afaik...
10th March 2014, 07:26 PM |#6  
Senior Member
Thanks Meter: 145
Originally Posted by gymfreak81

ALSO does android need to be updated to 4.4.2 to install CARBON ROM?

Flashing a ROM overwrites system partition completely. You could have android version 1 running and still just flash another ROM
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes