FORUMS

Guide and tips for getting and using A2DP

171 posts
Thanks Meter: 1
 
By RonnyGydar, Senior Member on 12th June 2006, 03:24 PM
Post Reply Email Thread
It seems I am not the only one that have had "some pains" when using A2DP (="Stereo Bluetooth" / "Wireless Stereo"-bluetooth profile).

I thought I write down some tips for getting A2DP to work, and how to minimize the issues people are having...and hopefully others will fill in their tips...and maybe even prove me wrong (I have been wrong before...but what are the odds of that happening TWICE!?":) ) on some points?

1. Challenge is getting a headset that supports A2DP, and works well with the Universal
I have had a pair of HP stereo headphones (these are only for music, does not have a microphone), a set of Motorola HT820 and a pair of i-Tech BluePRO. There are probably 20-30 other options as we speak (among other from Ericsson, Nokia, etc).

All the 3 ones I had worked with the Universal using A2DP to listen to music. Here are the PRO's and CON's for each of them from my point of view.

HP Stereo Headphones (same as Logitechs iPod BT headphones)
+ Clear and nice sound.
+ For "over the ear"-headphones, they were comfortable.
- Seems to be fairly sensitive for stuttering/lag/gaps when used for A2DP...at least is MY headset like that!
- Poor batterycapasity (approx 8 hours)
- Not an mini-usb plug (since the JasJar use mini-USB...less cables to bring)
- lacks a little bass wise (at least compared to the i-Techs)

i-Tech BluePRO
+ Seems to have fairly little prob with "lag/suttering" (my specific headset has almost no issues with it at least!)
+ Great bass (a BIG plus for me...I love techno-music:)
+ Great batterylife (approx 20 hours, and even more if you buy a 2500mah rechargable AA battery)
+ Can play very loud...if you want to that is (actually louder than my wired Koss headphones)
+ Uses 1 AA battery (I felt this was a CON first, but now that I have bought some 2500mah rechargable AA batteries, this actually is a "pro")
- "fuzzy" sound (compared to HP and Motorola HT820, the sound is slighty "fuzzy"...I noticed it when I swapped from Motorola to these, but have not noticed afterwards...so for HiFi people it might be a big CON, for me it was not).
- Reconnect not as expected (will not automatically reconnect to Universal when it is turned off and then on again)
- not very good for phonecalls (people are sometimes complaining it is hard to hear me)

Motorola HT820
+ Clear and nice sound.
+ Great microphone (people on other end say I am crystal clear, even when I walk outside)
+ Good batterylife (15 hours I think)
+ Charges over MiniUSB (hurrah, can use the Universal sync/charge cable)
+ Reconnects as expected (if you turn on the headset it will automatically reconnect with Universal)
- Seems to be fairly sensitive for stuttering/lag/gaps when used for A2DP (not an issue with phonecalls it seems)...at least is MY headset like that!
- ucomfortable to wear over time (after around two hours, they "hurt the ears", due to the way they hang over the ears...might be my ears though:)
- lacks a little bass wise (at least compared to the i-Techs)


I think that just about any person would chose the Motorola's over the i-Tech's anytime.

...but I am not everyone...so I personally use the i-Tech...and that is ONLY because of the "heavy bass", "loud soundlevel" and "closed earmuffs"...since that means I can listen to music/podcasts in even noisy environments and get what I define as "good sound" (="lots and lots of bass":)

[UPDATE 1. august 2006]
I used my Motorola's again when I was on vacation (have used only the iTechs for several months now), and suddenly had a lot of lag/stuttering again...an issue I thought I had resolved with registryfixes and new ROM's.
...but "suddenly" I could not walk around with my headset and listen to "gapless music in stereo"...I could not do a workout at the gym with them, even when the Universal was 2-3 meters away from me...I would get gaps/lags once every minute or so.

With my iTech's this problem is almost non-existent. ...I wrongly thought this issue was fixed on the Universal-side, with the latest ROM's I installed, so forth...but it seems that at least "part of the problem" was the headsets themselves (my Motorola HT820's and my HP headset seems a quite a bit worse off in this regard than my iTech's).

My conlusion...test before you buy, since the headsets ALSO can influence the amount of lag/stuttering you get (as this was not complex enough as it was)!!!!

I am "happy" with my iTechs...but wish they automatically reconnected to Universal when I turn them on...and wish they were as good as the Motorola's for phonecalls.
[END OF UPDATE 1. august 2006]



2. Get a ROM which supports A2DP
This should not be to hard today, you can for example install the latest QTEK ROM (I use the WWE/english ROM, not sure of status on the other versions). Jwright (a user on this forum) have made a custom ROM which also contains A2DP and PushMail, and I know there are quite a few other "official ROM's" with A2DP...but I do not have that overview.

I do not have a QTEK 9000 myself, but actually a "Norwegian i-Mate JasJar"...but I was able to install the QTEK ROM, and U should be able to do it too, regardsless of version of Universal you have. ...it might be a rough ride though, you might need to search these forum and read up on the Wiki pages on how to get around "DeviceID" and "CountryID" issues...but is IS solveable (later I might update this with some direct links to some of those guides posts).

[UPDATE 14.06.2006, tip from "cktlcmd"]
The following are the ROMs with A2DP and AKU2 support (Battery icon replaced Time):
****QTEK ROM (latest ROM)
****T-Mobile NL (latest ROM)
****JWright's Modified ROM (latest ROM)

The following is the only ROM with A2DP support (No AKU2) but with the Time icon still showing:
****JWright's Modified I-Mate ROM (1st test released ROM)


You can find a lot of different ROM installation files here; ftp://xda:[email protected]_Updates/

PS!
If You have an AKU2 ROM (the ones with PushMail), and do not have A2DP, you can add it with a patch originally made for the HTC Tornado. I have tried this myself with an Norwegian iMate AKU2 ROM that did not have A2DP...and it worked! :)
It should work on other Windows Mobile 5 devices also (as long as they have AKU2). Then you do not have to reinstall your device from scratch...with all the work that usually involves (in getting everything back to exactly you like it).

You can read about it, and download file from here; http://forum.xda-developers.com/view...ado+a2dp+patch


So how do I know if I have A2DP or not
When you have bonded with your A2DP-able headset, you should under "Bluetooth Setttings", under the tab "Devices", among other see your headset (for me this is listed as; "i.Tech BluePRO").

If you tap-and-hold this, you will get a context-menu that should contain "Set as Wireless Stereo", if you see that text, you have A2DP. I see for example the following;
  • Edit
    Delete
    Set as Hands-free
    Set as Wireless Stereo

If anyone reading this know a better/easier way to verify if one has A2DP, feel free to tell me/us...so it is easier for people to check this! :)


3. Choosing a musicplayer to use on the Universal with A2DP
OK, you have A2DP setup, you have a headset...which musicsoftware should/can you use.

In teory, you should be able to use whatever music software you use today, TCPMP, PocketMusic, MortPlayer, Windows Media Player, so forth. Cause all sounds is sent to the headset (but strangely MortPlayer struggles at least). But you might have problems with AVRCP (AVRCP bluetooth profile, makes it possible to change tracks and play/pause/resume the music from buttons on the headset...very convienient when the Universal is in the rugsack for example).


MortPlayer (exellent player...but A2DP-vise...unfortunately...no)
http://www.sto-helit.de/modules/wmpd...wcat.php?cid=4
I have always before used a musicplayer called MortPlayer.

The reason for using that one, was that it is incredebly tuned for "doing everything without taking out the stylus" (big buttons everywhere), and that it has an insane amount of options (you can for example set it to always start with a specific voulme, start playing the last song you heard, at the position in the song you left it, and when you quit the sound is set back to what it was before starting it. You can even tell it that a specific folder is "soundbooks", and then it will always remember last listened position of all files in it).

But with A2DP MortPlayer unfortunately does not work well, I get only sound on the left speaker, and the AVRCP buttons do not work. So MortPlayer I must unfortunately leave for now! :(


Windows Media Player (works...but I "hate" it:)
You can of course use the built in Windows Media Player. It works with A2DP, and it support AVRCP. There is two (and in my eyes BIG such ones) problems with WMP.

One reason is that is is unbelievably painfull to use in daily use...every time you start it, it "forgets" where you left off the last time, and you have to choose "Storage Card" (it seems to choose "Main Memmory" as default library on startup?), then find the album or playlist and play it...and the areas to click on the screen to do all this requires the stylus (or a "precision finger":).

Another reason, is that the play/pause/resume button is not working 100% for all headsets (my HP headset seem to work fine, the iTech and Motorola seems to only work once, then I have to click the next time on the Universal, and then it will work one again...not much use in realworld scenarios).

One big bonus with WMP is that it is already installed, and AVRCP and A2DP works "out of the box", nothing you have to do.


PocketMusic (great, AVRCP works flawlessly)
http://www.pocketmind.com/pocketmusic.htm
This is in my eyes a very good musicplayer for "the go", much like MortPlayer (even though I think MortPlayer is better...with a wired headset that is). It can be set up so that it contines exactly at the same point in the same song as you quit it the day before, and look and behold, AVRCP work with it...and not just that...here the play/pause/resume button works flawlessly (which it does not for WMP for some headsets it seems)...at least with all my 3 headsets.

I now use PocketMusic. The minus with it is that it costs money, but it is well worth it (for me at least). And you can test/use it for free for 15 days or something like that, so you can "test before you buy".


TCPMP (works, at least sound vise)
http://tcpmp.corecodec.org/download
I do not use TCPMP (I use it for video, were I believe it is THE player to use...but not for music...too much fidling with the stylus in my view, but that's just my opinion), so I can not say tomuch about it...but I tested and the sound worked at least over A2DP. I did not get the AVRCP buttons to work...but I have seen some people saying "on the web" that it is possible to use...but I do not "how".



4. Stuttering/lag when using A2DP
A2DP works great...but there is at least one issue that can put most people off, and that is that you can get some stuttering/lag in the sound. This can feel like this; You listen to your music, all is great, and suddenly there is no sound at all for a second or so, and suddenly the music continues, and then it is silent, and then it plays again. Sometimes you get one of these, and no problems for hours, and other extreemes can be that the twice every second the sound disapears and appears all the time, until you give up, curse the "damn A2DP", and in best case puts your headphones hard on the table. :)

REASON 1: Universal is strugling (CPU/RAM)
One reason for stuttering can be that the JasJar is struggling performance vise. To help with this you can do the following;
1. Install "A2DP priority patch"
This is done by adding a value to the registy of your Universal, you can manually enter the registry value, or use a CAB-file or a REG-file someone has prepared.
http://forum.xda-developers.com/view...a2dp+lag+patch

2. Kill background programs (or do a soft reset)
When you get this problem, it can also be because of some program working in the background.

But as we all know...there is some rare moments when our PDA's/phones' just seem to be living its own life. I have had occations when there is no programs running, and the phone stills is incredible sluggish, and I can see the menus getting drawen painfully slow. ...and of course, if your PDA gets one of those "I-do-not-want-to-coperate"-moments, A2DP or your music player will struggle...but then it really is not an A2DP issue, since you most likely would have had the same problem with a wired headset.


REASON 2: Radio connection is disturbed (object obstructing signal, WiFi nearby, so forth)
It seems that the connection can be very sensitive for obstructions (between Universal and headset). For example, if I have the Universal in a pocket in my pants, while walking around...I can sometimes get lag/stuttering all the time. If I put it in my rugsack, it stutters very rearly...and if I hold it still in my hand in front of me (OK, you look very stupid doing this:), it will not stutter at all.

But if I put it on the table, and walk around the room, and even walk into another room, and will be around 10 meters away, it might not stutter. So I assume it depends of what kind of material is between the Universal and headset, and also the amount of it...but also it will depend on the "general amount of radio disturbance" in that area (an area with a lot of WiFi equipment/Bluetooth signals might be a lot worse that an area with little or no such equipment).

In general for me, I have practically no problems when I walk around with it in my rugsack, and generally have a little (and sometimes a lot of) stuttering when I have my universal in my pant-pockets.

I also have no disturbance at home or at the Gym (as long as I have the Universal around 8-12 meters away from me), but at work (Telecom company with lot of radiotransmitters around) it works at best 3-4 meters maybe. All of this without obstructions.


"Hearing the root-cause"
If you have done all this, and still get stuttering, here is a tip for understanding WHERE the issue is. It seems that you actually can hear if it is an "Universal struggling"-issue, or an "radio-disturbance" issue...

If the sound is continuing exactly where it left of, when it stopped...then it is the Universal that is struggling. Meaning, if you hear a podcast and they say; "The president of...[silence]...the united states of America, Bush said today...", then it is the Universal that is struggling, and you could try to close some programs a soft reset or similar.

If the sound does not continue exactly where it left of, like; "The president of...[silence]...Bush said today", then it is an issue with radio disturbance in some form.

...and with this knowledge, you hopefully will be able to resolve it.


Hope this extreeemly long post will be usefull for someone, feel free to comment/correct/add info and experiences...so that "A2DP newbies" get an easier start than us! :)
The Following User Says Thank You to RonnyGydar For This Useful Post: [ View ] Gift RonnyGydar Ad-Free
12th June 2006, 09:41 PM |#2  
Pantaloonie's Avatar
Senior Member
Thanks Meter: 9
 
More
Excellent post, just what I need to know as I have just ordered the Motorola HS820.
Two questions - am I correct in thinking that the latest official UK O2 XDA Exec Rom does not include the a2dp profile?
And if so, which ROM should I go for - I don't need push email, and I want as little branding as possible.
Thanks.
13th June 2006, 09:34 AM |#3  
RonnyGydar's Avatar
OP Senior Member
Flag Oslo
Thanks Meter: 1
 
More
Hi Pantaloonie,

I do not know if "latest official UK O2 XDA Exec ROM" have A2DP, hopefully someone else reading this will know and respond.


There is a lot of official ROM out there (ftp://xda:[email protected]_Updates), but the only two english ROM's that I know for certain that have A2DP is (but I think there are more now);[WARNING] It seems that my link above is NOT to the ENGLISH version, but to a GREEK version of the ROM!!!!
I will try out myself at home, and change the link to the correct ROM...but can't do this at work...


And if you want to have minimal operator customization, I think the QTEK ROM's are fairly basic ones. And in worst case you can softreset when the installation starts installing all the apps from ExtendedROM when you do an installation of the ROM. But then you will also often miss some utillities that you actually want to use.

Another alternative is to "cook your own ROM" (I did this for my old Qtek9090), but then you can expect to spend a day or two reading up on this forum, downloading the tools for doing this, and creating you own ExtendedRom. If I get hold of Jwrights customized ROM, I will update my post here though.
13th June 2006, 10:45 PM |#4  
cktlcmd's Avatar
Senior Member
Farmington, CT; Jackson, NJ
Thanks Meter: 11
 
More
Excellent post!

The following are the ROMs with A2DP and AKU2 support (Battery icon replaced Time):
****QTEK ROM (latest ROM)
****T-Mobile NL (latest ROM)
****JWright's Modified ROM (latest ROM)

The following is the only ROM with A2DP support (No AKU2) but with the Time icon still showing:
****JWright's Modified I-Mate ROM (1st test released ROM)
14th June 2006, 12:18 AM |#5  
Senior Member
Thanks Meter: 12
 
10101010
More
Excellent post dude...you just saved me a ton load of internet research...you should do this more often...keep up the good work
14th June 2006, 12:46 PM |#6  
RonnyGydar's Avatar
OP Senior Member
Flag Oslo
Thanks Meter: 1
 
More
cktlcmd, thanks for the great input!!! :)
Have added it to my original post, so that others reading this post, don't have to scan through all comments...not a problem right now...but might be harder when more people start giving tips and comments! :)

Pantaloonie, cktlcmd and youmeus, thanks for the positive feedback! Hopefully at lot of other will fill this with more experiences and tips! ...and I will try to summarize all tips into my original post, so that it is as up-to-date as possible!
14th June 2006, 05:15 PM |#7  
Senior Member
Thanks Meter: 0
 
More
This topic is under the Universal category, however everything listed in the initial post should be applicable to any device trying to get A2DP to work cleanly.

However, I believe there are several of us that have tried each of the suggested solutions and it still hasn't resolved the lagging issues. I'd be interested in learning about any debugging tools that could be used to figure out the root cause. Are there any kind of system tracing tools available or even a tool that could list process/thread and device driver priorities that could provide some clues. Is there some way we can determine if it's cpu limited, bandwidth limited (cpu to bt i/o?), interrupt related, etc.

I would also be interested in figuring out if there are any tweeks that can be applied to the bta2dp.dll driver other than setting the priority. For example what is the Flags parameter in the registry used for? It's currently set to 65538 on my device. Could it be a buffer size? A baud rate? Anyone know?

It seems to me if we figure out the root cause then it could even help people where A2DP is working so-so, but only if they close all apps, overclock, etc. To me doing these things is just a workaround until we figure out the real issue.
14th June 2006, 05:56 PM |#8  
Retired Forum Moderator
Flag Vancouver
Thanks Meter: 19
 
More
HS820 aren't stereo. HT820 Are... Great post otherwise
14th June 2006, 06:13 PM |#9  
Senior Member
Thanks Meter: 12
 
More
Aah...one can very easily use the Tornado A2Dp posted in the prophet section with any of the AKU2 ROMs...I hv successfully used with Nokia HS 12W...with FM..it works...really works
15th June 2006, 12:23 AM |#10  
RonnyGydar's Avatar
OP Senior Member
Flag Oslo
Thanks Meter: 1
 
More
hdubli, are you saying that it actually works with Universal also? Do you have a direct link to the file in that case, so others easily find the correct file.

ady, thanks will correct post, HT820 it is, I remembered it was someting with "820" at least! :)

hannip, I put it under Universal since I only had experience with Universal in this regard, and also the ROM's...but if I get some tip/help/assistance from others... ;)

hannip, I seem to have almost no problems anymore, and most of the times I have had lag/stuttering, it seems to have been "radio disturbance" that have been the problem...now I have learned when it work and when it doesn't, and have very seldom any problems. for example having JasJar in rugsack when I walk, and not in frontpocket of pants. ...and due to the size of JasJar you need a rugsack anyway! :)

That said, I agree it certainly wouldn't hurt to understand more about root-causes.

Will try to find out name of a app I used a year ago, which showed CPU utillation, memmory and processes.

I must quit now, my girlfriend complains about the irritating clicking from the keys of my JasJar here... :)
15th June 2006, 09:28 AM |#11  
RonnyGydar's Avatar
OP Senior Member
Flag Oslo
Thanks Meter: 1
 
More
Hannip,

Searched for a tool (and tested all I found) you asked for...here is results...

Performance Monitor (does NOT work on WM5...made for Casio E-10x...veeery long time ago I had one:)
http://www.thumbsupsoft.com/maphtm/pemon.html
Downloaded, installed it on JasJar. Starts up, but only shows ProgramMemory and MainMemory, but no graph, nor any threads)...and does not completely uninstall either!


MemMaid 1.6 (Works on WM5)
http://www.dinarsoft.com/
I have this myself, is not really an monitoring app, but it also can show all running processes (not programs, like built in simmilar program for this) and their memmory usage. On my JasJar when builtin app shows 1 running app (MemMaid), MemMaid shows 17 running processes (and that they take up approx 22MB!).
Great app...but gives no info about CPU utilization unfortunately.



PMH TaskManager (does NOT work on WM5)

http://www.phm.lu/products/PocketPC/TaskMgr/
This one looked really promissing; "Display the running processes with their IDs, number of threads, CPU time, priority and complete path...".

But also is an PocketPC 2002 app, and on the JasJar it only shows process name...no info on CPU time, priority, so forth! :(



SuperTasks 2.0 (YEEES, it works...and do what we want!!!)
http://www.pocketgear.com/software_detail.asp?id=14661

This one shows CPU time pr process, and a graph for total CPU usage (among other), much like task manager om your PC (if you're one of the Windows-people that is:).

It has a 30 day trial, so you should be able to test a lot before deciding to buy or not.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes