FORUMS
Remove All Ads from XDA

Galaxy S4 Screen Rotation Stopped Working!

341 posts
Thanks Meter: 71
 
By Ritvars, Senior Member on 21st March 2014, 03:13 PM
Post Reply Email Thread
Everything worked fine until I installed official 4.4.2 ROM from Sammobile. Screen rotation just stopped working and the only way i can get it to work is by installing "Adaptive Rotation Lock (free)". Well, i think it's because of that, because with 4.3 everything worked fine.

I installed official 4.4.2 on March 15th. Later on 19th it just stopped working. My I9505 is rooted, used it to record videos from screen and deleting some bloatware, i wasn't dealing with no custom crap, just a plain root, but i red that this voids warranty either way. I really don't know what to do, after checking CPU-Z my sensors seem to be fine:
And yes, i checked if Auto-Rotation setting is ticked in notification bar, restarted phone, turned off for several seconds and turned back on. Downloaded an app called Sensor Tester from Soaus which allowed to calibrate accelerometer, that didn't work either. I even smacked with care the back of my phone to get sensors back in their place (if they didn't already) and that didn't work too.

Looking forward to your help, thanks in advance!
The Following 4 Users Say Thank You to Ritvars For This Useful Post: [ View ] Gift Ritvars Ad-Free
 
 
21st March 2014, 03:26 PM |#2  
debbuger's Avatar
Senior Member
Flag Dubai
Thanks Meter: 180
 
More
Quote:
Originally Posted by Ritvars

Everything worked fine until I installed official 4.4.2 ROM from Sammobile. Screen rotation just stopped working and the only way i can get it to work is by installing "Adaptive Rotation Lock (free)". Well, i think it's because of that, because with 4.3 everything worked fine.

I installed official 4.4.2 on March 15th. Later on 19th it just stopped working. My I9505 is rooted, used it to record videos from screen and deleting some bloatware, i wasn't dealing with no custom crap, just a plain root, but i red that this voids warranty either way. I really don't know what to do, after checking CPU-Z my sensors seem to be fine:


And yes, i checked if Auto-Rotation setting is ticked in notification bar, restarted phone, turned off for several seconds and turned back on. Downloaded an app called Sensor Tester from Soaus which allowed to calibrate accelerometer, that didn't work either. I even smacked with care the back of my phone to get sensors back in their place (if they didn't already) and that didn't work too.

Looking forward to your help, thanks in advance!

U have deleted Samsung hub that's why screen rotation stopped working...

https://mega.co.nz/#!X94VhRhT!cXBmuh...5cVmZitt8rVOqw
Download this and paste it in system/lib/ and change its permissions to 0644 i.e. rw-r-r and reboot..gud luck

Sent from my GT-I9505 using Tapatalk
The Following 71 Users Say Thank You to debbuger For This Useful Post: [ View ] Gift debbuger Ad-Free
21st March 2014, 03:53 PM |#3  
OP Senior Member
Thanks Meter: 71
 
More
Quote:
Originally Posted by debbuger

U have deleted Samsung hub that's why screen rotation stopped working...

https://mega.co.nz/#!X94VhRhT!cXBmuh...5cVmZitt8rVOqw
Download this and paste it in system/lib/ and change its permissions to 0644 i.e. rw-r-r and reboot..gud luck

Sent from my GT-I9505 using Tapatalk

I can't paste it in system/lib because File manager or Root Explorer won't let me.
Could you write step-by-step how to do this?
The Following 4 Users Say Thank You to Ritvars For This Useful Post: [ View ] Gift Ritvars Ad-Free
21st March 2014, 04:13 PM |#4  
Member
Thanks Meter: 6
 
More
Quote:
Originally Posted by Ritvars

I can't paste it in system/lib because File manager or Root Explorer won't let me.
Could you write step-by-step how to do this?

Is your phone rooted?
21st March 2014, 04:46 PM |#5  
OP Senior Member
Thanks Meter: 71
 
More
Quote:
Originally Posted by jupkeyope

Is your phone rooted?

Yes, my phone is rooted.


P.S. Just tried Root Browser and everything worked! Thank you, debugger!
21st March 2014, 06:00 PM |#6  
Joku1981's Avatar
Senior Member
Thanks Meter: 920
 
Donate to Me
More
Quote:
Originally Posted by Ritvars

I can't paste it in system/lib because File manager or Root Explorer won't let me.
Could you write step-by-step how to do this?

  1. Acquire the apps you want OR DELETED.
  2. Place them on SD card.
  3. Open Root Explorer.
  4. Go to /sdcard where you placed the .apk files.
  5. Press the menu button to 'Multi-Select' and copy. (Or individually long press and copy)
  6. Select the .apk files you placed on your SD card.
  7. Go back to the " / " folder. (Press the [...] dots at the top)
  8. Open the 'system' folder.
  9. Open the 'app' folder. (You should now be in /system/app)
  10. MOUNT AS R/W! (By default you are mounted as R/O)
  11. Paste the .apk files.
  12. REMEMBER THE NAMES! (To change permissions)
  13. Scroll to each .apk and long press individually. (Options should pop up)
  14. Scroll to and press 'Permissions'.
  15. New screen should say (ALONG THE TOP) Read - Write - Execute (ALONG THE SIDE) User - Group - Others.
  16. Change the .apk permissions to match all your other system app permission. (Check READ for ALL. Check WRITE for USER. Leave Execute UNCHECKED)
  17. Press OK.
  18. Go to phone Home Screen.
  19. Reboot.
The Following 11 Users Say Thank You to Joku1981 For This Useful Post: [ View ] Gift Joku1981 Ad-Free
11th April 2014, 03:54 AM |#7  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by debbuger

U have deleted Samsung hub that's why screen rotation stopped working...


Download this and paste it in system/lib/ and change its permissions to 0644 i.e. rw-r-r and reboot..gud luck

Sent from my GT-I9505 using Tapatalk

Many thanks, it worked for me also (GT-i9500)!

After the 4.4.2 update I kept receiving messages Samsung Hub had crashed and it didn't auto-rotate anymore.
15th April 2014, 02:54 AM |#8  
Kevin70707's Avatar
Junior Member
Thanks Meter: 0
 
More
Thanks. It worked for me as well.
21st April 2014, 06:36 PM |#9  
Senior Member
Flag Hamburg
Thanks Meter: 51
 
More
Quote:
Originally Posted by debbuger

U have deleted Samsung hub that's why screen rotation stopped working...

https://mega.co.nz/#!X94VhRhT!cXBmuh...5cVmZitt8rVOqw
Download this and paste it in system/lib/ and change its permissions to 0644 i.e. rw-r-r and reboot..gud luck

Sent from my GT-I9505 using Tapatalk

Thanks a million worked also for me!!
23rd April 2014, 12:54 AM |#10  
RiTCHiE007's Avatar
Senior Member
Thanks Meter: 284
 
More
Awesome this fixed the screen rotation! Any quick way to get airview of the folders to work also?
10th May 2014, 05:58 PM |#11  
Member
Thanks Meter: 0
 
More
Sprint sphl720?
Will this work on the sprint l720? I have same issue

Tried it today, it works!!!!!!!!!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes