Remove All Ads from XDA
Honor View 10

[Q]"I:Can't format unknown volume: /external_sd" in CTRecovery

3 posts
Thanks Meter: 0
By antoine38130, Junior Member on 24th March 2014, 02:14 AM
Post Reply Email Thread
Hi XDA Users,

Before asking help, i would like to say that I'm newbies, i'm little bit lost here, and i don't know if i have the permission to post this question here. Sorry if i make a mistake

I have an error when i try to launch a CWM(Edify) script. :

I:Can't format unknown volume: /external_sd

I tried to change updater-binary(No change) and I tried to use empty updater-script: this error is not linked at a command line in my script(No change)

The recovery used is Carliv Touch Recovery porting on my device(Wiko Highway)(link: he works without problems, but i noticed that i have some bad line in my /etc/fstab. I tried to repack a new .img whith good /etc/fstab version but my device was stay on boot image. I have restore my first recovery.img

My question is: CWM try to mount all partition in /etc/fstab at start of updater-script? And if yes, can i disable this function.
I you see something for my recovery problems, i take all tips!

Thanks for you attention,
PS: I have forgot to say that I'm french with a very bad english level, but don't worry, i work on this x)
27th March 2014, 12:13 AM |#2  
OP Junior Member
Thanks Meter: 0

I have finally found the error in my recovery: my Fstab has some bad device. Now, it's work!

but update-binary will not work

I have this:

-- Installing: /sdcard/
Finding update package...
I:Update location: /sdcard/
Opening update package...
Installing update...
E:Error in /sdcard/
(Status 0)
Installation aborted.
I:Can't partition unsafe device: /dev/block/mmcblk0p8
I:Can't format unknown volume: /external_sd
I:Can't format unknown volume: /emmc

For info, this is my /etc/fstab:

# mount point fstype device [device2]

/boot emmc /dev/bootimg
/cache ext4 /dev/block/mmcblk0p6
/data ext4 /dev/block/mmcblk0p7
/misc emmc /dev/misc
/recovery emmc /dev/recovery
/system ext4 /dev/block/mmcblk0p5
/sdcard vfat /dev/block/mmcblk0p8
/sd-ext auto /dev/block/mmcblk0p2

I feel that the error is in recovery... but i don't found an fonctionnal ROM for my phone(remember: Wiko Higway)

Thanks for you attention
27th March 2014, 05:55 AM |#3  
Junior Member
Thanks Meter: 2

Sent from my One S using xda app-developers app
23rd June 2014, 10:58 PM |#4  
Clandaries's Avatar
Senior Member
Flag Süderstapel
Thanks Meter: 71
Can you please give me your recovery for the Highway?

Thank you.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes