Remove All Ads from XDA

[Q] HSPL4 critical error: USB not found

2 posts
Thanks Meter: 0
By hrvoje.b, Junior Member on 6th April 2014, 05:35 PM
Post Reply Email Thread
Hello everyone, glad to join the community. I need some help on getting WP7 to work on my HD2.
I got the phone from a friend and it has already been flashed (hope it's the right word)
and it has some version of android running on it. I downloaded HSPL4 and ran it as administrator. Got some errors about missing .dll's
but I resolved it by installing Microsoft Mobile Device Center as activesync is not available on Windows7. So, I start the boot mode
by holding volume down and power buttons but I don't get a three coloured screen, instead I get a b/w menu which looks like this:

Build: Feb 1 2011 03:46:07
by Cotulla 2011
Boot menu:
1. Boot WPH
2. Boot AD SD
3. Boot AD NAND
4. USB MassStg
5. USB Flasher
7. AD Hardreset
8. AD Recovery
9. Tetris
10. Services
11. Reset
12. PowerDown

Then I connect the USB cable to computer and start HSPL4 as admin again and i get an error message saying:

Flow: 00000001
Error code: 00000002
Description: USB Connect failed!

I tried selecting options 4, 5 and 6 (after which computer recognizes the phone as a USB device) and starting HSPL4 but
i got the same error. Tried googleing for answers but without much success as everyone gets the three coloured screen
in boot mode except me. The device says the current ROM is CyanogenMod-7-11072011-NIGHTLY-Desire[TyphooN_v3.7.5-MAGLDR].
Hope someone knows a way past this. Thanks!
6th April 2014, 09:45 PM |#2  
dxdy's Avatar
Senior Member
Thanks Meter: 2,018
Donate to Me
you messed up something....

to flash HSPL4 you must boot to bootloader, not to magldr....

turn off phone and hold volume minus and power together until show three color screen... look picture in attachment
now you flash HSPL4....

also in my signature is tutorial how to flash WP7 to HD2....
Attached Thumbnails
Click image for larger version

Name:	WP_20130619_002_resize_resize.jpg
Views:	25
Size:	43.5 KB
ID:	2672232  
7th April 2014, 12:14 AM |#3  
OP Junior Member
Thanks Meter: 0
Thanks for the reply. I just can't get that boot screen.. However, something seems to be wrong with that volume down button. When I'm in the MAGLDR menu and I press it sometimes it selects an option, sometimes it says:

from MicroSD
load zImage
K: /zImage
SD kernel open failed

and sometimes it highlights the option below (goes down, which I guess is what it is meant to do). The volume up button work fine, it goes up in the menu. When I boot Android both button work fine and turn the volume up and down. Any ideas? Is there any other way to get to that three color screen?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes