Remove All Ads from XDA
Honor View 10

[Q] How to flash Android rom on Aliyun OS Umi Cross C1?

3 posts
Thanks Meter: 1
By pixel9, Junior Member on 31st March 2014, 04:20 AM
Post Reply Email Thread
Hello, this is what I've tried:

1.Root YunOS with "framaroot.apk" --> no success (so I can't flash a new recovery with "Mobileuncle_MTK_Tools 20140111v2.9.9.apk")

2.Root the phone with program --> no success (certainly it's because there is no usb debugging mode in Aliyun OS).

3.Flash the phone with "MTK flashtool" (Sp flash tool) --> I can only flash the original AliYunOS rom in download mode.
with Android roms I get the scatter file problem: "pmt changed for the rom it must be downloaded"

3.1.Replace the recovery in the Yunos rom with the cwm recovery and flash only the recovery --> playing with the battery, I saw the cwm recovery one time for 2 seconds but the phone continue the starting procedure. Afther that I can only access the Yunos testing recovery.

3.2.Replace the scatter file from an Android rom with the scatter file from Aliyunos and flash with Android rom --> phone still booting for more than 15 minutes. So I flashed the yunos rom again.

4.Flash an Android rom with Sp flash tool in "firmware update mode" --> problem with the preloader: bricked phone. I flashed the yunos rom again to save the phone.

5.Install ADB drivers then launch "MtkDroidTools" --> Android adb device not found error (so apparently I can't create a scatter file with MtkDroidTools).

What other options are available? I'm in dispute with the seller because the phone was supposed to be in Android version with multilingual and Google play.

Thank you for proposing a debut of solution.
6th April 2014, 06:36 AM |#2  
Paulzt's Avatar
Flag New York
Thanks Meter: 5
Donate to Me
A 150. Technology exam? Or enjoyable product
Omg... Please tell me there's a less complicated way. I just won a umi cross on eBay for half the retail but reading this i gear my enjoyment ended there. The seller days out comes with Android 4.2 i know nothing of Alyn can you install play store or other store? Is it possible to use the phone if it is Android in a simple way or do i now have home work to do? Oi, how do i even root the device or connect to a computer, I'm panicked please advise on lay mens terms.....
6th April 2014, 08:37 AM |#3  
OP Junior Member
Thanks Meter: 1
Partitions problem
In Sp flash tool, I did a format+download to avoid the "pmt changed for the rom it must be downloaded" error. I installed this rom (the flashable version):

But there are 2 problems:
1. the IMEI are invalid with this Android rom --> should be resolved with "Mobileuncle_MTK_Tools" (but I didn't try, because of the 2nd problem)

2. the partitions are not right: 5GB for the applications and 1.3GB for internal SDcard. In Aliyun I have 25GB storage.
So I flash it again with the Aliyun OS rom:

I read that there could be problems with "SP flash tool" using version 3.x with scatter file bigger than 1KB or using version 5.x with scatter files less than 1KB. For me only SP flash tool 5.x works good.

So if someone have a suggestion to try to solve the storage partition problem, I'll be very happy. Thanks in advance.
The Following User Says Thank You to pixel9 For This Useful Post: [ View ] Gift pixel9 Ad-Free
26th April 2014, 02:22 AM |#4  
OP Junior Member
Thanks Meter: 1
Thumbs up Bye Bye YunOS
Hello, to solve the storage partition problem, just erase the internal SD: the 23GB are back.

For the IMEI are invalid problem, install "Mobileuncle_MTK_Tools":
Sim1: at+egmr=1 7 "35xxxxxxxxxxxxx"
Sim2: at+egmr=1 10 "35xxxxxxxxxxxxx"
Start imei by 35 or 36 (total 15 digits)

but before I needed to flash an other ROM with the recovery cause the "settings" crashes.

The phone is working good now with android, the only small problem is that you need to enter the IMEI after every "factory restore".

3rd April 2015, 04:42 PM |#5  
Junior Member
Flag Ashland, OH
Thanks Meter: 4
Originally Posted by pixel9

In Sp flash tool, I did a format+download to avoid the "pmt changed for the rom it must be downloaded" error.

This information solved my "pmt changed for the rom it must be downloaded" error. I was able to successfully flash my phone that I have been struggling with for a week and a half. Thank you!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes