Remove All Ads from XDA

Xperia S : How To Recover Phone To Stock By Using Flashtool.

175 posts
Thanks Meter: 211
By dwarkesh2492, Senior Member on 28th May 2013, 10:03 PM
Post Reply Email Thread
This is a beginners tutorial on how to revert back to STOCK firmware using Flashtool by @Androxyde

I'm sure there must have been many more tutorials on this, but this post is modified for simplicity with image for new users.

Has Your Mobile
  1. Soft Brick
  2. Not Responding After A Mistake In Flash
  3. Only LED Shows Green/Red/Blue Light
  4. Bootloops Troubling?
  5. Make the phone as good as new.
Then this guide will help you to recover your phone back to STOCK.
Things You Need Before Returning To Stock
  1. Flashtool
  2. ftf file for your Xperia S


Here is a stock rar file for Xperia S --->
[FIRMWARE][6.1.A.2.45] World Generic

Now Lets Get Down To Business.

Flash it using latest version of Flashtool
1. Download the Firmware
2. Extract the .rar
3. Put the .ftf in <flashtool directory>/firmwares/
4. Run flashtool
5. Click flash or thunder icon

6. Flash mode, Ok
7. Select from left panel the correct firmware --> Lt26i 6.1.A.2.45 SG Generic (Your ftf File in firmware folder)
8. Click Ok!

9. OK ... Wait for a connection pop-up
10. Do not follow the instruction there, Just Connect Xperia S holding volume down button
11. Wait for installation to complete (When no more loading and the log shows Reboot and enable android debugging)
12. Unplug device and reboot
13. Close flashtool.

That Should Bring You Back To Stock!
If after that if you really want to bring your phone back to factory comdition.

For Making the Phone As Good As New
RELOCK THE BOOTLOADER that should do the trick!

For Relocking Flash the Attached "Xperia S Relock File" Given below
In The Same Manner Following Every Step.
In Step 7 Select Relock Xperia S File
And You Are Done!

Hit Thanks if it Helped You!
Attached Files
File Type: zip - [Click for QR Code] (63.0 KB, 484 views)
The Following 9 Users Say Thank You to dwarkesh2492 For This Useful Post: [ View ] Gift dwarkesh2492 Ad-Free
29th May 2013, 01:17 PM |#2  
s-X-s's Avatar
Senior Member
Flag Dublin
Thanks Meter: 193
This is covered in Soft Brick recover thread......
29th May 2013, 04:21 PM |#3  
dwarkesh2492's Avatar
OP Senior Member
Flag Pondicherry
Thanks Meter: 211
Originally Posted by s-X-s

This is covered in Soft Brick recover thread......

Yes You Are Right!

But Any New User Will Not Like To Go Through Such A Long Process If HE/SHE is feeling helpless.

Again this is Modified for new users..

Giving them exactly what they want is top most priority.

Dwarkesh Soren
The Following User Says Thank You to dwarkesh2492 For This Useful Post: [ View ] Gift dwarkesh2492 Ad-Free
6th June 2013, 02:44 AM |#4  
Thanks Meter: 0
My acro s become brick during relocking process...pls hlp me
it only shows "sony".
1st August 2013, 12:56 PM |#5  
Junior Member
Thanks Meter: 0
Ok I did fallow the directions. My ion does not respond to anything so first i removed the battery wire from motherboard for 5 minutes then I locked in on position volume - and connected it to pc with flashtool running with my firmware ready to flash. after few hours when I check it flasing tool command lanes have"Flashig finished, disconnect the device,for the flashing tool unknown sources and debugging must be check in,device connected in flash mode,device disconnected. Have only red led and pc companion does not recognize the phone . when disconnected from pc phone is dead nothing works. need help please.
22nd August 2013, 10:00 AM |#6  
Junior Member
Thanks Meter: 0
me too
Originally Posted by giri143

My acro s become brick during relocking process...pls hlp me
it only shows "sony".

my sl too, you on phone until out off battery.

next reflash tock rom for your phone.

you try
good luck!!!

p/s: sorry, limited English!
23rd August 2013, 06:41 PM |#7  
Thanks Meter: 28
To say that this is for bricked phones is inaccurate. These are the steps to follow when you want to flash any ROM, for whatever reason,even if your phone is working flawlessly.
15th March 2014, 08:04 AM |#8  
Junior Member
Thanks Meter: 0
Reseting Sim-unlock counter???
Will this also reset the sim-unlock counter????
20th March 2014, 08:56 PM |#9  
Junior Member
Thanks Meter: 0
will this work if i am currently using:

Xperia S - LT26i
Android Version: 4.1.2
Baseband Version: 8660-AAABQOLYM-314010-28
Kernel Version: 3.0.55-FXP+ root@ubuntu #1
CyanogenMod Version: 10-20121221-UNOFFICIAL-nozomi
19th May 2014, 04:00 PM |#10  
Grigoris0r20r's Avatar
Senior Member
Thanks Meter: 13
hello.yesterday i tried to restore my DRM keys and when it said to restart my phone i pressed yes.then if closed down and now it wont open.sometimes when i press the power button the bottom lights up but the screen remains black.and sometimes when i hold volume up or down i get a flashing green light.just vibrations and nothing.i tried to flash back the firmware but still screen.and all that after i restored the drm keys.i was on existenz 2.5 rom.please can you help me?and now i just see the bottom right corner of XS lighting up and then off and then light it destroyed?
Post Reply Subscribe to Thread

flash stock xperia s firmware, using flashtool

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes