Remove All Ads from XDA
Honor 9 Lite

Bootloop after CM install. Won't restore backup, mount /data, flash stock

7 posts
Thanks Meter: 0
By guismo, Junior Member on 9th May 2014, 12:03 AM
Post Reply Email Thread
Hi developers. I am sorry for posting this. I spent the last week trying to solve it by myself with no hope. This is my second time installing something on a phone, but it is my only phone, so I beg anyone for a help...

-What I did:

Some days ago I downgraded to this ROM C5503_10.1.1.A.1.310_GLOBAL-LTE.ftf to use DoomLord rooting script. I did it with flashtool for linux and I applied his .bat step by step in the terminal since windows would not detect my phone.
It worked. I had root for some days, but I was still annoyed by sony default android. So I decided to install Cyanogenmod.

I unlocked the device with sony official system and wen't straight to this instructions, before the first reboot

I booted succesfully in CWM, followed everything as it says there. But that's where weird things happened:
-The problems:
-The backup
I tried, it wouldn't mount /sdcard. Since I don't understand much about this, I thought it was normal. The next choice was sdcard1, I backed up there. Or so I thought...

-The factory reset
I factory reset, again, not mounting sdcard. Here is the message that shows when I try this now:
can't mount /data!
Error mounting /sdcard.android_secure
Skipping format...
Data wipe complete.

Since it said it is complete, I went on installing the zip file from my sdcard1. Both CM 10.2.1 (dogo, the right one for my phone) and the appropriate GAPPS.

Now it loops on the CM loop animation and I have to remove the battery...

-The restore problem
It still boots on the recovery mode. So I tried recovering my backup from sdcard1. But the image name is 1970. And it says "md5 mismatch"

I tried flashing again the stock rom with flashtool. The proccess goes on but nothing happens. I still have CWM and the boot loop.

I read elsewhere someone with a similar problem who solved using sony "emma" software. I installed it, it won't even recocnize my phone.
It recocnizes that there is a phone, but don't know which one.

But that has alway been the case with windows. I haven't been able to do anything in windows other then accessing the sdcard (when the phone worked).

Is there something I can do? I imagine that somehow, for some reason, the /data and /sdcard partitions got corrupted. I imagine I would need to repartition this and install again, but I have no idea how this happens on phones...

I can mount /system /cache and /storage/sdcard1. just /data I can´t. Says "error mounting /data"

This is my only phone and a vey recent $400 thing. I was very stupid to do that withouth a replacement and really need this phone. I greatly appreciate any help...
9th May 2014, 02:22 PM |#2  
OP Junior Member
Thanks Meter: 0
I found this post searching the internet. Is it possible that this would solve my problem? or would it finish bricking the phone?


Here's what you'll need:

Working recovery, basic knowledge of adb & the shell
Parted (download here)

Note also that I had run unrevoked forever (so my phone was S-OFF) ... I'm not sure if that's required or not.

So, grab parted from the link above. Now you need to extract the individual binaries from the .zip (the 6 files in the sdparted folder within the zip), ideally to your android-sdk\tools directory. Now push all 6 files (adb push [file] /sbin/). Next, we need to make them useable, so go into the shell (adb shell). Change to your /sbin/ directory, and run: chmod 0755 <file> on each of the 6 files.

Now, we need to fix the partitions. This is assuming that the partitions are there, just the wrong format (which is what happened to me .. I accidentally made them FAT32 instead of ext). So, run the following: parted /dev/block/mmcblk0 mkfs ext2. It will ask if you want to continue, hit yes. When it asks for the partition number, enter 1. Next, when it asks for the format, enter ext2. Let it do its thing. Now, once it's done, run parted again. This time, enter partition 2 (everything else is the same).

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes