Remove All Ads from XDA

[Help] Galaxy Note Power Button Not Working Right After Changing Of Battery

46 posts
Thanks Meter: 0
By afiyy, Member on 1st March 2013, 04:01 PM
Post Reply Email Thread

I just change my Stock battery to Anker Battery after knowing that the previous battery is bloated .

After changing to Anker Battery , all of a sudden my Power Button is not working.

Before that everything works fine.
1st March 2013, 04:20 PM |#2  
dsmas's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 252
Re: [Help] Galaxy Note Power Button Not Working Right After Changing Of Battery
Try with another battery.

Sent from my GT-N7000 using xda premium
1st March 2013, 04:32 PM |#3  
OP Member
Thanks Meter: 0

Try with another battery.

Sent from my GT-N7000 using xda premium

it is still the same .
1st March 2013, 05:35 PM |#4  
OP Member
Thanks Meter: 0
tried factory reset still the same
21st March 2013, 06:58 AM |#5  
awe215's Avatar
Flag Philadelphia
Thanks Meter: 36
Did you turn off your note before swapping batteries?

Were you running a custom rom?

I had the same thing happen to me. I have two batteries (stock and anker) and switch between them everyday. Two weeks ago, I switched them out and it won't turn on for longer than 3 seconds.

From what I have read, it is a faulty power button issue. It could just be you need to get a stock battery. It could be something worse. Update this thread and let us know how it turns out.

---------- Post added at 04:58 AM ---------- Previous post was at 04:15 AM ----------

In the 15 minutes since responding to you, I fixed my phone (it seems).

I took the back off (again!) as per the how-to youtube video....

Then I took some tweezers....

and wiggled the crap out of the power button. Side to side, back and forth....I wiggled with some force. I half hoped I would bust the damn power button off and just use usb to start the thing up....a working note, even crippled by usb start up, is better than none right?

So, needless to say, I fiddled then checked it with a battery...fiddled and checked it with a battery and when I could check it with a battery, where it wouldn't buzz and shut off immediatley, I knew I was getting somewhere.

I am back in CM 10.1 with Flap kernel.

The moral? Grab the tweezers!
2nd May 2014, 12:51 AM |#6  
Junior Member
Thanks Meter: 0
faced the problem few days back and power button started working now
i had got the same issue when i switched to these batteries, i did not want to open the case. I tried the charging in usb and taking the battery off etc. But those things did not work. I was constantly using the wall charger which comes with these Ancher batteries. But for few days I started using usb charging for phone with laptop. It strangely seemed to fix my power button. But not sure if it will help someone..but worth a try.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes