Remove All Ads from XDA
Honor 9 Lite

(Novel Length) Updating SM-T320 (8.4") firmware via KIES

160 posts
Thanks Meter: 33
By Wotta, Senior Member on 14th May 2014, 04:05 AM
Post Reply Email Thread
So I regularly checked for a firmware update in the Settings - General - About. And starting maybe two days ago it went from telling me my device was up to date, to telling me that the quota was over and I could try again later or try KIES.

Tomorrow never comes.

So I tried KIES. On the Macintosh, which is mostly where I live.

KIES installs. The SM-T320 is seen by AFT (when enabled), and KIES sees it in the sense that it knows something it cares about is connected... it tells me "Connecting...". Forever.

Removing AFT, reinstalling drivers, rebooting tablet, nothing solved this.

So, when in doubt, try Windows. Windows is that obnoxious, often slightly drunk friend with the muscle-T-shirts, too much B.O. (body odor for non-Merkins) and a swagger... that crass and unsophisticated guy that you've always kept in touch with, and who is reliable... if unsavory... in many situations.

Anyhow, so log back into Samsung/KIES, but this time on Windows, and install the latest....

Freshly installed off the website, KIES started right up. And told me there's an update available. Like, seriously?! I just downloaded you! The update has today (05-13) as part of the announcement, though the version (I later determined) is apparently 3.2.14034_17. Funny it wasn't on the site.

No problem. (Or, as your crass, unsophisticated Windows box with a bad mullet might say, "No Problemo".) Let it update itself. This didn't take long. Maybe 30 seconds.

And then, when prompted, I connected the SM-T320 to the Windows box running the new KIES and did get the firmware update notice:
A new firmware version is available. Upgrading may improve the performance of `GALAXY Tab PRO(SM-T320)'. Do you want to upgrade?
Current firmware version : PDA:NAI / CSC:NAI (XAR)
Latest firmware version : PDA:ND3 / CSC:ND3 (XAR)

This lead to a dialog that I need to install the USB driver before updating the connection... and need to disconnect the device for that.

For those of you keeping score, we have now struggled with the Mac version, surrendered, installed the Windows version from the website, installed the mandatory optional update to the newest Windows version (from G_d knows where), and now are being told our driver is out-of-date... all in 20 minutes!

The driver download-and-update install took maybe 20 seconds.

Plugging the SM-T320 back in resulted in the same update message again... new firmware yada yada yada. And the option to install this new firmware.

Selecting "Yes" resulted in a FAKE spinner over a greyed dialog. In other words, not the normal hazed-over dialog with a pea-sized spinner, but like actual dark-grey filtering over a dime-sized graphic pretending to be a spinner. Who the zark programmed this? Did this really seem like a good idea? Just give us an hour-glass and be done with it!

This grey screen lasted a long time. Well, probably a minute, by which I mean, like, sixty seconds and not the kind of minute that today's teenagers have within 45 milliseconds. And then it popped up... and consent box.

Are you still counting reinstalls and acceptances?

This box has a rationally-sized license agreement (okay, it's long, but only eight sections. Signing your soul over is optional, and they only require your second-born, not the standard first.)

But it also has two radio-button sets, for required information exchange (IMEI/MEID, SN, etc., none of which falls into the violation of privacy arena) and optional (crash data, sexual identity, I.Q., annual income, primary STDs.) You have to accept the former, and may decide on the latter.

And then, I am no not kidding, yet another box requiring acceptance!
The following features are included with this update:
· Restricted profile added for Multi User Mode
· Samsung Apps widget
· Hancom Office widget
· Other stability improvements

Thank you for choosing Samsung!
Surely we're ready, you say. In fact, your humble correspondent can truthfully state he's beyond ready, having at this point finished off two Margaritas and a Chocolate Martini. He may, in fact, be a bit toasted. But no, the sad truth is, there's more.

This Windows box had never seen a Samsung or KIES before. It's my dev box, not my daily driver. So I don't know if normal, mere mortal, folk will be hit by this but I got another mandatory install... Admin Delegator by Mobile <something> ltd.

This doesn't show as an admin* file on the disk, nor in the Control Panel installed programs list. I couldn't find it after giving it permission to install at the UAC prompt. But it must have done something, because I was, yet again, prompted to unplug, restart and replug the SM-T320.

Still counting? I think we're up to around 15 installs, prompts and restarts. For you greybeards out there, this is Windows 95 type stuff.

At this point it started doing the install. Which probably took about 15 minutes, despite being on a blazingly fast static sync-DSL.

The end result is:
  • Kernel 3.4.0-1263708
  • Tue Apr 8 14:49:36 KST 2014
  • Build Number: KOT49H.T320UEU1AND3

The primary difference so far? I'm out an hour.
Post Reply Subscribe to Thread

firmware, hell, kies

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes