Remove All Ads from XDA

Problem with Wifi or USB tether on LG Motion

2 posts
Thanks Meter: 2
By jayyx, Junior Member on 17th January 2013, 11:07 AM
Post Reply Email Thread
I have searched but could not find any thing related and there is no specific forum for this device. The problem is when I connect my laptop using the Android Wifi or USB tethers, I can only access HTTPS sites. If I try to hit a HTTP site, they give the general 'could not connect' error. I have tested to ensure I can hit both HTTP and HTTPS sites from my phones browser. I have the same issue using multiple different Wifi and/or USB tether apps. Any advice or guidance would be greatly appreciated.

With LG Motion (MetroPCS) I am able to browse HTTPS sites but can not browse HTTP sites when using an Android Wifi or USB tether app.
17th January 2013, 11:26 AM |#2  
OP Junior Member
Thanks Meter: 2
I did some more research and found that MetroPCS is now blocking tethering traffic

"Their filtering is based on HTTP user-agents. If your user-agent matches a known user-agent that is not android it
will reject the traffic. Now there are two problems with this,

A.) If an unknown userAgent is passed or No user agent, your traffic is accepted.
B.) There are a bazillion TCP protocols that do not have user-agents.

So off the bat with no user-agent spoofing, all protocols work except HTTP, including HTTPS, HTTPS works out of
box because of its encryption."
The Following 2 Users Say Thank You to jayyx For This Useful Post: [ View ] Gift jayyx Ad-Free
8th March 2013, 06:30 PM |#3  
Senior Member
Thanks Meter: 50
Re: Problem with Wifi or USB tether on LG Motion
so it is safe to assume you are tethering w/o paying their $10/mo fee to allow thethering through you MetroPCS phone?

FYI, I feel that fee is a pretty high premium as it brings the unlimited 4g LTE use plan to $70mo. Still not that bad if you can make use of it. Extras like this bug me for some reason, but if they put it in the plan and just charged more I prolly would not think twice.

Sent from my Kindle Fire using Tapatalk 2
1st August 2013, 03:32 PM |#4  
Junior Member
Thanks Meter: 0
So I'm not Crazy
this had me pulling my hair out...

tethering was working for me- but then stopped mid-session. thinking it was due to network errors i just quit for the day... only to find tethering never working again.

tracert discovered traffic bouncing through near half a dozen 10.x networks before only finding "no replies". as you suggest, dns traffic worked (non http) and thus added to the confusion.

it appears i hit some usage threshold and http traffic was disabled. funny thing is i was willing to pay the $10/month tethering fee but was told i can't simultaneously have unlimited 4G and tethering on my account. i opted in favor of spending my $10 on unlimited 4G. i'm not necessarily a heavy network users but definitely beyond their 2.5 GB cap.

thanks for sharing and confirming i wasnt crazy thinking my tethering was broken.
25th May 2014, 06:06 AM |#5  
Junior Member
Thanks Meter: 0
MetroPCS 4g tether not allowing http sites fixed
Tonight, I found a solution for this same issue. I was not able to see this review except on the lg-ms770 phone I have with Android 4.0.4. After seeing the term userAgent, and how that seems to be the issue, I tested an Android tablet on my WiFi tether. It worked great! However, this laptop and my desktop could not surf using http.

As my terminology is out of date, and I am a bit overwhelmed at times by all this great achievement, I found something in the Google Play store called Chrome UA Spoofer. It let me change the user agent that MetroPCS sees when using Google Chrome on my Windows XP and 8 computers. Now, I can surf all http sites that I usually use at work. It's a little slow but I think that has to do with local 4G issues that seem persistent to all users of the services here where I live.

At least it helps me save the $10.00/mth I really didn't want to have to pay. I currently shell out $60.00/mth for my phone with "unlimited everything" service, but the http issue was really bugging me. Thanks to your posts and the key term userAgent which was needed for me to first understand the issue and then find a way around it.

Hope I can be helpful in the future.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes