Remove All Ads from XDA

Enable UMS (USB Mass Storage)?

4,413 posts
Thanks Meter: 995
Post Reply Email Thread
I I just bought a Kenwood car stereo deck that indicated on the box and in the manual that there was Android compatibility. Got the thing installed, plugged in my S5 with 128GB microSD, and I got "NA Device." I did some research and it turns out the damn thing doesn't support MTP. WTF? MTP has been around since ICS, maybe a couple years. I would think that a BRAND NEW car stereo would have MTP support. /rant

Anyway, I tried various apps on the Play Store, and SGS3 Easy UMS, and none of them worked. One or two mounted the external card as an empty CD-ROM drive. Is there any way to get UMS working?
29th May 2014, 02:36 PM |#2  
GuyInDogSuit's Avatar
OP Senior Member
Flag Antelope, CA
Thanks Meter: 995
Donate to Me
3rd June 2014, 12:02 PM |#3  
fffft's Avatar
Senior Member
Thanks Meter: 776
Originally Posted by GuyInDogSuit

Is there any way to get UMS working?

Well kind of.. sort of.. maybe.

You should be able to get UMS running, but I won't promise that you'll find it easy to do. Samsung doesn't really support the older UMS mode. Which is a shame.. while UMS is an older and more simplistic protocol than MTP it simply works with most devices. Still most of the blame lies with your stereo vendor which claims to support Android while eschewing MTP support, which is what most Android devices use..

Anyway, as you have discovered, Samsung basically has MTP and PTP. End users can pull down the notifications bar after connecting an USB cable to a device and click on the "Connected as.. " notification to switch between the two modes. Or you should be able to pull up the full USB options menu with the dialer (keypad) code *#0808#

As to getting UMS to work.. you can certainly do it if you are rooted and using a capable kernel.. i.e. a kernel that supports UMS, ntfs/hfs/hfs+, etc. If you aren't rooted, you will have to experiment with different third party apps (and possibly update your stock firmware) until you find a combination that works. Also keep in mind that UMS is only likely to give your stereo access to the SD card in your phone.. not the phone's internal memory.

Some apps to try include:
Easy UMS -
SG USB Mass Storage Enabler -
USB Mass Storage - Google Play store

3rd June 2014, 02:38 PM |#4  
GuyInDogSuit's Avatar
OP Senior Member
Flag Antelope, CA
Thanks Meter: 995
Donate to Me
I've tried several UMS-enabler apps. The most they could do was make an empty CD-ROM drive appear in My Computer. I've been using Blaze kernel but it doesn't seem to make a difference. Easy UMS just says "External card not mounted.... could not get path of external SD card. Maybe it's unmounted?"

Sent from my Galaxy S5.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes