Remove All Ads from XDA

A solution about GPS and Ingress in LG L9

19 posts
Thanks Meter: 2
By Kasprom, Junior Member on 30th May 2014, 12:20 AM
Post Reply Email Thread
I just want to share some conclusions and workarounds/solutions for GPS and Ingress app problems I've encountered almost a year and made some tests through this time.

I am using p760. Last year, when I had stock JB 4.1.2 I found out about Ingress, and I fell in love with concept of this game.
However, my phone, to be more precise GPS refused to work properly with Ingress app. It wasn't able to hold a GPS location, it drifted a lot, and overall it was searching for signal way more time than being fixed. Since this game heavily depends on precise location, it was a huge frustration to play it. At the same time apps like Endomondo, maps, etc worked flawlessly. I googled various solutions as far non-rooted phone allows, and some apps, nothing worked.
At the same time I tried Ingress I was researching about Cyanogenmod and other projects alike. I thought it might come in help.
After moving to CM 10.1.3 (4.2.2) the same story repeated. A rooted phone gave new options to try new things, but nothing helped again, no modifiying gps.conf file thousand times, nothing.
CM 10.2.1 (4.3) (I was on this for few months, didn't care about GPS that much since it was winter) and some builds found here based on CM 11 (4.4) were complete disaster, GPS refused to work at all, again I went through tons of GPS apps, gps.conf and other gps related system files modifying, nothing helped. Only app, which was able to get fix to multiple satellites was "GPS Helper". Leaving app open for 10 minutes under clear sky, it slowly got fixes up to 8 sattelites. After that other apps worked with GPS for few minutes, but the effect quickly faded away and all satellites were lost eventually.
Then after clearing cache/dalvik cache I returned to my 4.2.2 backup and what a suprise! After booting Ingress as a first app, it quickly found my location and held it quite good with no noticable problems for like 20 minutes. No searching for signal, no drifting.
When I closed Ingress and turned off GPS toggle and later booting up Endomondo, it wasn't able to get signal, it kept searching.
Closed Ingress, turned off and on GPS, booted Ingress, got fix, jumped to Endomondo and it also got excellent signal and worked fine.
Through testing on freshly installed 4.2.2 roms of Cyanogenmod and MIUI here is my assumption:
Ingress is a weird app which handles some kind of GPS related cache differently than any other app and requires some kind of privileged access. For Ingress to work fine with GPS it should be booted first after fresh install/cache+dalvik cache cleared. It will get GPS location, however a downside for this - you should boot later Ingress first to get fix if you need GPS for other apps. Currently I can confirm this only for Endomondo.

In other words, here is what you do step by step:
1) Back up your files, wipe data, cache and dalvik cache (or you can just wipe cache+dalvik cache on your currently installed rom and skip steps 2 and 2.1)
2) Install any Android Rom/backup up to 4.2.2. Avoid 4.3 and 4.4 Roms, if they didn't work for you, they will not work this time.
2.1) In case of backup, wipe cache + dalvik cache again
3) Boot phone. Be sure no any other app has used GPS after wipe.
4) Launch Ingress. Get GPS fix.
5) Now your Ingress should be much smoother. (As I said only downside - you should boot Ingress first to get GPS for other apps.)
6) To confirm that Ingress has influenced "GPS cache" by it's own terms, close Ingress, turn GPS off, reboot phone, turn GPS on, launch Endomondo. If app cannot find location and keeps searching, you are ok. Boot Ingress and use GPS for Endomondo after that.
7) In case if Ingress have the same issues as previously and Endomondo can find location by itself, do cache+dalvik cache wipe again and try from 3rd step again.

Hope this is helpful for somebody.
The Following 2 Users Say Thank You to Kasprom For This Useful Post: [ View ] Gift Kasprom Ad-Free
31st May 2014, 04:59 AM |#2  
no_un_bot's Avatar
Flag Guadalajara
Thanks Meter: 18
Originally Posted by Kasprom

2) Install any Android Rom/backup up to 4.2.2. Avoid 4.3 and 4.4 Roms, if they didn't work for you, they will not work this time..

Oh bummer, Im loving my p768g with the Resurrection remix ROM, 4.4.2 found here.
Nonetheless, thank you for sharing this workaround, Im sure many people who rely on GPS will find this most useful.
People like you make this great community what it it.
1st June 2014, 08:19 PM |#3  
Junior Member
Thanks Meter: 3
I think the developers will find solution for gps. But thanks anyway for great job. Sorry for bad English.!

Wysłane z mojego LG-P760 przy użyciu Tapatalka
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes