FORUMS
Remove All Ads from XDA

Z2 magnetic charging port loose

70 posts
Thanks Meter: 7
 
By roninr1c, Member on 2nd June 2014, 02:10 PM
Post Reply Email Thread
Hello all,

Any of you had any issues with the magnetic charging port on your Z2 coming lose? Mine has. Pulled it off the magnetic charging dock and the port was left of the dock.
 
 
2nd June 2014, 02:31 PM |#2  
Member
Flag Hong Kong
Thanks Meter: 1
 
More
Please post a picture

Sent from my D6503 using Tapatalk
2nd June 2014, 02:32 PM |#3  
Member
Flag chennai
Thanks Meter: 6
 
More
i dont have any issues with my port. i dont use dock.. but i have the magnetic connector.. the magnetic port is held by a clip in the other side of the metal frame, i think that might have released your port.. thats an easy fix..but u need to disassemble the phone..
2nd June 2014, 02:36 PM |#4  
OP Member
Miami, FL
Thanks Meter: 7
 
More
this is what came out...
Attached Thumbnails
Click image for larger version

Name:	DSC_0021[1].jpg
Views:	6991
Size:	135.2 KB
ID:	2776528  
The Following User Says Thank You to roninr1c For This Useful Post: [ View ] Gift roninr1c Ad-Free
2nd June 2014, 02:50 PM |#5  
Senior Member
Thanks Meter: 540
 
More
Return the phone at once to where you made your purchase. Insist on either a new phone or a full refund. No brainer.

Let us now how you get on. Good luck and stand your ground!

Ryland
2nd June 2014, 04:43 PM |#6  
SkyS1gn's Avatar
Senior Member
Flag ŐriszentpĂ©ter
Thanks Meter: 25
 
More
Quote:
Originally Posted by roninr1c

this is what came out...

LOL
3rd June 2014, 05:57 AM |#7  
Smartphoner's Avatar
Senior Member
Flag Alexandria
Thanks Meter: 98
 
More
Quote:
Originally Posted by roninr1c

this is what came out...

OMG. Even a junkyard magnet won't be able to do that with the phone!

Sent from my D6503 using XDA Premium 4 mobile app
3rd June 2014, 08:44 AM |#8  
Junior Member
Thanks Meter: 7
 
More
Haha, this is really awkward. I hope Sony will fix this for you - looks really like a problem on the manufacturing side.
3rd June 2014, 03:37 PM |#9  
biniek's Avatar
Junior Member
Flag Warsaw
Thanks Meter: 3
 
Donate to Me
More
I wonder if the water resistant capability is vulnerable because of this, can you see internals thru holes after the dock?
3rd June 2014, 03:41 PM |#10  
Senior Member
Thanks Meter: 129
 
More
Quote:
Originally Posted by sevoflurane

OMG. Even a junkyard magnet won't be able to do that with the phone!

Sent from my D6503 using XDA Premium 4 mobile app

It would, the magnetic port isn't soldered in, those two contact Strips Look like they just plug into something

Sent from my D6503 using Tapatalk
3rd June 2014, 06:02 PM |#11  
Member
Flag Busan
Thanks Meter: 41
 
More
Unhappy The same issue in South Korea.
Quote:
Originally Posted by roninr1c

Hello all,

Any of you had any issues with the magnetic charging port on your Z2 coming lose? Mine has. Pulled it off the magnetic charging dock and the port was left of the dock.


I'm sorry, bad English.
Several cases occurred in the same issue, even in our country.
But the problem is the fault of the customer, according to Sony service center.
Many people are angry, but they do not change attitudes.
Sony's quality control is questionable, but they do not recognize it either.
I hope you look forward to a good result. Please let us know results later!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes