Remove All Ads from XDA

[Q] Fastboot blues on the Moto X: is this the end?

4 posts
Thanks Meter: 0
By deadphonewalking, Junior Member on 4th June 2014, 06:11 AM
Post Reply Email Thread
Phone: Moto X / KitKat 4.4
Carrier: AT&T (XT1058)
Problem: Mysteriously stopped booting.
Good News: Fastboot is recognized.
Bad News: (bootloader) Flash write failure

Taking this guide as my playbook - I tried to flash on a stock OS. Here's the main spot from the thread I'm working from-

-- Solution #2 - Medium --
1) Download the stock SBF firmware for your pre-KitKat ROM (
2) Unzip the ROM and copy the files to your fastboot directory
3) Go into Fastboot mode (power button and vol. down) and type in:
fastboot erase cache
fastboot erase customize
fastboot erase clogo
fastboot flash partition gpt.bin
fastboot flash system system.img
fastboot flash recovery recovery.img
fastboot flash boot boot.img

The mission objective is simple: retrieve files off of sdcard and factory reset.

So with my mfastboot (not the android one), I'm trying to flash my stock OS back on so I can get a drive in windows and retrieve sdcard files. Actually, ANY OS back on at this stage of the game will be nice.

Things I have NOT done:
1. rooted the phone, or
2. unlocked the boot loader

If doing these will help, let me know.

So I get my download from for 4.4.2 & ATT carrier and unpack the files.

flashing for 'partition' in gpt.bin actually works (yay), but I get the above error ("Flash write failure") for system.img and recovery.img

It seems others with this problem changed cables and USB ports, so I tried that. No dice.
Someone said something about permissions, so I started my command window with administrator privileges, also no luck.
Unless, of course, they meant permissions on the phone side of things? Would that actually help?

So at this juncture if my SDCard died I can go for warranty because I never did any unlocking.
However, if the SDCard can be saved, I am willing to void the warranty and unlock. The data on it is valueable to me and yes a lesson I learned here is I should start using dropbox or equivalent service. Noted.

Should I unlock the phone and try mfastboot flash system system.img, or am I already dead?
4th June 2014, 10:45 AM |#2  
OP Junior Member
Thanks Meter: 0
Factory reset doesn't even work, I get "no valid piv block in sp for system"

I just ran mfastboot erase cache and at the command prompt I get:
(bootloader) Failed to erase partition
FAILED: Remote failure

The phone screen says, 'Failed to erase partition cache'

This doesn't sound good.... Is there anyway can get this thing booted?
4th June 2014, 11:53 AM |#3  
OP Junior Member
Thanks Meter: 0
Ah, nevermind, it just keeps getting errors flashing everything. Something with the phone itself is seriously wrong.

I've decided to return it. I think my data is lost.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes