Remove All Ads from XDA
Honor View 10

[Q] [ICS] How I do to use VPN and saved passwords w/o PIN (NOT FREE, PAID SOLUTION)

10 posts
Thanks Meter: 9
By sebastiannielsen, Junior Member on 19th March 2012, 06:06 AM
Post Reply Email Thread
(NO ROOTING REQUIRED. Secure Settings will encourage you to root but skip that, its not neccessary for this trick to work)

I know many, like me that is annoyed that you are FORCED to have a PIN/pattern/password lock when you use secure credentials to manage your VPN connections, and saved passwords for websites and such.

Here is the solution. It requires you to buy a specific app on market, the app is not mine, and is rather expensive, but the app is very useful for other purposes too so its really worth the money.

1: You need to gather these apps:
Secure Settings: (FREE)
Tasker: (6$)

When you're done buying Tasker and downloading Secure Settings, do this:
Enable Device admin for Secure Settings (Settings-->Security-->Device Administrators-->check "Secure Settings").

Initalize data storage. Set the pin to 0000
To initalize data storage, you can set up a VPN connection or save a password. Data storage is successfully initalized, when you no longer can disable PIN protection. (When the topmost 3 alternatives are greyed out). If you still can disable these, data storage is not initalized and is empty.

Now go to Tasker, and set up this:
Tasks -> (+) -> name: "boot"
Add Task: Task->Wait. Set Delay to 30 seconds
Add Task: Plugins->Secure Settings. Edit. Then set Password/PIN to ENABLED, pick the radio button "Pin Code", enter the PIN 0000 in both boxes.
Add Task: Task->Wait. Set Delay to 5 seconds
Add Task: Plugins->Secure Settings. Edit. Then set Password/PIN to DISABLED.
Save the task.

Now go to Profiles, name the profile "boot", select Events->System->Device boot.
Pick the task "boot".
Save, enable tasker - done.
Reboot your phone

NOTE: The device needs about 1-2 minutes to decrypt your saved credentials at boot, during this time, attempting to access VPN settings or saved password will render a password dialog. Just cancel the dialog and wait a little bit more.

The reason you need to set a PIN to 0000 before clearing it, is so Secure Settings can save your current PIN in memory, else it wont decrypt secure storage. It takes some seconds to commit the PIN set, why you need to wait 5 seconds before clearing the PIN. When you clear the PIN after this, Secure Settings will also decrypt your Secure Storage.
The reason of waiting 30 seconds at boot is because Android is extremely busy at startup, so task executing the first 30 seconds isnt reliable, so you need to wait a little before doing anything.

Enjoy your PIN-free, Pattern free, Password free lockscreen on your VPN enabled device with saved website passwords.

(NOTE to android developers: I Really hope you do NOT do anything to this. If the user want to have unsecured credentials storage, let them have. The setup here is pretty complicated so its nothing you do at mistake and then think your phone is protected. Its not a loophole either because you need to know the current PIN/Password to set up this)
The Following 8 Users Say Thank You to sebastiannielsen For This Useful Post: [ View ] Gift sebastiannielsen Ad-Free
25th March 2012, 12:41 AM |#2  
Junior Member
Thanks Meter: 0
Smile qustion re
Hey Sebastian thank you so much. This worked great for me. But I didn't really understand how all this worked.

So, I just wanted to ask you if I can remove the Tasker and the Secure Settings? If i remove them, will the VPN retain the saved login and password, and will I still be to open my phone without pin?

20th June 2012, 03:40 PM |#3  
lonely_nino's Avatar
Junior Member
Flag Tehran
Thanks Meter: 6
Talking free soloution
i was searching for a soloution for this problem and i found this useful topic.
this is the free and easy soloution.
The Following User Says Thank You to lonely_nino For This Useful Post: [ View ] Gift lonely_nino Ad-Free
2nd April 2013, 08:52 AM |#4  
Shiwantha's Avatar
Senior Member
Thanks Meter: 316
Thank you for saving me the trouble.

Working well your method on OS 4.2.1
18th June 2013, 10:11 AM |#5  
Junior Member
Thanks Meter: 0
Thanks Sebastian

Works a treat for me but i do have a Tasker "no active profiles" icon at the top of my note 2

any thoughts?
25th February 2014, 12:11 PM |#6  
D@rKnight's Avatar
Thanks Meter: 0
Thanks ... superb method and great instruction to do it .
20th May 2014, 07:20 AM |#7  
Junior Member
Thanks Meter: 0
this was bugging me for days. I tried to change locksettings.db but samsung security wouldn't let me. Also tried the forgot pattern and signing with google account method but it doesn't work after reboot. You method did the trick. thanks for the solution.
13th June 2014, 05:29 AM |#8  
Junior Member
Thanks Meter: 1
how is it supposed to work?
I followed the instructions.

However on the tasker icon in the top left I see 'No active profiles'

However I do have a profile 'on boot' like described and it is set to 'on' (green icon).

Tasker is enabled.

When I reboot the tablet (nexus 7) it still asks for the pin.

These instructions are missing acceptance criteria so not sure what should happen next.


Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes