Remove All Ads from XDA

[Root] [Guide] Obtain root via towelroot

6 posts
Thanks Meter: 3
Post Reply Email Thread
Getting root on the stock 4.1.2 rom is very simple with towelroot.


[1] Go to on your Relay and click the picture in the middle of the page, it will download an apk to your device.

[2] Install the apk you just download (you may have to allow unknown sources in settings)

[3] Click the make it rain button and wait 15 seconds. Your device will now reboot

[4] You are now rooted!

[5] Optional: Go to the Play Store or this thread and download the latest version of SuperSU.

[6] Optional: Launch the SuperSU app and follow the instructions there. If you do not have a custom recovery installed, do not choose that option for installation.

If you are still having trouble, follow this video. It is for the S5, but it is done exactly the same way!
The Following 3 Users Say Thank You to derpy-net For This Useful Post: [ View ] Gift derpy-net Ad-Free
26th June 2014, 03:25 AM |#2  
Thanks Meter: 22
I was brain-farting after a long day at work and I just couldn't get the Relay rooted using Odin. Switched ports, different cables, CWM, TWRP, side-load whatever .... towelroot got me rooted in two minutes. Would have been 1 minute but I didn't open it after downloading, so I had to do it again to "make it rain".

Of course, then I found out I was not entering download mode correctly using home key+vol down key+pwr key - guess I was so used to hold both vol up and vol down at same time on other phone. So .... didn't need it in the long run, but saved me some time and I donated to developer as well.
20th July 2014, 03:37 PM |#3  
Junior Member
Thanks Meter: 1
Thank you.

I have successfully obtain root and install Super SU using the instructions.

17th December 2014, 03:01 AM |#4  
Junior Member
Thanks Meter: 0
I realize that this is my first post, and that this is a bit of a necro, but I can verify that towelroot worked on my stock Relay SGH-T699, with Android 4.1.2

One thing I should mention is that viewing in Firefox on my phone resulted in just viewing a text file of the .apk instead of saving it as .apk. I had to download it on my PC and transfer it over. After that, it worked as advertised.

I would probably have more posts, but this actually solved my needs without me needing to ask anything.
29th December 2014, 06:22 AM |#5  
Junior Member
Thanks Meter: 0
Worked great for my Relay!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes