[ROOT] TowelRoot - 4.3 & 4.4.2

9,407 posts
Thanks Meter: 6,919
 
By DocHoliday77, Senior Member on 24th June 2014, 09:46 AM
Post Reply Email Thread
Hey everyone! Most of you have probably already heard about this, but for those who have not, I thought I would post up the information.

XDA Recognized Developer @geohot has developed a new root method that so far is working for many, many devices....Including ours!!! And believe me, it just does not get any easier than this!

Check out geohot's original thread here on XDA: I'm throwing a party and you should come **GS5 ROOT THREAD**

Don't forget to at least click his Thanks button, and consider donating to him if you can. There was a bounty started for rooting the Verizon and AT&T S5's, and they finally got their wish! And geohot gets to claim a nearly $19,000 bounty!!! Amazing stuff! For those who may not be familiar with his previous work, he was the first to jailbreak the iPhone/iPod, and if I am not mistaken he did the same with the PS3!


So anyway, you are here to root your device, no? I guess we should get on with it then!

This is confirmed to work on 4.3, NC2 firmware for the T999, as well as 4.3 and 4.4.2 KK firmware for the I747! It should work for the T999V firmware released this morning, and for the upcoming KK updates to the T999/T999L/T999N!



HOW TO ROOT WITH TOWELROOT
Developed By: geohot


Go to http://towelroot.com
Click on the red Lambda symbol to download the towelroot.apk
Install towelroot.apk on your device
Open the app
"make it ra1n"

You are now rooted! But need to follow a couple more steps.
Install Chainfire's SuperSU from the Play Store
Open SuperSu and let it update the su binary
When it asks if you would like to disable Knox, SAY YES!



Note: I tested this on stock unrooted 4.3 firmware. Build NC2. When I told SuperSu to disable Knox it just hung with the spinner going. I just had to close SuperSu, reopen and when prompted again, said yes and it worked just fine.

There you have it! The easiest root method we have ever had for our S3's! Enjoy!
The Following 39 Users Say Thank You to DocHoliday77 For This Useful Post: [ View ] Gift DocHoliday77 Ad-Free
24th June 2014, 09:47 AM |#2  
DocHoliday77's Avatar
OP Senior Member
Flag HuntsVegas!!!
Thanks Meter: 6,919
 
Donate to Me
More
Recently many have reported problems with root after installing SuperSU. Mostly they are issues with updating the binary breaking root. Chainfire knows about this and is working on it, but until he fixes it do not install via the Play Store.

Instead, download and install (as a normal app) SuperSU 2.00 from here.
https://www.androidfilehost.com/?fid=23622183712471997

This should get you guys by until he finds a fix. Sorry for the trouble some of you have had.
The Following 3 Users Say Thank You to DocHoliday77 For This Useful Post: [ View ] Gift DocHoliday77 Ad-Free
24th June 2014, 11:48 AM |#3  
cLogic's Avatar
Senior Member
Flag Montreal
Thanks Meter: 193
 
More
Thumbs up
CONFIRMED .. this worked on My Videotron SGH-T999V with latest stock 4.4.2 firmware (NF1) ... altho with the following notes ...

at first I tried to use the same procedure I used to root 4.3 (twrp 2.7.1.0 recovery, de-knox script, and superSu 1.65) ... but su binary would either fail to update or not survive boot

used latest towel root apk (version 2), but su binary failed to update until after a reboot

now I'm in the process of using root and Titanium to debloat KitKat .. thanks samsung, lol

so far, I don't really notice much difference between kitkat and 4.3 which is kinda odd for a "major" release .. it's actually a letdown

mucho thanks for bringing this to our forum, Doc ... merci bien
The Following 3 Users Say Thank You to cLogic For This Useful Post: [ View ] Gift cLogic Ad-Free
24th June 2014, 05:53 PM |#4  
yeeahnick's Avatar
Senior Member
Thanks Meter: 262
 
More
thank you for this method, unfortunately i only found out about this now and rooted with cf-auto-root last night. Are there are advantages using towelroot instead of cf-auto-root besides that you dont need odin?
24th June 2014, 06:10 PM |#5  
DocHoliday77's Avatar
OP Senior Member
Flag HuntsVegas!!!
Thanks Meter: 6,919
 
Donate to Me
More
In the end, root is root. So no real advantages once you've already done so. This just makes the process extra quick and super easy!
I consider it to be the safest method at this point as well. If for no other reason than it limits the potential for human errors. But it also requires no flashing, which which always carries some risk of its own.


If anyone who has never tripped the warranty bit tries this method, please confirm it does not trip it.
Its been reported not to already on other devices, and I see no reason it would, but its better to have confirmation on each device nonetheless.

And fyi, after flashing stock then running Towelroot, the device status remained "Official" and I could still check for updates until I rebooted. After rebooting it re-runs its check and sets the status to "Custom".
The Following 2 Users Say Thank You to DocHoliday77 For This Useful Post: [ View ] Gift DocHoliday77 Ad-Free
24th June 2014, 09:26 PM |#6  
Junior Member
Thanks Meter: 4
 
More
can verify that it works
25th June 2014, 01:15 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Thumbs up WAY TO GO
Can confirm this works on At&t stock 4.3
25th June 2014, 04:33 PM |#8  
Member
Flag Richmond, VA
Thanks Meter: 5
 
More
This is a wonderful, wonderful thing & may actually get me off my lazy a$$ & get me to finally root...

Many props to @geohot!
25th June 2014, 06:28 PM |#9  
DocHoliday77's Avatar
OP Senior Member
Flag HuntsVegas!!!
Thanks Meter: 6,919
 
Donate to Me
More
Lol! Kinda hard to make excuses to not root now, huh?
25th June 2014, 07:46 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Thanks worked great on my sgh-t999v running stock 4.4.2, it got hung up on disabling knox but after a reset and opening supersu again the message popped up and disabled knox. This is aMAZing
The Following User Says Thank You to northghost For This Useful Post: [ View ] Gift northghost Ad-Free
25th June 2014, 11:16 PM |#11  
Senior Member
Flag Halifax
Thanks Meter: 76
 
More
So I tried Towelroot yesterday with both mine and my wifes S3, I can confirm that it works and didn't have any problems. I've included screenshots from Download Mode and Device Status...All Official!....And most important....DeBloated!!!!

Thanks for the advise Doc
Attached Thumbnails
Click image for larger version

Name:	IMG_20140625_190130.jpg
Views:	3550
Size:	242.2 KB
ID:	2817568   Click image for larger version

Name:	IMG_20140625_190007.jpg
Views:	3524
Size:	258.2 KB
ID:	2817569   Click image for larger version

Name:	Screenshot_2014-06-25-19-18-54.png
Views:	3467
Size:	132.5 KB
ID:	2817585  
Post Reply Subscribe to Thread

Tags
galaxy s3, kitkat, root, t999, towelroot

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes