FORUMS
Remove All Ads from XDA

WM6 A2DP best settings here

3,435 posts
Thanks Meter: 8,156
 
By hardcore, Senior Member on 25th May 2007, 07:13 AM
Post Reply Email Thread
After discussions with Sleuth255, I've done some further testing on the registry settings and found some optimum settings for A2DP. These are applicable to the newer releases of WM6.

Finding #1:

ADD/CHANGE the following values from the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings :
Name: UseJointStereo
Value (DWORD): 1

What this does is enable Joint-Stereo for the SBC codec, which is important and makes the biggest significant change to improve sound quality. (Note: In earlier versions of WM5 and WM6, Joint-Stereo was broken and resulted in a mono-output. This is not the case anymore with the newer WM6 ROMS.)

Further note: Sleuth255 found that some of his A2DP headsets could not work with JS turned on. In that case, you have to set the value to 0 to disable JS (resulting in poorer quality sound with more "hissing").

Finding #2:

REMOVE the following values from the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings if they are present:
- BitPool
- MaxSupportedBitPool

These values are used to manually set limits for the BT stack for the A2DP SBC codec. Previously, it was thought that these values should be set between 38 to 86. But if the values are removed, I think that the BT stack automatically chooses the best BitPool values for maximum quality. I've tried removing these values and the sound quality either improved or at least stayed the same.

[ SUMMARY ]

At this point, you should have only one value in the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings:

UseJointStereo = 1

Your A2DP audio should be very good at this point - almost indistinguishable from a wired headset. However, if you are still unsatisfied with the sound (you may notice some very slight "hissing" or "swishing" sounds on high frequencies of certain songs), you may want to try the optional setting below.

[ OPTIONAL ]

Finding #3:

This is optional, and a matter of preference.

ADD the following value to the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings:
Name: SampleRate
Value (DWORD): 48000 (decimal)

This forces the A2DP stack to send the audio to the headset at 48000Hz instead of the default 44100Hz. For some reason, I find that the 48Khz value makes the "hissing" sounds less obvious. Your findings may vary, as some people may prefer the slightly more forward sound of the original setting. But if you are game, give this a try - one thing for sure is that it definitely changes the sound quality.

To reverse the change, just remove the SampleRate value.

If you make this 3rd optional change, you should have the following values in the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings:

UseJointStereo = 1
SampleRate = 48000

[ Note - Quick tip on registry editing ]

Of course, every registry change needs a soft-reset to take effect. And please take the usual proper care when editing the registry or risk damaging your device.

Find that your settings dont "stick" after a reset?
Make sure you reset the phone like this: After making changes to the registry, exit your registry editor. Then press and hold the power button of your phone for about 5 seconds, a window should pop up asking you if you want to shutdown your phone (click Yes). Once the phone has shut down, press and hold the power button for a few seconds until the phone starts up again.

Happy listening! BTW, I find that Mortplayer is an excellent MP3 player to use with A2DP. It works well with the control buttons on my headset.
 
 
25th May 2007, 02:28 PM |#2  
Senior Member
Flag Globetrotting
Thanks Meter: 0
 
More
Tried steps one and two... YAY! *throws away wired headset* Thanks guys!
25th May 2007, 08:49 PM |#3  
deviusdragger's Avatar
Senior Member
California
Thanks Meter: 60
 
More
Well just when i thought my headset was sounding banging. now im gonna try this. Hope this helps. And awesome job on the findings guys.
25th May 2007, 10:23 PM |#4  
Sleuth255's Avatar
Retired Senior Moderator
Flag Milwaukee
Thanks Meter: 39
 
More
Yeah.... I remember that about bitpool/maxbitpool. Back when A2DP first came out on the Tornado we never set any of these. No values lets it dynamically adjust.

These are great settings btw.
25th May 2007, 10:39 PM |#5  
chrisnash's Avatar
Senior Member
Flag London
Thanks Meter: 7
 
More
Well I thought I was happy with my audio but I've just applied the tweaks and I'm listening to my favourite tracks and the improvement is great. youre right, the hiss has gone and although I hadnt thought it that noticeable before, this is so much cleaner.
I have the latest lsvw rom and and am running the new htc audio manager and I didn't think I would ever hear bass on my tytn!
And now I'm listening to my favourite Stevie Wonder track on wmv lossless in WMP and its fab!!!
Interestingly, I've just checked the reg settings after soft reset and the SampleRate key is gone!
I'll reapply it, soft reset and see what happens.
Many thanks for the info.
25th May 2007, 10:54 PM |#6  
chrisnash's Avatar
Senior Member
Flag London
Thanks Meter: 7
 
More
This time the samplerate stuck and it even better!
26th May 2007, 02:23 AM |#7  
Kikouyou's Avatar
Senior Member
Thanks Meter: 18
 
More
Thanks much, this is outstanding!
26th May 2007, 02:42 AM |#8  
Member
Thanks Meter: 0
 
More
Can post a A2DP patch from the recent WM6 ROM?
Can Sleuth255 or anyone bless us, the poor smartphone users here who still suffer the 'hiss', by posting a A2DP patch from the latest WM6 ROM (like the previous Tornado A2DP patch) to install in our outdated WM5 devices? Please. The entire smartphone community here will thank you, if the patch free us from the terrible 'hiss' problem in WM5 roms.
26th May 2007, 04:03 AM |#9  
Ender666666's Avatar
Senior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by hardcore

Summary:

If you make all 3 changes, you should have the following values in the registry at HKLM\Software\Microsoft\Bluetooth\A2DP\Settings:

UseJointStereo = 1
SampleRate = 48000

PURE BRILLIANCE!!! I tolerated the hiss before as this device was my first with A2DP and I likened it to listening to the radio, but HOT DAMN it sounds fan-freakin'-tastic now!

Can anyone make a CAB file for this to make the edit easier for the general public?
26th May 2007, 04:36 AM |#10  
guapinoy's Avatar
Senior Member
Thanks Meter: 71
 
More
Great job guys!!! Makes my 50 dollar Nextlink spider headphones great No skipping too!
26th May 2007, 05:09 AM |#11  
Sleuth255's Avatar
Retired Senior Moderator
Flag Milwaukee
Thanks Meter: 39
 
More
Quote:
Originally Posted by arunraaj

Can Sleuth255 or anyone bless us, the poor smartphone users here who still suffer the 'hiss', by posting a A2DP patch from the latest WM6 ROM (like the previous Tornado A2DP patch) to install in our outdated WM5 devices? Please. The entire smartphone community here will thank you, if the patch free us from the terrible 'hiss' problem in WM5 roms.

We'd have to graft the entire bt stack onto WM5.... not an impossible task I suppose but not an easy one either....
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes