Remove All Ads from XDA
Honor 9 Lite

Touch Screen "Smudge"

360 posts
Thanks Meter: 15
By dan13l, Senior Member on 9th August 2007, 12:09 PM
Post Reply Email Thread
4th July 2008, 09:41 AM |#131  
erwinsie's Avatar
Senior Member
Thanks Meter: 36
hi just like pheroah said, i can confirm that if you still under warranty, just send it back, they will change the LCD without question. mine is fixed from smudges now. thanks
8th July 2008, 07:17 AM |#132  
piper_indebt's Avatar
Flag Singapore City
Thanks Meter: 1
Hi Everybody, I have my touch for 6 months now, And I have noticed today that I also have that annoying smudge, mine is the same with alexandred's picture, almos 2Cm wide and 3 to 4 CM Long, My Touch is still under warranty I guess, so I will try to work on a replacement. Hope they would fix this or replace with new one. But I have to get my original rom back first I guess.
I didnt have this problem initially, Its only this month I've noticed this blur. I'm suspecting maybe i dropped my phone resulting to this blur, thats the only possible case that I could think of. But then again I might be wrong. will update you guys if my provider (m1 singapore) will do anything to my phone.

Update: Called up M1, they reffered me to HTC Care, So I went there, with my phone, the customer service right away said its not covered in the warranty, and she asked another customer service, different opinion, she said, "Its always like that What" and then they consulted ther technician, and they explained that the smudge/blur is caused by pressure, and that I have to pay some SGD 100 to replace the LCD. So, I got my phone back, just thought of having it replaced if its really gets worst.

BUt any of you guys who got their LCD blurred so bad while your phone is ON got any worst?
4th October 2009, 11:36 PM |#133  
Junior Member
Thanks Meter: 0
hi all,
i recently tried to update my rom to the new onyx 5.2 , but running it on my pc through the active sync. It worked for a while then the phone just went off and its stuck on the windows mobility screen and doesn't seem to want to load the os ...what should i do
6th October 2009, 08:32 PM |#134  
Thanks Meter: 2
seems to be a common problem with the elf. it happened to me ad it seemed the layers of the digitiser had begun to seperate due to sudden temprature change. eventually it stopped responding to touch, fixed it temporaraly by spplying pressure in a freezer lol. have since replaced it with a chinese clone digitiser and its worked fine ever since
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes