Remove All Ads from XDA

Solved: Digitizer/Touchscreen not recognizing well

120 posts
Thanks Meter: 0
By MocciJ, Senior Member on 8th May 2008, 09:51 PM
Post Reply Email Thread
This is a problem partially described here

After convincing myself to change my old digitizer full of scratches I ordered a new one from China. I got it to pass the initial startup tests (the ones that show up when hard resetted) but obiouvsly it was all too easy.

The only zone of the touchscreen that is working well is at the top left - center left. Otherwise I have to 1) press REALLY hard and 2) waiting about 1 sec pressing to get it recognize inputs.

Initially I thought it was some hardware behaviour, maybe related on how the digitizer's ribbon cable was solded; then I've ended in the thread that I linked.

The questions are: it's just a crappy touchscreen or there's somewhat else? It's an hardware or software problem? If that's a soft prob, do I have to upgrade to some other ROM (current is 1.12 ITA) - modify something in the registry - say some magic words? CAOS!!

Oh and I accidentally cracked my relatively better old touchscreen. Trying to unstick it from the LCD with a cutter did't was a good idea. It's ok now, just reduced to many cute little fragments.

Well, duh, hmm, it's morelike a brick now. Please. It's like a son for me
9th May 2008, 08:31 AM |#2  
MocciJ's Avatar
OP Senior Member
Flag Verona
Thanks Meter: 0
I've figured it out
Searching in the registry I've found these keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Drivers\Touch\Pressure Threshold
HKEY_CURRENT_USER\ControlPanel\TouchPanel\Xthreadh old
HKEY_CURRENT_USER\ControlPanel\TouchPanel\Ythreadh old

I messed them up a bit and guess what? Those are the parameters for setting up the touchscreen!

I guess the first key is for set the touch sensibility of the digitizer: low values made it unusable, I assume that higher values set higher sensibility: however I worked only on the other 2 keys.

Changing the values of Xthreadhold and Ythreadhold changed the areas of sensibility of the digitizer: so I extended the sensibility to all the X axis just setting 12 from 4, and so for the Y axis I've raised it to 15.

Now it's functional again!!


(UPDATE): searching further I discovered that PressureThreshold is related to the alignment test: harder the press on the crosses, less sensible the digitizer and viceversa.
31st May 2009, 10:02 PM |#3  
Alex_GP's Avatar
Senior Member
Thanks Meter: 94
Thanks for the discovery!

My O2 Xda Mini was slugish when taping the screen but this fixed it!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes