Remove All Ads from XDA

Internet Sharing suddenly stopped working

153 posts
Thanks Meter: 17
By djlenoir, Senior Member on 4th September 2008, 05:33 PM
Thread Deleted Email Thread
I am running dcd 2.3.2 with radio 3.42.30. Everything was working great until late last week... my Internet Sharing suddenly stopped working. When I say 'stopped working' I mean that it is no longer allowing me to connect via USB to my PC to get internet access. The PC does see it and ActiveSync pops up and when I start Internet Sharing it appears to work, even providing a IP address to the computer. However, it never actually gets 'out' from the phone. On my friend's Vista machine, the little globe never appears on the network icon in the system tray. I tried a hard reset, a couple times, without success. I even pulled the battery for a while to see if that would help. Tried different USB cables. Tried changing the IP from mobile preferred to mobile only. My friend's mogul flashed the same is working, mine just stopped. Any thoughts?

Edit: PIE works until I establish Internet Sharing. Internet Sharing says connected but I don't get out to the internet and PIE will not work giving some message about "Page can not be found" until I disconnect from Internet Sharing.
4th September 2008, 11:19 PM |#2  
djlenoir's Avatar
OP Senior Member
Thanks Meter: 17
I have persevered through the issue and have found a solution. I assumed the problem was likely DNS related because I was connecting fine, it was simply not showing as on the ‘Internet’ in Windows Vista. Once I connected this way with my phone, I was unable to browse even using PIE as I would get an error indicating the page could not be found. A little searching and I came across this DNS ‘speed fix’ post over at ppcgeeks.
I followed the instructions to change the DNS server entries and I was then able to tether just fine. So apparently, DNS was the culprit. However, I am wondering now what my default DNS servers were. I don’t see anything other than on my PC when I check ipconfig information. Is there a utility that I can load on the phone to see what DNS servers I am getting from Sprint?
I would like to see what my friend who is using Sprint and not having a problem is getting also. If it is a Sprint DNS issue, maybe I should let them know about it and what the specific DNS server(s) are that are affected.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes