FORUMS
Remove All Ads from XDA

*** Flash X1 without PC - Micro SD Method ***

2,305 posts
Thanks Meter: 48
 
By jackleung, Recognized Developer on 14th November 2008, 09:43 AM
Post Reply Email Thread
This is useful if you load a bad image and cannot make an activesync connection for RUU flashing method.
This method works for any 6.1 and 6.5, and even radio rom.

*** Some Kingston brand may have problem to use SD method, no solution other than use RUU method ***

0. Make sure x1 is hard-spl first
1. Make sure yr micro-sd is formatted w/ fat-32
2. rename the image file (normally "ruu_signed.nbh") to Kovsimg.nbh, copy that to the micro-sd, and put that it yr X1
3. Make sure X1 is disconnect to your PC to avoid goes to serial mode (AC power source is OK)
4. Bring x1 to boot-loader mode by turning off the x1 completely. Hold the "volume down" button on the right, and hold the power on button until you see the tri-color screen.
5. Then follow the on-screen instruction
The Following User Says Thank You to jackleung For This Useful Post: [ View ]
 
 
14th November 2008, 01:47 PM |#2  
xmoo's Avatar
Retired Recognized Developer
Flag Eindhoven
Thanks Meter: 1,805
 
More
Thx, always using this system.
17th November 2008, 09:20 PM |#3  
tnyynt's Avatar
Retired Senior Moderator
Thanks Meter: 5
 
Donate to Me
More
Exclamation Sticky
Sticked this one!

Edit By Badwolve1: Unstickyed due to lack of posting, but reference in the X1 Thread (Here)
19th November 2008, 06:35 AM |#4  
Junior Member
Thanks Meter: 0
 
More
I am newbie in Windows Mobile system.
Please somebody tell me, what is SPL, and hard spL?
19th November 2008, 08:43 AM |#5  
xmoo's Avatar
Retired Recognized Developer
Flag Eindhoven
Thanks Meter: 1,805
 
More
Quote:
Originally Posted by inuka

I am newbie in Windows Mobile system.
Please somebody tell me, what is SPL, and hard spL?

http://wiki.xda-developers.com/index...20Questions%3F
http://wiki.xda-developers.com/index...gename=HardSPL
21st November 2008, 06:10 AM |#6  
Junior Member
Thanks Meter: 0
 
More
I used this method on my X1 but it keep saying " no image files " then go to serial , any solutions? thx
21st November 2008, 08:25 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by hysf

I used this method on my X1 but it keep saying " no image files " then go to serial , any solutions? thx

I've got the same proplem. Any suggestion?

Thanks!
21st November 2008, 02:21 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I've got it working now, just d/l all the files here and follow the instructions

http://forum.xda-developers.com/show....php?p=2906948

Cheers!
21st November 2008, 03:42 PM |#9  
Senior Member
Thanks Meter: 74
 
More
Quote:
Originally Posted by jackleung

This is useful if you load a bad image and cannot make an activesync connection for RUU flashing method.

0. Make sure x1 is hard-spl first
1. Make sure yr micro-sd is formatted w/ fat-32
2. rename the image file (normally "ruu_signed.nbh") to Kovsimg.nbh, copy that to the micro-sd, and put that it yr X1
3. Bring x1 to boot-loader mode by turning off the x1 completely. Hold the "volume down" button on the right, and hold the power on button until you see the tri-color screen.
4. Then follow the on-screen instruction

How do you format the micro-sd, can we use the card slot provided in laptops, becoause no adapter comes with the set
23rd November 2008, 01:53 AM |#10  
xmoo's Avatar
Retired Recognized Developer
Flag Eindhoven
Thanks Meter: 1,805
 
More
Quote:
Originally Posted by songao

I've got the same proplem. Any suggestion?

Thanks!

This could be a problem with you're ROM language.

My xperia was english, so had no problem. 2 Dutch xperia's had this problem.
Just flashed SPL first, then flashed the english rom. And now the sd card method works on the 2 dutch xperia's.
24th November 2008, 02:14 AM |#11  
nugift's Avatar
Senior Member
Flag Ho Chi Minh City
Thanks Meter: 3
 
More
Quote:
Originally Posted by hysf

I used this method on my X1 but it keep saying " no image files " then go to serial , any solutions? thx

Quote:
Originally Posted by xmoo

This could be a problem with you're ROM language.

My xperia was english, so had no problem. 2 Dutch xperia's had this problem.
Just flashed SPL first, then flashed the english rom. And now the sd card method works on the 2 dutch xperia's.

I also got the same problem when using the rom from this thread http://forum.xda-developers.com/show...04&postcount=1 but the flash of microSD method ran pretty well with this http://forum.xda-developers.com/show...=431218&page=6
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes